aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qscintilla
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2005-09-05 16:53:17 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2005-09-05 16:53:17 +0000
commitec3ff78118bd76039e994bd9e91de2b6a535bb28 (patch)
treea8ef41fbf5ca6ab2de4c1146f48c9edfa501b1c6 /x11-toolkits/qscintilla
parent0968fe26d715b2f62b9c0ac10b3ba24019437c9f (diff)
downloadports-ec3ff78118bd76039e994bd9e91de2b6a535bb28.tar.gz
ports-ec3ff78118bd76039e994bd9e91de2b6a535bb28.zip
Notes
Diffstat (limited to 'x11-toolkits/qscintilla')
-rw-r--r--x11-toolkits/qscintilla/Makefile146
-rw-r--r--x11-toolkits/qscintilla/distinfo4
-rw-r--r--x11-toolkits/qscintilla/files/patch-qscintilla.pro10
-rw-r--r--x11-toolkits/qscintilla/pkg-plist121
4 files changed, 247 insertions, 34 deletions
diff --git a/x11-toolkits/qscintilla/Makefile b/x11-toolkits/qscintilla/Makefile
index 978b0dbaddca..53630a5d1134 100644
--- a/x11-toolkits/qscintilla/Makefile
+++ b/x11-toolkits/qscintilla/Makefile
@@ -5,35 +5,149 @@
# $FreeBSD$
PORTNAME= qscintilla
-PORTVERSION= 1.5.1
-PORTREVISION= 1
+PORTVERSION= 1.6
+PORTREVISION=
CATEGORIES= x11-toolkits
-MASTER_SITES= http://www.river-bank.demon.co.uk/download/snapshots/QScintilla/ \
+MASTER_SITES= http://www.river-bank.demon.co.uk/download/QScintilla/ \
http://freebsd.ricin.com/ports/distfiles/
-DISTNAME= ${PORTNAME}-1.64-gpl-snapshot-20050709
+DISTNAME= ${PORTNAME}-${PORTVERSION}5-gpl-${PORTVERSION}
MAINTAINER= danny@ricin.com
-COMMENT= QT port of scintilla
+COMMENT= QT port of the Scintilla C++ editor class
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
-WRKSRC= ${WRKDIR}/${DISTNAME}/qt
-
USE_X_PREFIX= yes
USE_QT_VER= 3
-CONFIGURE_ENV= QTDIR="${X11BASE}"
MAKE_ENV= QTDIR="${X11BASE}"
INSTALLS_SHLIB= yes
+OPTIONS= DESIGNER_PLUGIN "Install plugin for Qt Designer" on \
+ DOCS "Install documentation" on \
+ EXAMPLES "Install examples" on \
+ LANG_DE "Install German translation" on \
+ LANG_FR "Install French translation" on \
+ LANG_PTBR "Install Brazilian Portuguese translation" on \
+ LANG_RU "Install Russian translation" on
+
+QMAKE= ${LOCALBASE}/bin/qmake
+SPEC= ${LOCALBASE}/share/qt/mkspecs/freebsd-g++
+PLUGINDIR= ${X11BASE}/lib/plugins/designer
+
+.include <bsd.port.pre.mk>
+
+.if defined(NOPORTDOCS) || defined(WITHOUT_DOCS)
+PLIST_SUB+= DOCS="@comment "
+.else
+PLIST_SUB+= DOCS=""
+.endif
+.if defined(WITHOUT_EXAMPLES)
+PLIST_SUB+= EXAMPLES="@comment "
+.else
+PLIST_SUB+= EXAMPLES=""
+.endif
+.if defined(WITHOUT_DESIGNER_PLUGIN)
+PLIST_SUB+= DESIGNER_PLUGIN="@comment "
+.else
+PLIST_SUB+= DESIGNER_PLUGIN=""
+.endif
+.if defined(WITHOUT_LANG_DE)
+PLIST_SUB+= LANG_DE="@comment "
+.else
+PLIST_SUB+= LANG_DE=""
+.endif
+.if defined(WITHOUT_LANG_FR)
+PLIST_SUB+= LANG_FR="@comment "
+.else
+PLIST_SUB+= LANG_FR=""
+.endif
+.if defined(WITHOUT_LANG_PTBR)
+PLIST_SUB+= LANG_PTBR="@comment "
+.else
+PLIST_SUB+= LANG_PTBR=""
+.endif
+.if defined(WITHOUT_LANG_RU)
+PLIST_SUB+= LANG_RU="@comment "
+.else
+PLIST_SUB+= LANG_RU=""
+.endif
+.if defined(WITHOUT_LANG_DE) && defined(WITHOUT_LANG_FR) && defined(WITHOUT_LANG_PTBR) && defined(WITHOUT_LANG_RU)
+PLIST_SUB+= TRANSLATIONS="@comment "
+.else
+PLIST_SUB+= TRANSLATIONS=""
+.endif
+
do-configure:
- cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${LOCALBASE}/bin/qmake \
- -spec ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ qscintilla.pro
+ ( cd ${WRKSRC}/qt && \
+ ${SETENV} ${MAKE_ENV} ${QMAKE} -spec ${SPEC} qscintilla.pro )
+
+post-configure:
+ ( cd ${WRKSRC}/qt && \
+ ${CAT} qscintilla.pro | ${GREP} -v DESTDIR > qscintilla.tmp && \
+ ${CAT} Makefile | ${GREP} -v DEL_FILE | ${GREP} -v MOVE | \
+ ${GREP} -v DESTDIR > Makefile.tmp && \
+ ${MV} qscintilla.tmp qscintilla.pro && \
+ ${MV} Makefile.tmp Makefile && \
+ cd ${WRKSRC}/designer && \
+ ${CAT} designer.pro | ${GREP} -v lqscintilla > designer.tmp && \
+ ${ECHO} "INCPATH += /usr/X11R6/include ../qt" >> \
+ designer.tmp && \
+ ${ECHO} "LIBS += -L../qt -L/usr/X11R6/lib -lqscintilla" >> \
+ designer.tmp && \
+ ${ECHO} "DESTDIR = ." >> designer.tmp && \
+ ${MV} designer.tmp designer.pro )
+
+do-build:
+ ( cd ${WRKSRC}/qt && ${SETENV} ${MAKE_ENV} ${MAKE} )
+
+post-build:
+.if !defined(WITHOUT_DESIGNER_PLUGIN)
+ ( cd ${WRKSRC}/designer && ${SETENV} ${MAKE_ENV} \
+ ${QMAKE} -spec ${SPEC} designer.pro && ${MAKE} )
+.endif
do-install:
- ${INSTALL_DATA} ${WRKSRC}/qextscintilla*.h ${PREFIX}/include
- ${MKDIR} ${DATADIR}/translations
- ${INSTALL_DATA} ${WRKSRC}/qscintilla*.qm ${DATADIR}/translations
- ${INSTALL_DATA} ${WRKSRC}/libqscintilla.so.6.0.0 ${PREFIX}/lib/libqscintilla.so.6
- ${LN} -sf ${PREFIX}/lib/libqscintilla.so.6 ${PREFIX}/lib/libqscintilla.so
+ ( cd ${WRKSRC} && \
+ ${INSTALL_DATA} qt/qextscintilla*.h ${PREFIX}/include && \
+ ${INSTALL_DATA} qt/libqscintilla.so.6.0.0 \
+ ${PREFIX}/lib/libqscintilla.so.6 && \
+ ${LN} -sf ${PREFIX}/lib/libqscintilla.so.6 \
+ ${PREFIX}/lib/libqscintilla.so )
+.if !defined(WITHOUT_DESIGNER_PLUGIN)
+ ( cd ${WRKSRC} && \
+ ${INSTALL_DATA} designer/libqscintillaplugin.so ${PLUGINDIR} )
+.endif
+.if !defined(WITHOUT_LANG_DE) || !defined(WITHOUT_LANG_FR) || !defined(WITHOUT_LANG_PTBR) || !defined(WITHOUT_LANG_RU)
+ ${MKDIR} -m 0755 ${DATADIR}/translations
+.endif
+.if !defined(WITHOUT_LANG_DE)
+ ( cd ${WRKSRC} && \
+ ${INSTALL_DATA} qt/qscintilla_de.qm ${DATADIR}/translations )
+.endif
+.if !defined(WITHOUT_LANG_FR)
+ ( cd ${WRKSRC} && \
+ ${INSTALL_DATA} qt/qscintilla_fr.qm ${DATADIR}/translations )
+.endif
+.if !defined(WITHOUT_LANG_PTBR)
+ ( cd ${WRKSRC} && \
+ ${INSTALL_DATA} qt/qscintilla_ptbr.qm ${DATADIR}/translations )
+.endif
+.if !defined(WITHOUT_LANG_RU)
+ ( cd ${WRKSRC} && \
+ ${INSTALL_DATA} qt/qscintilla_ru.qm ${DATADIR}/translations )
+.endif
+.if !defined(NOPORTDOCS) && !defined(WITHOUT_DOCS)
+ ( cd ${WRKSRC} && \
+ ${MKDIR} -m 0755 ${DOCSDIR}/html ${DOCSDIR}/Scintilla && \
+ ${INSTALL_DATA} ChangeLog NEWS README ${DOCSDIR} && \
+ ${INSTALL_DATA} doc/qscintilla.dxy ${DOCSDIR} && \
+ ${INSTALL_DATA} doc/html/* ${DOCSDIR}/html && \
+ ${INSTALL_DATA} doc/Scintilla/* ${DOCSDIR}/Scintilla )
+.endif
+.if !defined(WITHOUT_EXAMPLES)
+ ( cd ${WRKSRC} && \
+ ${MKDIR} -m 0755 ${EXAMPLESDIR} && \
+ ${INSTALL_DATA} example/* ${EXAMPLESDIR} )
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/qscintilla/distinfo b/x11-toolkits/qscintilla/distinfo
index ba0e39124289..66707ba4904a 100644
--- a/x11-toolkits/qscintilla/distinfo
+++ b/x11-toolkits/qscintilla/distinfo
@@ -1,2 +1,2 @@
-MD5 (qscintilla-1.64-gpl-snapshot-20050709.tar.gz) = ba58240acd0c03a95d7e904f53e1b7b1
-SIZE (qscintilla-1.64-gpl-snapshot-20050709.tar.gz) = 779415
+MD5 (qscintilla-1.65-gpl-1.6.tar.gz) = 8dbebef07cd2c934fbec3ee1bdfecfa3
+SIZE (qscintilla-1.65-gpl-1.6.tar.gz) = 821730
diff --git a/x11-toolkits/qscintilla/files/patch-qscintilla.pro b/x11-toolkits/qscintilla/files/patch-qscintilla.pro
deleted file mode 100644
index 375f283b5543..000000000000
--- a/x11-toolkits/qscintilla/files/patch-qscintilla.pro
+++ /dev/null
@@ -1,10 +0,0 @@
---- qscintilla.pro.orig Sat Aug 2 18:52:07 2003
-+++ qscintilla.pro Sat Aug 2 18:52:11 2003
-@@ -25,7 +25,6 @@
-
- TEMPLATE = lib
- TARGET = qscintilla
--DESTDIR = $(QTDIR)/lib
- CONFIG += qt warn_off release dll thread
- INCLUDEPATH = . ../include ../src
- DEFINES = QEXTSCINTILLA_MAKE_DLL QT SCI_LEXER
diff --git a/x11-toolkits/qscintilla/pkg-plist b/x11-toolkits/qscintilla/pkg-plist
index 5662a02dc1d6..93070ea34b29 100644
--- a/x11-toolkits/qscintilla/pkg-plist
+++ b/x11-toolkits/qscintilla/pkg-plist
@@ -7,24 +7,133 @@ include/qextscintilladocument.h
include/qextscintillaglobal.h
include/qextscintillalexer.h
include/qextscintillalexerbash.h
+include/qextscintillalexerbatch.h
include/qextscintillalexercpp.h
include/qextscintillalexercsharp.h
+include/qextscintillalexercss.h
+include/qextscintillalexerdiff.h
include/qextscintillalexerhtml.h
include/qextscintillalexeridl.h
include/qextscintillalexerjava.h
include/qextscintillalexerjavascript.h
include/qextscintillalexerlua.h
+include/qextscintillalexermakefile.h
include/qextscintillalexerperl.h
include/qextscintillalexerpov.h
+include/qextscintillalexerproperties.h
include/qextscintillalexerpython.h
include/qextscintillalexerruby.h
include/qextscintillalexersql.h
+include/qextscintillalexertex.h
include/qextscintillamacro.h
include/qextscintillaprinter.h
-lib/libqscintilla.so.6
lib/libqscintilla.so
-share/qscintilla/translations/qscintilla_de.qm
-share/qscintilla/translations/qscintilla_fr.qm
-share/qscintilla/translations/qscintilla_ru.qm
-@dirrm share/qscintilla/translations
-@dirrm share/qscintilla
+lib/libqscintilla.so.6
+%%DESIGNER_PLUGIN%%lib/plugins/designer/libqscintillaplugin.so
+%%DOCS%%%%DOCSDIR%%/ChangeLog
+%%DOCS%%%%DOCSDIR%%/NEWS
+%%DOCS%%%%DOCSDIR%%/README
+%%DOCS%%%%DOCSDIR%%/Scintilla/Design.html
+%%DOCS%%%%DOCSDIR%%/Scintilla/Lexer.txt
+%%DOCS%%%%DOCSDIR%%/Scintilla/License.txt
+%%DOCS%%%%DOCSDIR%%/Scintilla/SciBreak.jpg
+%%DOCS%%%%DOCSDIR%%/Scintilla/SciCoding.html
+%%DOCS%%%%DOCSDIR%%/Scintilla/SciRest.jpg
+%%DOCS%%%%DOCSDIR%%/Scintilla/SciTEIco.png
+%%DOCS%%%%DOCSDIR%%/Scintilla/SciWord.jpg
+%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaDoc.html
+%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaDownload.html
+%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaHistory.html
+%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaRelated.html
+%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaToDo.html
+%%DOCS%%%%DOCSDIR%%/Scintilla/ScintillaUsage.html
+%%DOCS%%%%DOCSDIR%%/Scintilla/Steps.html
+%%DOCS%%%%DOCSDIR%%/Scintilla/index.html
+%%DOCS%%%%DOCSDIR%%/html/annotated.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintilla-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintilla.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaAPIs-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaAPIs.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaBase-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaBase.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaCommand-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaCommand.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaCommandSet-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaCommandSet.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaDocument-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaDocument.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexer-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexer.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerBash-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerBash.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerBatch-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerBatch.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerCPP-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerCPP.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerCSS-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerCSS.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerCSharp-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerCSharp.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerDiff-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerDiff.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerHTML-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerHTML.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerIDL-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerIDL.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerJava-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerJava.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerJavaScript-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerJavaScript.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerLua-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerLua.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerMakefile-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerMakefile.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerPOV-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerPOV.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerPerl-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerPerl.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerProperties-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerProperties.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerPython-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerPython.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerRuby-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerRuby.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerSQL-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerSQL.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerTeX-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaLexerTeX.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaMacro-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaMacro.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaPrinter-members.html
+%%DOCS%%%%DOCSDIR%%/html/classQextScintillaPrinter.html
+%%DOCS%%%%DOCSDIR%%/html/dir_000000.html
+%%DOCS%%%%DOCSDIR%%/html/dirs.html
+%%DOCS%%%%DOCSDIR%%/html/doxygen.css
+%%DOCS%%%%DOCSDIR%%/html/doxygen.png
+%%DOCS%%%%DOCSDIR%%/html/functions.html
+%%DOCS%%%%DOCSDIR%%/html/functions_enum.html
+%%DOCS%%%%DOCSDIR%%/html/functions_eval.html
+%%DOCS%%%%DOCSDIR%%/html/functions_func.html
+%%DOCS%%%%DOCSDIR%%/html/hierarchy.html
+%%DOCS%%%%DOCSDIR%%/html/index.html
+%%DOCS%%%%DOCSDIR%%/qscintilla.dxy
+%%EXAMPLES%%%%EXAMPLESDIR%%/License.txt
+%%EXAMPLES%%%%EXAMPLESDIR%%/README
+%%EXAMPLES%%%%EXAMPLESDIR%%/application.cpp
+%%EXAMPLES%%%%EXAMPLESDIR%%/application.h
+%%EXAMPLES%%%%EXAMPLESDIR%%/application.pro
+%%EXAMPLES%%%%EXAMPLESDIR%%/fileopen.xpm
+%%EXAMPLES%%%%EXAMPLESDIR%%/fileprint.xpm
+%%EXAMPLES%%%%EXAMPLESDIR%%/filesave.xpm
+%%EXAMPLES%%%%EXAMPLESDIR%%/main.cpp
+%%LANG_DE%%%%DATADIR%%/translations/qscintilla_de.qm
+%%LANG_FR%%%%DATADIR%%/translations/qscintilla_fr.qm
+%%LANG_PTBR%%%%DATADIR%%/translations/qscintilla_ptbr.qm
+%%LANG_RU%%%%DATADIR%%/translations/qscintilla_ru.qm
+%%DOCS%%@dirrm %%DOCSDIR%%/Scintilla
+%%DOCS%%@dirrm %%DOCSDIR%%/html
+%%DOCS%%@dirrm %%DOCSDIR%%
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%TRANSLATIONS%%@dirrm %%DATADIR%%/translations
+%%TRANSLATIONS%%@dirrm %%DATADIR%%
+%%DESIGNER_PLUGIN%%@unexec /sbin/ldconfig -R