aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt23
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-12-04 03:47:18 +0000
committerWill Andrews <will@FreeBSD.org>2001-12-04 03:47:18 +0000
commit1d206a3483e848f4589962473bdf169313ea740f (patch)
tree269caee3e56d61cd6318b44d85c3ff64b32d57b6 /x11-toolkits/qt23
parentfb2c030e15fb4b426c06fee701c06b7f44c272ab (diff)
downloadports-1d206a3483e848f4589962473bdf169313ea740f.tar.gz
ports-1d206a3483e848f4589962473bdf169313ea740f.zip
Notes
Diffstat (limited to 'x11-toolkits/qt23')
-rw-r--r--x11-toolkits/qt23/Makefile11
-rw-r--r--x11-toolkits/qt23/files/patch-aa33
-rw-r--r--x11-toolkits/qt23/files/patch-designer::Makefile.in12
-rw-r--r--x11-toolkits/qt23/files/patch-designer::mainwindow.cpp32
-rw-r--r--x11-toolkits/qt23/pkg-plist8
5 files changed, 72 insertions, 24 deletions
diff --git a/x11-toolkits/qt23/Makefile b/x11-toolkits/qt23/Makefile
index 4d9ab09216d8..915f399b0f96 100644
--- a/x11-toolkits/qt23/Makefile
+++ b/x11-toolkits/qt23/Makefile
@@ -7,6 +7,7 @@
PORTNAME?= qt
PORTVERSION?= 2.3.1
+PORTREVISION= 1
CATEGORIES?= x11-toolkits
MASTER_SITES= ftp://ftp.trolltech.com/qt/source/ \
ftp://ftp.chg.ru/pub/X11/qt/source/
@@ -18,6 +19,7 @@ MAINTAINER?= kde@FreeBSD.org
LIB_DEPENDS= mng.1:${PORTSDIR}/graphics/libmng \
png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
+BUILD_DEPENDS= objprelink:${PORTSDIR}/devel/objprelink
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_MESA= yes
@@ -75,7 +77,10 @@ pre-fetch:
.endif
.endif
-pre-configure:
+qt-pre-configure:
+ @true
+
+pre-configure: qt-pre-configure
${PERL} -pi -e "s,gcc,${CC},g; s,g\+\+,${CXX},g; \
s,/usr/X11R6,${X11BASE},g; \
s,-fno-exceptions,-fno-exceptions ${CXXFLAGS} -I/usr/include -D_PTH_H_ -D_PTH_PTHREAD_H_ -frerun-cse-after-loop,g" ${CONFIG}
@@ -86,6 +91,10 @@ pre-configure:
s,cp src/moc/moc bin/moc,cp src/moc/moc2 bin/moc2,g; \
s,symlinks src-moc src-mt sub-src sub-tools sub-tutorial sub-examples,symlinks src-moc src-mt sub-src sub-tools,g" \
${WRKSRC}/Makefile
+.if (${PORTNAME} == "qt")
+ ${PERL} -pi -e "s@\$$(MAKE) designer@@g; s@uic \\\@uic@g; \
+ s@\t\tdesigner@@g" ${WRKSRC}/tools/designer/Makefile.in
+.endif
post-configure:
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} symlinks)
diff --git a/x11-toolkits/qt23/files/patch-aa b/x11-toolkits/qt23/files/patch-aa
index a58966744e42..d30908925332 100644
--- a/x11-toolkits/qt23/files/patch-aa
+++ b/x11-toolkits/qt23/files/patch-aa
@@ -1,5 +1,5 @@
---- configs/freebsd-g++-shared Sun Dec 24 02:41:35 2000
-+++ configs/freebsd-g++-shared.new Sun Dec 24 02:42:49 2000
+--- configs/freebsd-g++-shared Wed Jun 13 03:56:43 2001
++++ configs/freebsd-g++-shared.new Sun Dec 2 19:22:52 2001
@@ -6,7 +6,7 @@
# Compiling with support libraries
@@ -18,6 +18,15 @@
SYSCONF_LIBS_QT_OPENGL =
# OpenGL
SYSCONF_LFLAGS_OPENGL = -L/usr/X11R6/lib
+@@ -32,7 +32,7 @@
+ SYSCONF_LIBS_YACC =
+
+ # Linking applications
+-SYSCONF_LINK = g++
++SYSCONF_LINK = objprelink $(OBJECTS) $(OBJMOC) && g++
+ SYSCONF_LFLAGS =
+ SYSCONF_LIBS =
+
@@ -46,7 +46,7 @@
SYSCONF_LIBS_THREAD =
@@ -27,10 +36,18 @@
# UI compiler
SYSCONF_UIC = $(QTDIR)/bin/uic
-@@ -60,1 +60,1 @@
+@@ -57,16 +57,15 @@
+ # - Usually needs to incorporate $(VER_MAJ), $(VER_MIN) and $(VER_PATCH)
+ #
+ SYSCONF_LINK_SHLIB = g++
-SYSCONF_LINK_TARGET_SHARED = lib$(TARGET).so.$(VER_MAJ).$(VER_MIN).$(VER_PATCH)
+-SYSCONF_LINK_LIB_SHARED = $(SYSCONF_LINK_SHLIB) -shared -Wl,-soname,lib$(TARGET).so.$(VER_MAJ) \
+SYSCONF_LINK_TARGET_SHARED = lib$(TARGET).so.$(VER_MAJ)
-@@ -65,6 +65,4 @@
++SYSCONF_LINK_LIB_SHARED = objprelink $(OBJECTS) $(OBJMOC) && \
++ $(SYSCONF_LINK_SHLIB) -shared -Wl,-soname,lib$(TARGET).so.$(VER_MAJ) \
+ $(LFLAGS) -o $(SYSCONF_LINK_TARGET_SHARED) \
+ $(OBJECTS) $(OBJMOC) $(LIBS) && \
+ mv $(SYSCONF_LINK_TARGET_SHARED) $(DESTDIR); \
cd $(DESTDIR) && \
- rm -f lib$(TARGET).so lib$(TARGET).so.$(VER_MAJ) lib$(TARGET).so.$(VER_MAJ).$(VER_MIN); \
- ln -s $(SYSCONF_LINK_TARGET_SHARED) lib$(TARGET).so; \
@@ -39,14 +56,16 @@
+ rm -f lib$(TARGET).so;\
+ ln -s $(SYSCONF_LINK_TARGET_SHARED) lib$(TARGET).so
-@@ -77,8 +75,8 @@
+ # Linking static libraries
+ # - Build the $(TARGET) library, eg. lib$(TARGET).a
+@@ -77,8 +76,8 @@
SYSCONF_LINK_LIB_STATIC = rm -f $(DESTDIR)$(SYSCONF_LINK_TARGET_STATIC) ; \
$(SYSCONF_AR) $(DESTDIR)$(SYSCONF_LINK_TARGET_STATIC) $(OBJECTS) $(OBJMOC)
# Compiling application source
-SYSCONF_CXXFLAGS = -pipe -fno-exceptions -O2
-SYSCONF_CFLAGS = -pipe -fno-exceptions -O2
-+SYSCONF_CXXFLAGS = -DQT_PREFIX=\"${PREFIX}\" -pipe -O -fno-exceptions
-+SYSCONF_CFLAGS = -DQT_PREFIX=\"${PREFIX}\" -pipe -O -fno-exceptions
++SYSCONF_CXXFLAGS = -DQT_PREFIX=\"${PREFIX}\" -pipe -fno-exceptions -O2
++SYSCONF_CFLAGS = -DQT_PREFIX=\"${PREFIX}\" -pipe -fno-exceptions -O2
# Default link type (static linking is still be used where required)
SYSCONF_LINK_LIB = $(SYSCONF_LINK_LIB_SHARED)
SYSCONF_LINK_TARGET = $(SYSCONF_LINK_TARGET_SHARED)
diff --git a/x11-toolkits/qt23/files/patch-designer::Makefile.in b/x11-toolkits/qt23/files/patch-designer::Makefile.in
deleted file mode 100644
index f13ffe614aa8..000000000000
--- a/x11-toolkits/qt23/files/patch-designer::Makefile.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- tools/designer/Makefile.in Wed Jan 31 21:29:47 2001
-+++ tools/designer/Makefile.in.new Sat Feb 3 18:05:34 2001
-@@ -6,8 +6,7 @@
- #############################################################################
-
- SUBDIRS = util \
-- uic \
-- designer
-+ uic
-
- all:
- $(MAKE) util
diff --git a/x11-toolkits/qt23/files/patch-designer::mainwindow.cpp b/x11-toolkits/qt23/files/patch-designer::mainwindow.cpp
new file mode 100644
index 000000000000..eddf54f011d9
--- /dev/null
+++ b/x11-toolkits/qt23/files/patch-designer::mainwindow.cpp
@@ -0,0 +1,32 @@
+--- tools/designer/designer/mainwindow.cpp 2000/11/18 17:50:58 1.1
++++ tools/designer/designer/mainwindow.cpp 2000/11/18 17:53:21
+@@ -125,7 +125,7 @@
+ : QMainWindow( 0, "mainwindow", WType_TopLevel | WDestructiveClose ),
+ #endif
+ grd( 10, 10 ), sGrid( TRUE ), snGrid( TRUE ), restoreConfig( TRUE ), splashScreen( TRUE ),
+- docPath( "$QTDIR/doc/html" ), client( asClient )
++ docPath( QT_PREFIX "/share/doc/qt2/html" ), client( asClient )
+ {
+ self = this;
+ setIcon( PixmapChooser::loadPixmap( "logo" ) );
+@@ -3144,7 +3144,7 @@
+ QMessageBox::information( this, tr( "Create Template" ), tr( "Couldn't create the template" ) );
+ return;
+ }
+- fn.prepend( QString( getenv( "QTDIR" ) ) + "/tools/designer/templates/" );
++ fn.prepend( QT_PREFIX "/share/qt2/designer/templates/" );
+ fn.append( ".ui" );
+ QFile f( fn );
+ if ( !f.open( IO_WriteOnly ) ) {
+@@ -3236,9 +3236,9 @@
+
+ void MainWindow::openHelpForDialog( const QString &dia )
+ {
+- QString manualdir = QString( getenv( "QTDIR" ) ) + "/tools/designer/manual/book1.html";
++ QString manualdir = QT_PREFIX "/share/qt2/designer/manual/book1.html";
+ if ( !QFile::exists( manualdir ) )
+- manualdir = QString( getenv( "QTDIR" ) ) + "/doc/html/designer/book1.html";
++ manualdir = QT_PREFIX "/share/doc/qt2/html/designer/book1.html";
+ QFile file( manualdir );
+ if ( !file.open( IO_ReadOnly ) )
+ return;
diff --git a/x11-toolkits/qt23/pkg-plist b/x11-toolkits/qt23/pkg-plist
index 59ed9b3dfbc1..8b7682a9c868 100644
--- a/x11-toolkits/qt23/pkg-plist
+++ b/x11-toolkits/qt23/pkg-plist
@@ -284,16 +284,16 @@ include/qt2/qwmatrix.h
include/qt2/qworkspace.h
include/qt2/qxml.h
include/qt2/qxt.h
-%%SHARED%%lib/libqtgl.so
-%%SHARED%%lib/libqtgl.so.4
%%SHARED%%lib/libqt2-mt.so
%%SHARED%%lib/libqt2-mt.so.4
-%%STATIC%%lib/libqt2.a
%%SHARED%%lib/libqt2.so
%%SHARED%%lib/libqt2.so.4
-%%STATIC%%lib/libqutil.a
+%%SHARED%%lib/libqtgl.so
+%%SHARED%%lib/libqtgl.so.4
%%SHARED%%lib/libqutil.so
%%SHARED%%lib/libqutil.so.1
+%%STATIC%%lib/libqt2.a
+%%STATIC%%lib/libqutil.a
share/doc/qt2/ANNOUNCE
share/doc/qt2/FAQ
share/doc/qt2/PORTING