aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt23
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-07-29 02:44:58 +0000
committerWill Andrews <will@FreeBSD.org>2000-07-29 02:44:58 +0000
commit7c6b0a6ca67c232e3193583296b01e93dca141d0 (patch)
tree9e447eb977d3bcd634436471bc866293fd9f1989 /x11-toolkits/qt23
parentafd41a13ec53118181a879d55ecf0a8275dccb01 (diff)
downloadports-7c6b0a6ca67c232e3193583296b01e93dca141d0.tar.gz
ports-7c6b0a6ca67c232e3193583296b01e93dca141d0.zip
Notes
Diffstat (limited to 'x11-toolkits/qt23')
-rw-r--r--x11-toolkits/qt23/Makefile52
-rw-r--r--x11-toolkits/qt23/distinfo2
-rw-r--r--x11-toolkits/qt23/pkg-descr2
-rw-r--r--x11-toolkits/qt23/pkg-plist89
4 files changed, 105 insertions, 40 deletions
diff --git a/x11-toolkits/qt23/Makefile b/x11-toolkits/qt23/Makefile
index ec167dc2ee44..70beda5baacc 100644
--- a/x11-toolkits/qt23/Makefile
+++ b/x11-toolkits/qt23/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: qt21
+# New ports collection makefile for: qt22
# Date created: 17 Jul 1999
# Whom: imura@kml.cs.titech.ac.jp
#
@@ -6,49 +6,58 @@
#
PORTNAME= qt
-PORTVERSION= 2.1.1
+PORTVERSION= 20000724A
CATEGORIES= x11-toolkits
-MASTER_SITES= ftp://ftp.trolltech.com/qt/source/
-DISTNAME= ${PORTNAME}-x11-${PORTVERSION}
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= snapshots/current
-MAINTAINER= imura@FreeBSD.org
+MAINTAINER= will@FreeBSD.org
-LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
- jpeg.9:${PORTSDIR}/graphics/jpeg \
- GL.14:${PORTSDIR}/graphics/Mesa3
+LIB_DEPENDS= png.3:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_BZIP2= yes
NO_LATEST_LINK= yes
USE_GMAKE= yes
-INSTALLS_SHLIB= yes
USE_X_PREFIX= yes
USE_NEWGCC= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -system-zlib -system-libpng -system-jpeg -sm \
- -I${LOCALBASE}/include -L${LOCALBASE}/lib
+ -gif -I${LOCALBASE}/include -L${LOCALBASE}/lib
CONFIGURE_ENV= QTDIR=${WRKSRC}
MAKE_ENV= QTDIR=${WRKSRC}
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
CONFIG= ${WRKSRC}/configs/freebsd-g++-shared
-.if defined(QT_GIF_AVAILABLE) || defined(HAVE_UNISYS_LICENSE)
-CONFIGURE_ARGS+=-gif
-RESTRICTED= 'Requires a license from UNISYS'
-.endif
-
.if !defined(NOPORTDOCS)
.include "${.CURDIR}/files/manpages"
.endif
+pre-fetch:
+.if exists(${X11BASE}/lib/libqt2.so.3)
+ @${ECHO} "An older version of QT2 is installed. To avoid clobbering"
+ @${ECHO} "that installation, deinstall it and then install this port."
+ @${ECHO} "Note that this port contains beta-quality source code and"
+ @${ECHO} "must be used only wherever absolutely needed, such as for"
+ @${ECHO} "KDE2 snapshot 20000724A and later."
+ @${FALSE}
+.endif
+
pre-configure:
- @${PERL} -pi -e "s,gcc,${CC},g" ${CONFIG}
- @${PERL} -pi -e "s,g\+\+,${CXX},g" ${CONFIG}
- @${PERL} -pi -e "s,/usr/X11R6,${X11BASE},g" ${CONFIG}
- @${PERL} -pi -e "s,-pipe -O2,${CXXFLAGS},g" ${CONFIG}
+ ${PERL} -pi -e "s,gcc,${CC},g" ${CONFIG}
+ ${PERL} -pi -e "s,g\+\+,${CXX},g" ${CONFIG}
+ ${PERL} -pi -e "s,/usr/X11R6,${X11BASE},g" ${CONFIG}
+ ${PERL} -pi -e "s,-pipe -O2,${CXXFLAGS},g" ${CONFIG}
+ ${PERL} -pi -e "s@VER_MAJ = 2@VER_MAJ = 4@g" ${WRKSRC}/src/Makefile.in
+ ${PERL} -pi -e "s@TARGET = qt@TARGET = qt2@g" ${WRKSRC}/src/Makefile.in
post-configure:
@(cd ${WRKSRC} ; ${GMAKE} symlinks)
+pre-install:
+ @(find ${WRKSRC} -name CVS | xargs rm -rf)
+
do-install:
${MKDIR} ${PREFIX}/include/qt2
(cd ${WRKSRC} ; \
@@ -63,6 +72,7 @@ do-install:
${INSTALL_DATA} lib/libqxt.a ${PREFIX}/lib ; \
${INSTALL_DATA} lib/libqt2.so.3 ${PREFIX}/lib )
${LN} -sf libqt2.so.3 ${PREFIX}/lib/libqt2.so
+ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/qt2/html
(cd ${WRKSRC} ; \
@@ -72,8 +82,6 @@ do-install:
${INSTALL_DATA} PORTING ${PREFIX}/share/doc/qt2 ; \
${INSTALL_DATA} README ${PREFIX}/share/doc/qt2 ; \
${INSTALL_DATA} README.QT ${PREFIX}/share/doc/qt2 ; \
- ${INSTALL_DATA} changes-2.1.0 ${PREFIX}/share/doc/qt2 ; \
- ${INSTALL_DATA} changes-2.1.1 ${PREFIX}/share/doc/qt2 ; \
${INSTALL_DATA} doc/html/* ${PREFIX}/share/doc/qt2/html ; \
${INSTALL_MAN} doc/man/man3/q* ${PREFIX}/man/man3 )
.endif
diff --git a/x11-toolkits/qt23/distinfo b/x11-toolkits/qt23/distinfo
index 9f99089a6828..9b64f04a1e6b 100644
--- a/x11-toolkits/qt23/distinfo
+++ b/x11-toolkits/qt23/distinfo
@@ -1 +1 @@
-MD5 (qt-x11-2.1.1.tar.gz) = 4af3035d2ce5ada50faa6a092539efe4
+MD5 (qt-20000724A.tar.bz2) = c7af2fd05a40c47d7d5bdaa1c4f65e0a
diff --git a/x11-toolkits/qt23/pkg-descr b/x11-toolkits/qt23/pkg-descr
index 514320bf8aed..78327aaabb1c 100644
--- a/x11-toolkits/qt23/pkg-descr
+++ b/x11-toolkits/qt23/pkg-descr
@@ -1,5 +1,5 @@
Qt is a toolkit for building a GUI for X in C++. The main
-documentation is in /usr/X11R6/share/doc/qt2 and is also available on
+documentation is in share/doc/qt2 and is also available on
the web.
WWW: http://doc.trolltech.com/
diff --git a/x11-toolkits/qt23/pkg-plist b/x11-toolkits/qt23/pkg-plist
index 39db7f1c4c17..df06f254d50b 100644
--- a/x11-toolkits/qt23/pkg-plist
+++ b/x11-toolkits/qt23/pkg-plist
@@ -4,14 +4,10 @@ bin/moc2
bin/msg2qm
bin/qt20fix
bin/qtrename140
-include/qt2/jri.h
-include/qt2/jri_md.h
-include/qt2/jritypes.h
-include/qt2/npapi.h
-include/qt2/npupp.h
include/qt2/q1xcompatibility.h
include/qt2/qabstractlayout.h
include/qt2/qaccel.h
+include/qt2/qaction.h
include/qt2/qapp.h
include/qt2/qapplication.h
include/qt2/qarray.h
@@ -29,6 +25,7 @@ include/qt2/qbuffer.h
include/qt2/qbutton.h
include/qt2/qbuttongroup.h
include/qt2/qcache.h
+include/qt2/qcanvas.h
include/qt2/qcdestyle.h
include/qt2/qcheckbox.h
include/qt2/qchkbox.h
@@ -41,6 +38,10 @@ include/qt2/qcolordialog.h
include/qt2/qcombo.h
include/qt2/qcombobox.h
include/qt2/qcommonstyle.h
+include/qt2/qcompactstyle.h
+include/qt2/qconfig-embedded.h
+include/qt2/qconfig-minimal.h
+include/qt2/qconfig.h
include/qt2/qconnect.h
include/qt2/qconnection.h
include/qt2/qcstring.h
@@ -48,27 +49,29 @@ include/qt2/qcursor.h
include/qt2/qdatastream.h
include/qt2/qdatetime.h
include/qt2/qdatetm.h
+include/qt2/qdial.h
include/qt2/qdialog.h
include/qt2/qdict.h
include/qt2/qdir.h
+include/qt2/qdns.h
include/qt2/qdragobject.h
include/qt2/qdrawutil.h
include/qt2/qdrawutl.h
include/qt2/qdropsite.h
include/qt2/qdstream.h
+include/qt2/qerrormessage.h
include/qt2/qeucjpcodec.h
include/qt2/qeuckrcodec.h
include/qt2/qevent.h
+include/qt2/qfeatures.h
include/qt2/qfile.h
include/qt2/qfiledef.h
-include/qt2/qfiledefs_p.h
include/qt2/qfiledialog.h
include/qt2/qfiledlg.h
include/qt2/qfileinf.h
include/qt2/qfileinfo.h
include/qt2/qfocusdata.h
include/qt2/qfont.h
-include/qt2/qfontdata_p.h
include/qt2/qfontdatabase.h
include/qt2/qfontdialog.h
include/qt2/qfontdta.h
@@ -77,6 +80,7 @@ include/qt2/qfontinfo.h
include/qt2/qfontmet.h
include/qt2/qfontmetrics.h
include/qt2/qframe.h
+include/qt2/qftp.h
include/qt2/qgarray.h
include/qt2/qgbkcodec.h
include/qt2/qgcache.h
@@ -95,6 +99,7 @@ include/qt2/qhbox.h
include/qt2/qhbuttongroup.h
include/qt2/qheader.h
include/qt2/qhgroupbox.h
+include/qt2/qhostaddress.h
include/qt2/qiconset.h
include/qt2/qiconview.h
include/qt2/qimage.h
@@ -111,7 +116,6 @@ include/qt2/qkeycode.h
include/qt2/qkoi8codec.h
include/qt2/qlabel.h
include/qt2/qlayout.h
-include/qt2/qlayoutengine_p.h
include/qt2/qlcdnum.h
include/qt2/qlcdnumber.h
include/qt2/qlined.h
@@ -130,12 +134,14 @@ include/qt2/qmetaobj.h
include/qt2/qmetaobject.h
include/qt2/qmime.h
include/qt2/qmlined.h
+include/qt2/qmngio.h
include/qt2/qmotifstyle.h
include/qt2/qmovie.h
include/qt2/qmsgbox.h
include/qt2/qmultilinedit.h
include/qt2/qmultilineedit.h
include/qt2/qnamespace.h
+include/qt2/qnetwork.h
include/qt2/qnetworkprotocol.h
include/qt2/qnp.h
include/qt2/qobjcoll.h
@@ -162,6 +168,7 @@ include/qt2/qpngio.h
include/qt2/qpntarry.h
include/qt2/qpoint.h
include/qt2/qpointarray.h
+include/qt2/qpolygonscanner.h
include/qt2/qpopmenu.h
include/qt2/qpopupmenu.h
include/qt2/qprintdialog.h
@@ -171,7 +178,6 @@ include/qt2/qprogbar.h
include/qt2/qprogdlg.h
include/qt2/qprogressbar.h
include/qt2/qprogressdialog.h
-include/qt2/qpsprinter_p.h
include/qt2/qpsprn.h
include/qt2/qptrdict.h
include/qt2/qpushbt.h
@@ -184,14 +190,15 @@ include/qt2/qrangect.h
include/qt2/qrect.h
include/qt2/qregexp.h
include/qt2/qregion.h
-include/qt2/qrichtext_p.h
include/qt2/qrtlcodec.h
include/qt2/qscrbar.h
include/qt2/qscrollbar.h
include/qt2/qscrollview.h
include/qt2/qsemimodal.h
+include/qt2/qserversocket.h
include/qt2/qsession.h
include/qt2/qsessionmanager.h
+include/qt2/qsgistyle.h
include/qt2/qshared.h
include/qt2/qsignal.h
include/qt2/qsignalmapper.h
@@ -203,9 +210,12 @@ include/qt2/qsizepolicy.h
include/qt2/qsjiscodec.h
include/qt2/qslider.h
include/qt2/qsmartptr.h
+include/qt2/qsocket.h
+include/qt2/qsocketdevice.h
include/qt2/qsocketnotifier.h
include/qt2/qsocknot.h
include/qt2/qsortedlist.h
+include/qt2/qsound.h
include/qt2/qspinbox.h
include/qt2/qsplitter.h
include/qt2/qstack.h
@@ -216,6 +226,7 @@ include/qt2/qstrlist.h
include/qt2/qstrvec.h
include/qt2/qstyle.h
include/qt2/qstylesheet.h
+include/qt2/qt.h
include/qt2/qt_x11.h
include/qt2/qtabbar.h
include/qt2/qtabdialog.h
@@ -227,12 +238,14 @@ include/qt2/qtextbrowser.h
include/qt2/qtextcodec.h
include/qt2/qtextstream.h
include/qt2/qtextview.h
+include/qt2/qthread.h
include/qt2/qtimer.h
include/qt2/qtl.h
include/qt2/qtoolbar.h
include/qt2/qtoolbutton.h
include/qt2/qtooltip.h
include/qt2/qtranslator.h
+include/qt2/qtsciicodec.h
include/qt2/qtstream.h
include/qt2/qurl.h
include/qt2/qurlinfo.h
@@ -246,7 +259,6 @@ include/qt2/qvbox.h
include/qt2/qvbuttongroup.h
include/qt2/qvector.h
include/qt2/qvgroupbox.h
-include/qt2/qwellarray_p.h
include/qt2/qwhatsthis.h
include/qt2/qwidcoll.h
include/qt2/qwidget.h
@@ -262,8 +274,7 @@ include/qt2/qwmatrix.h
include/qt2/qworkspace.h
include/qt2/qxt.h
lib/libqgl.a
-lib/libqt2.so
-lib/libqt2.so.3
+lib/libqt2.so.4
lib/libqxt.a
share/doc/qt2/ANNOUNCE
share/doc/qt2/FAQ
@@ -271,8 +282,7 @@ share/doc/qt2/LICENSE.QPL
share/doc/qt2/PORTING
share/doc/qt2/README
share/doc/qt2/README.QT
-share/doc/qt2/changes-2.1.0
-share/doc/qt2/changes-2.1.1
+share/doc/qt2/html/HOWTO-framebuffer.html
share/doc/qt2/html/aboutqt.html
share/doc/qt2/html/abstractwidgets.html
share/doc/qt2/html/accelerators.html
@@ -323,9 +333,10 @@ share/doc/qt2/html/easteregg2.html
share/doc/qt2/html/environment.html
share/doc/qt2/html/eventsandfilters.html
share/doc/qt2/html/examples.html
+share/doc/qt2/html/face.png
+share/doc/qt2/html/features.html
share/doc/qt2/html/fileiconview-main-cpp.html
share/doc/qt2/html/focus.html
-share/doc/qt2/html/fontmatch.html
share/doc/qt2/html/forever-forever-cpp.html
share/doc/qt2/html/frames.png
share/doc/qt2/html/functions.html
@@ -349,6 +360,7 @@ share/doc/qt2/html/iconview-main-cpp.html
share/doc/qt2/html/images.html
share/doc/qt2/html/index
share/doc/qt2/html/index.html
+share/doc/qt2/html/installation.html
share/doc/qt2/html/io.html
share/doc/qt2/html/keyfeatures21.html
share/doc/qt2/html/layout-layout-cpp.html
@@ -390,10 +402,16 @@ share/doc/qt2/html/primes.html
share/doc/qt2/html/progress-progress-cpp.html
share/doc/qt2/html/progressbar-main-cpp.html
share/doc/qt2/html/properties.html
+share/doc/qt2/html/propertyindex
share/doc/qt2/html/qabstractlayout-h.html
share/doc/qt2/html/qaccel-h.html
share/doc/qt2/html/qaccel-members.html
share/doc/qt2/html/qaccel.html
+share/doc/qt2/html/qaction-h.html
+share/doc/qt2/html/qaction-members.html
+share/doc/qt2/html/qaction.html
+share/doc/qt2/html/qactiongroup-members.html
+share/doc/qt2/html/qactiongroup.html
share/doc/qt2/html/qapplication-h.html
share/doc/qt2/html/qapplication-members.html
share/doc/qt2/html/qapplication.html
@@ -445,6 +463,31 @@ share/doc/qt2/html/qcache-members.html
share/doc/qt2/html/qcache.html
share/doc/qt2/html/qcacheiterator-members.html
share/doc/qt2/html/qcacheiterator.html
+share/doc/qt2/html/qcanvas-h.html
+share/doc/qt2/html/qcanvas-members.html
+share/doc/qt2/html/qcanvas.html
+share/doc/qt2/html/qcanvasellipse-members.html
+share/doc/qt2/html/qcanvasellipse.html
+share/doc/qt2/html/qcanvasitem-members.html
+share/doc/qt2/html/qcanvasitem.html
+share/doc/qt2/html/qcanvasline-members.html
+share/doc/qt2/html/qcanvasline.html
+share/doc/qt2/html/qcanvaspixmap-members.html
+share/doc/qt2/html/qcanvaspixmap.html
+share/doc/qt2/html/qcanvaspixmaparray-members.html
+share/doc/qt2/html/qcanvaspixmaparray.html
+share/doc/qt2/html/qcanvaspolygon-members.html
+share/doc/qt2/html/qcanvaspolygon.html
+share/doc/qt2/html/qcanvaspolygonalitem-members.html
+share/doc/qt2/html/qcanvaspolygonalitem.html
+share/doc/qt2/html/qcanvasrectangle-members.html
+share/doc/qt2/html/qcanvasrectangle.html
+share/doc/qt2/html/qcanvassprite-members.html
+share/doc/qt2/html/qcanvassprite.html
+share/doc/qt2/html/qcanvastext-members.html
+share/doc/qt2/html/qcanvastext.html
+share/doc/qt2/html/qcanvasview-members.html
+share/doc/qt2/html/qcanvasview.html
share/doc/qt2/html/qcdestyle-h.html
share/doc/qt2/html/qcdestyle-members.html
share/doc/qt2/html/qcdestyle.html
@@ -525,8 +568,11 @@ share/doc/qt2/html/qdate.html
share/doc/qt2/html/qdatetime-h.html
share/doc/qt2/html/qdatetime-members.html
share/doc/qt2/html/qdatetime.html
+share/doc/qt2/html/qdial-h.html
share/doc/qt2/html/qdial-m.png
+share/doc/qt2/html/qdial-members.html
share/doc/qt2/html/qdial-w.png
+share/doc/qt2/html/qdial.html
share/doc/qt2/html/qdialog-h.html
share/doc/qt2/html/qdialog-members.html
share/doc/qt2/html/qdialog.html
@@ -971,6 +1017,9 @@ share/doc/qt2/html/qsemimodal.html
share/doc/qt2/html/qsessionmanager-h.html
share/doc/qt2/html/qsessionmanager-members.html
share/doc/qt2/html/qsessionmanager.html
+share/doc/qt2/html/qsgistyle-h.html
+share/doc/qt2/html/qsgistyle-members.html
+share/doc/qt2/html/qsgistyle.html
share/doc/qt2/html/qshared-h.html
share/doc/qt2/html/qshared-members.html
share/doc/qt2/html/qshared.html
@@ -1007,6 +1056,9 @@ share/doc/qt2/html/qsocketnotifier.html
share/doc/qt2/html/qsortedlist-h.html
share/doc/qt2/html/qsortedlist-members.html
share/doc/qt2/html/qsortedlist.html
+share/doc/qt2/html/qsound-h.html
+share/doc/qt2/html/qsound-members.html
+share/doc/qt2/html/qsound.html
share/doc/qt2/html/qspaceritem-members.html
share/doc/qt2/html/qspaceritem.html
share/doc/qt2/html/qspinbox-h.html
@@ -1200,6 +1252,7 @@ share/doc/qt2/html/qxtapplication-members.html
share/doc/qt2/html/qxtapplication.html
share/doc/qt2/html/qxtwidget-members.html
share/doc/qt2/html/qxtwidget.html
+share/doc/qt2/html/rangecontrols-main-cpp.html
share/doc/qt2/html/removed20.html
share/doc/qt2/html/richtext-main-cpp.html
share/doc/qt2/html/rintersect.png
@@ -1216,6 +1269,7 @@ share/doc/qt2/html/shclass.html
share/doc/qt2/html/showimg-main-cpp.html
share/doc/qt2/html/signalsandslots.html
share/doc/qt2/html/simple-application.html
+share/doc/qt2/html/smooth.png
share/doc/qt2/html/splitter-splitter-cpp.html
share/doc/qt2/html/splitter-views-m.png
share/doc/qt2/html/splitter-views-w.png
@@ -1318,8 +1372,11 @@ share/doc/qt2/html/ttlogo-small.png
share/doc/qt2/html/tutorial.html
share/doc/qt2/html/tutorial.png
share/doc/qt2/html/unicode.html
+share/doc/qt2/html/unsmooth.png
share/doc/qt2/html/validator-main-cpp.html
+share/doc/qt2/html/whatsthis
share/doc/qt2/html/whatsthis.png
+share/doc/qt2/html/winsystem.html
share/doc/qt2/html/wizard-main-cpp.html
share/doc/qt2/html/xform-xform-cpp.html
share/doc/qt2/html/xt.html