aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt30/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-04-25 18:25:44 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-04-25 18:25:44 +0000
commitf10ac6098cb05cc7fd97b13a92e5f530a2e08a51 (patch)
tree8b2973f20d2639bc6262a464703fa6490eebb81a /x11-toolkits/qt30/Makefile
parentd3a76d18b49dafb721c7bc511d944677371cfd96 (diff)
Notes
Diffstat (limited to 'x11-toolkits/qt30/Makefile')
-rw-r--r--x11-toolkits/qt30/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/x11-toolkits/qt30/Makefile b/x11-toolkits/qt30/Makefile
index dc35457e7824..a81719e1678c 100644
--- a/x11-toolkits/qt30/Makefile
+++ b/x11-toolkits/qt30/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= qt
PORTVERSION?= 3.0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES?= x11-toolkits
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/3.0/src
@@ -48,4 +48,16 @@ ALL_TARGET= symlinks sub-src sub-tools
CFLAGS+= -O0
.endif
+# The following target is necessary if qt30 is installed at the
+# time the port build is started; it is related to the Makefiles
+# having dependencies on these (installed) .prl files. --AlanE
+pre-install:
+ @${INSTALL_DATA} ${WRKSRC}/lib/*.prl ${PREFIX}/lib
+
+# no reason to install CVS dirs
+post-install:
+ @-${RM} -fr ${PREFIX}/doc/html/CVS
+ @-${RM} -fr ${PREFIX}/templates/CVS
+ @-${RM} -fr ${PREFIX}/mkspecs/CVS ${PREFIX}/mkspecs/*/CVS
+
.include <bsd.port.post.mk>