aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt31
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-01-05 06:17:03 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-01-05 06:17:03 +0000
commit51c33146f840418d1775d15ad302c9a840aac98e (patch)
tree0b2dd24803602dcf36e5bc1a538305e9b4bbe1cc /x11-toolkits/qt31
parent9bff6b664b9b600cc44614b0f356f613909af0fd (diff)
downloadports-51c33146f840418d1775d15ad302c9a840aac98e.tar.gz
ports-51c33146f840418d1775d15ad302c9a840aac98e.zip
Notes
Diffstat (limited to 'x11-toolkits/qt31')
-rw-r--r--x11-toolkits/qt31/Makefile2
-rw-r--r--x11-toolkits/qt31/files/patch-al31
-rw-r--r--x11-toolkits/qt31/files/patch-am23
-rw-r--r--x11-toolkits/qt31/files/patch-an60
-rw-r--r--x11-toolkits/qt31/files/patch-ao85
-rw-r--r--x11-toolkits/qt31/files/patch-ap12
6 files changed, 212 insertions, 1 deletions
diff --git a/x11-toolkits/qt31/Makefile b/x11-toolkits/qt31/Makefile
index e7fc891de579..6c597d5eccc4 100644
--- a/x11-toolkits/qt31/Makefile
+++ b/x11-toolkits/qt31/Makefile
@@ -8,7 +8,7 @@
PORTNAME= qt
PORTVERSION= 2.2.3
.if exists(${X11BASE}/lib/libXft.so) && !defined(NO_AA)
-PORTREVISION= 1
+PORTREVISION= 2
.endif
CATEGORIES= x11-toolkits
MASTER_SITES= ftp://ftp.trolltech.com/qt/source/
diff --git a/x11-toolkits/qt31/files/patch-al b/x11-toolkits/qt31/files/patch-al
new file mode 100644
index 000000000000..a7a86c62bc89
--- /dev/null
+++ b/x11-toolkits/qt31/files/patch-al
@@ -0,0 +1,31 @@
+diff -ur src/kernel/qfont.cpp src/kernel/qfont.cpp
+--- src/kernel/qfont.cpp Wed Oct 4 13:48:48 2000
++++ src/kernel/qfont.cpp Mon Oct 9 11:53:48 2000
+@@ -200,6 +200,8 @@
+ <li> \c QFont::KOI8U - KOI8-U, Cyrillic/Ukrainian, defined in
+ <a href="ftp://ftp.nordu.net/rfc/rfc2319.txt">RFC 2319.</a>
+ <li> \c QFont::AnyCharSet - whatever is handiest.
++ <li> \c QFont::CP_1251, Microsoft Cyrillic encoding
++ <li> \c QFont::PT_154, Paratype Asian Cyrillic encoding
+ <li> \c QFont::Set_Ja, Japanese
+ <li> \c QFont::Set_Ko, Korean
+ <li> \c QFont::Set_Th_TH
+@@ -1016,11 +1018,16 @@
+ result = "iso8859-15";
+ break;
+ case QFont::KOI8R:
+- result = "KOI8-R";
++ result = "koi8-r";
+ break;
+ case QFont::KOI8U:
+- result = "KOI8-U";
++ result = "koi8-u";
+ break;
++ case QFont::CP_1251:
++ result = "cp1251";
++ break;
++ case QFont::PT_154:
++ result = "pt154";
+ case QFont::Set_Ja:
+ result = "Set_Ja";
+ break;
diff --git a/x11-toolkits/qt31/files/patch-am b/x11-toolkits/qt31/files/patch-am
new file mode 100644
index 000000000000..bea22e3b5906
--- /dev/null
+++ b/x11-toolkits/qt31/files/patch-am
@@ -0,0 +1,23 @@
+diff -ur src/kernel/qfont.h src/kernel/qfont.h
+--- src/kernel/qfont.h Wed Oct 4 13:48:48 2000
++++ src/kernel/qfont.h Mon Oct 9 11:53:48 2000
+@@ -70,6 +70,9 @@
+ ISO_8859_14, Latin8 = ISO_8859_14,
+ ISO_8859_15, Latin9 = ISO_8859_15,
+ KOI8R,
++ KOI8U,
++ CP_1251,
++ PT_154,
+ Set_Ja, Set_1 = Set_Ja,
+ Set_Ko,
+ Set_Th_TH,
+@@ -96,8 +99,7 @@
+ KSC_5601,
+ GB_2312,
+ Big5,
+- TSCII,
+- KOI8U
++ TSCII
+ };
+ enum StyleHint { Helvetica, Times, Courier, OldEnglish, System, AnyStyle,
+ SansSerif = Helvetica,
diff --git a/x11-toolkits/qt31/files/patch-an b/x11-toolkits/qt31/files/patch-an
new file mode 100644
index 000000000000..74b1d0cfa126
--- /dev/null
+++ b/x11-toolkits/qt31/files/patch-an
@@ -0,0 +1,60 @@
+diff -ur src/kernel/qfont_x11.cpp src/kernel/qfont_x11.cpp
+--- src/kernel/qfont_x11.cpp Wed Oct 4 13:48:48 2000
++++ src/kernel/qfont_x11.cpp Mon Oct 9 11:59:36 2000
+@@ -324,6 +324,9 @@
+ { "ISO 8859-14", QFont::ISO_8859_14 },
+ { "ISO 8859-15", QFont::ISO_8859_15 },
+ { "KOI8-R", QFont::KOI8R },
++ { "KOI8-U", QFont::KOI8U },
++ { "CP 1251", QFont::CP_1251 },
++ { "PT 154", QFont::PT_154 },
+ { "eucJP", QFont::Set_Ja },
+ { "SJIS", QFont::Set_Ja },
+ { "JIS7", QFont::Set_Ja },
+@@ -337,7 +340,6 @@
+ { "Big5", QFont::Set_Big5 },
+ { "ta_TA.TSCII", QFont::TSCII },
+ { "TSCII", QFont::TSCII },
+- { "KOI8-U", QFont::KOI8U },
+ { 0, /* anything */ QFont::ISO_8859_1 }
+ };
+
+@@ -513,6 +515,12 @@
+ } else if( strcmp( tokens[CharsetRegistry], "koi8" ) == 0 &&
+ strcmp( tokens[CharsetEncoding], "u" ) == 0) {
+ fd->charSet = QFont::KOI8U;
++ } else if( qstrcmp( tokens[CharsetEncoding], "cp1251" ) == 0 ||
++ (qstrcmp( tokens[CharsetEncoding], "1251" ) == 0 ) ) {
++ fd->charSet = QFont::CP_1251;
++ } else if( qstrcmp( tokens[CharsetEncoding], "cp154" ) == 0 ||
++ (qstrcmp( tokens[CharsetEncoding], "154" ) == 0 ) ) {
++ fd->charSet = QFont::PT_154;
+ } else if( qstrcmp( tokens[CharsetRegistry], "tscii" ) == 0 &&
+ qstrcmp( tokens[CharsetEncoding], "0" ) == 0 ) {
+ fd->charSet = QFont::TSCII;
+@@ -1424,11 +1432,23 @@
+ else
+ exactMatch = FALSE;
+ } else if ( charSet() == KOI8U ) {
+- if ( strcmp( tokens[CharsetRegistry], "koi8" ) == 0 &&
+- strcmp( tokens[CharsetEncoding], "u" ) == 0 )
++ if ( qstrcmp( tokens[CharsetRegistry], "koi8" ) == 0 &&
++ qstrcmp( tokens[CharsetEncoding], "u" ) == 0 )
+ score |= CharSetScore;
+ else
+ exactMatch = FALSE;
++ } else if ( charSet() == CP_1251 ) {
++ if (qstrcmp( tokens[CharsetEncoding], "cp1251" ) == 0 ||
++ qstrcmp( tokens[CharsetEncoding], "1251" ) == 0)
++ score |= CharSetScore;
++ else
++ exactMatch = FALSE;
++ } else if ( charSet() == PT_154 ) {
++ if (qstrcmp( tokens[CharsetEncoding], "cp154" ) == 0 ||
++ qstrcmp( tokens[CharsetEncoding], "154" ) == 0)
++ score |= CharSetScore;
++ else
++ exactMatch = FALSE;
+ } else if ( qstrcmp( tokens[CharsetRegistry], "iso8859" ) == 0 &&
+ charSet() >= ISO_8859_1 && charSet() <= ISO_8859_15 ) {
+ int i = 0;
diff --git a/x11-toolkits/qt31/files/patch-ao b/x11-toolkits/qt31/files/patch-ao
new file mode 100644
index 000000000000..58e5fd9dff99
--- /dev/null
+++ b/x11-toolkits/qt31/files/patch-ao
@@ -0,0 +1,85 @@
+diff -ur src/kernel/qfontdatabase.cpp src/kernel/qfontdatabase.cpp
+--- src/kernel/qfontdatabase.cpp Wed Oct 4 13:48:48 2000
++++ src/kernel/qfontdatabase.cpp Mon Oct 9 12:03:01 2000
+@@ -1280,9 +1280,15 @@
+ (qstrcmp( encoding, "r" ) == 0 ||
+ qstrcmp( encoding, "1" ) == 0) ) {
+ return QFont::KOI8R;
+- } else if ( strcmp( registry, "koi8" ) == 0 &&
++ } else if ( qstrcmp( registry, "koi8" ) == 0 &&
+ qstrcmp( encoding, "u" ) == 0) {
+ return QFont::KOI8U;
++ } else if ( qstrcmp( encoding, "cp1251" ) == 0 ||
++ qstrcmp( encoding, "1251" ) == 0) {
++ return QFont::CP_1251;
++ } else if ( qstrcmp( encoding, "cp154" ) == 0 ||
++ qstrcmp( encoding, "154" ) == 0) {
++ return QFont::PT_154;
+ } else if ( qstrcmp( registry, "tscii" ) == 0 &&
+ qstrcmp( encoding, "0" ) == 0 ) {
+ return QFont::TSCII;
+@@ -1334,6 +1340,14 @@
+ return QFont::KOI8R;
+ if ( name == "koi8-u" )
+ return QFont::KOI8U;
++ if ( name == "microsoft-cp1251" )
++ return QFont::CP_1251;
++ if ( name == "windows-1251" )
++ return QFont::CP_1251;
++ if ( name == "paratype-cp154" )
++ return QFont::PT_154;
++ if ( name == "paratype-154" )
++ return QFont::PT_154;
+ if ( name == "tis620-0" )
+ return QFont::TIS620;
+ if ( name == "tscii-0" )
+@@ -1380,6 +1394,10 @@
+ return "koi8-r";
+ case QFont::KOI8U:
+ return "koi8-u";
++ case QFont::CP_1251:
++ return "microsoft-cp1251";
++ case QFont::PT_154:
++ return "paratype-cp154";
+ case QFont::Unicode:
+ return "iso10646-1";
+ default:
+@@ -1448,11 +1466,17 @@
+ name = "French/Finnish/Euro(ISO 8859-15)";
+ break;
+ case QFont::KOI8R:
+- name = "Cyrillic (KOI8-R)";
++ name = "Russian Cyrillic (KOI8-R)";
+ break;
+ case QFont::KOI8U:
+- name = "Ukrainian (KOI8-U)";
++ name = "Ukrainian Cyrillic (KOI8-U)";
+ break;
++ case QFont::CP_1251:
++ name = "Windows Cyrillic (CP 1251)";
++ break;
++ case QFont::PT_154:
++ name = "Asian Cyrillic (PT 154)";
++ break;
+ case QFont::TSCII:
+ name = "Tamil (TSCII)";
+ break;
+@@ -1571,6 +1595,18 @@
+ sample += QChar(0x0436);
+ sample += QChar(0x2560);
+ break;
++ case QFont::CP_1251:
++ sample += QChar(0x0414);
++ sample += QChar(0x0490);
++ sample += QChar(0x040E);
++ sample += QChar(0x20AC);
++ break;
++ case QFont::PT_154:
++ sample += QChar(0x0496);
++ sample += QChar(0x04E8);
++ sample += QChar(0x04D8);
++ sample += QChar(0x04AE);
++ break;
+ case QFont::Unicode:
+ sample = "Aa";
+ sample += QChar(0x01A7); // Latin B
diff --git a/x11-toolkits/qt31/files/patch-ap b/x11-toolkits/qt31/files/patch-ap
new file mode 100644
index 000000000000..593ac76bdbbf
--- /dev/null
+++ b/x11-toolkits/qt31/files/patch-ap
@@ -0,0 +1,12 @@
+diff -ur src/kernel/qpsprinter.cpp src/kernel/qpsprinter.cpp
+--- src/kernel/qpsprinter.cpp Wed Oct 4 13:48:49 2000
++++ src/kernel/qpsprinter.cpp Mon Oct 9 11:53:48 2000
+@@ -1734,2 +1734,4 @@
+ { QFont::KOI8R, 2084 },
++ { QFont::KOI8U, 2088 },
++ { QFont::CP_1251, 2251 },
+ { QFont::ISO_8859_1, 4 },
+@@ -1747,2 +1749,3 @@
+ { QFont::ISO_8859_15, 111 },
++ { QFont::PT_154, 0 },
+ // makeFixedStrings() below assumes that this is last