aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt33/Makefile
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2007-08-01 12:41:43 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2007-08-01 12:41:43 +0000
commita3df7e8d97963f37cbc5d3b03d6666d83be2859a (patch)
tree2dc00867b6f9440c39f1a5493cd93e3163b5b69a /x11-toolkits/qt33/Makefile
parent0374a42edbd373495f21adc7ac38c8bb584dca9a (diff)
Notes
Diffstat (limited to 'x11-toolkits/qt33/Makefile')
-rw-r--r--x11-toolkits/qt33/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/x11-toolkits/qt33/Makefile b/x11-toolkits/qt33/Makefile
index 4cc5f5f9d0ea..e9787fc25c90 100644
--- a/x11-toolkits/qt33/Makefile
+++ b/x11-toolkits/qt33/Makefile
@@ -75,6 +75,8 @@ PACKAGE_COOKIE= ${WRKDIR}/.package_done.${PORTNAME}.${PREFIX:S/\//_/g}
.include <bsd.port.pre.mk>
+PREFIX_REAL!= /bin/realpath ${PREFIX}
+
# The previous Qt port versions installed qmake and qmake's specs under X11BASE
# The new devel/qmake port installs them under LOCALBASE. We can use
# either one here, but we prefer the newer:
@@ -193,8 +195,8 @@ post-build:
@cd ${WRKSRC}/tools/${tool}; ${SETENV} ${MAKE_ENV} ${MAKE}
.endfor
@${RM} -f ${WRKSRC}/doc/html/qmake*
- ${REINPLACE_CMD} -e 's|${PREFIX}/include/q.*h||g' \
- -e 's|${PREFIX}/include/private/q.*h||g' \
+ ${REINPLACE_CMD} -e 's|${PREFIX_REAL}/include/q.*h||g' \
+ -e 's|${PREFIX_REAL}/include/private/q.*h||g' \
${WRKSRC}/src/Makefile
# Work around qmake generated dependencies