aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt33/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2003-09-18 14:57:05 +0000
committerWill Andrews <will@FreeBSD.org>2003-09-18 14:57:05 +0000
commit01ff961210c499a0f1195f744c4e6a1125a932e7 (patch)
tree975326e07f6532f9c7757124222c6b4243184711 /x11-toolkits/qt33/Makefile
parent4e2467eac7941c69822844001476349153afc053 (diff)
downloadports-01ff961210c499a0f1195f744c4e6a1125a932e7.tar.gz
ports-01ff961210c499a0f1195f744c4e6a1125a932e7.zip
Notes
Diffstat (limited to 'x11-toolkits/qt33/Makefile')
-rw-r--r--x11-toolkits/qt33/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/x11-toolkits/qt33/Makefile b/x11-toolkits/qt33/Makefile
index ebfd8ae5f4e8..ac99826d63bd 100644
--- a/x11-toolkits/qt33/Makefile
+++ b/x11-toolkits/qt33/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME?= qt
-PORTVERSION= 3.1.2
-PORTREVISION?= 1
+PORTVERSION= 3.2.1
CATEGORIES?= x11-toolkits
MASTER_SITES= ftp://ftp.trolltech.com/qt/source/ \
ftp://ftp.silug.org/pub/qt/ \
@@ -47,7 +46,7 @@ CONFIGURE_ARGS+=-no-xft
.endif
.if defined(DEBUG)
-CONFIGURE_ARGS+= -debug
+CONFIGURE_ARGS+=-debug
.endif
.if !defined(BUILD_PLUGIN_ONLY)
@@ -138,6 +137,12 @@ post-patch:
${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
@${REINPLACE_CMD} -e 's,release,release thread,' \
${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
+.if ${OSVERSION} > 500016
+ @${REINPLACE_CMD} -e 's,-pthread -D_THREAD_SAFE,${PTHREAD_CFLAGS},' \
+ ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
+ @${REINPLACE_CMD} -e 's,-pthread,${PTHREAD_LIBS},' \
+ ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf
+.endif
.if !defined(BUILD_PLUGIN_ONLY)
@${RM} ${WRKSRC}/mkspecs/freebsd-g++/qmake.conf.bak