aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt33/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-04-27 04:21:38 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-04-27 04:21:38 +0000
commit3915c9854ee3fec8803f8413d37ef2b437d769c2 (patch)
treee6e1c9c1ab05544413f2ceafd2adb19310a7c549 /x11-toolkits/qt33/Makefile
parent8cb2274498ec44642c694083cc1986fe773c7577 (diff)
o Switch to official distribution distfiles instead of using specially
tailored ones o Add patch-aa to handle current not patched distfile (it is already incorporated in repo version) o Uphold hier(7) for documentation installation o Bump PORTREVISION o Fixes sent by [1]. Coordinated by [2] Submitted by: Lauri Watts <lauri@kde.org> [1] Reviewed by: Alan E <ports@geeksrus.net> [2] Approved by: will
Notes
Notes: svn path=/head/; revision=58214
Diffstat (limited to 'x11-toolkits/qt33/Makefile')
-rw-r--r--x11-toolkits/qt33/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/x11-toolkits/qt33/Makefile b/x11-toolkits/qt33/Makefile
index a81719e1678c..96e68a6b64a2 100644
--- a/x11-toolkits/qt33/Makefile
+++ b/x11-toolkits/qt33/Makefile
@@ -7,11 +7,11 @@
PORTNAME?= qt
PORTVERSION?= 3.0.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES?= x11-toolkits
-MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= stable/3.0/src
-DISTNAME= qt-copy-${PORTVERSION}
+MASTER_SITES= ftp://ftp.trolltech.com/qt/source/ \
+ ftp://ftp.chg.ru/pub/X11/qt/source/
+DISTNAME= qt-x11-free-${PORTVERSION}
DIST_SUBDIR= KDE
MAINTAINER?= kde@FreeBSD.org
@@ -20,7 +20,6 @@ LIB_DEPENDS= mng.1:${PORTSDIR}/graphics/libmng \
png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
-#WRKSRC= ${WRKDIR}/qt-copy
QT_PREFIX?= ${PREFIX}
USE_BZIP2= yes
USE_MESA= yes
@@ -34,6 +33,7 @@ CONFIGURE_ARGS= -system-zlib -system-libpng -system-libjpeg -sm -qt-gif \
-enable-iconview -enable-workspace -enable-network \
-enable-canvas -enable-table -enable-xml -remote -static \
-shared -no-nas-sound -no-stl -prefix ${QT_PREFIX} \
+ -docdir ${QT_PREFIX}/share/doc/qt \
-I${LOCALBASE}/include -L${LOCALBASE}/lib
.if !defined(NO_DEBUG)
CONFIGURE_ARGS+= -debug
@@ -48,16 +48,13 @@ ALL_TARGET= symlinks sub-src sub-tools
CFLAGS+= -O0
.endif
+pre-configure:
+ ${RM} -fr ${WRKSRC}/examples ${WRKSRC}/tutorial
+
# The following target is necessary if qt30 is installed at the
# time the port build is started; it is related to the Makefiles
# having dependencies on these (installed) .prl files. --AlanE
pre-install:
@${INSTALL_DATA} ${WRKSRC}/lib/*.prl ${PREFIX}/lib
-# no reason to install CVS dirs
-post-install:
- @-${RM} -fr ${PREFIX}/doc/html/CVS
- @-${RM} -fr ${PREFIX}/templates/CVS
- @-${RM} -fr ${PREFIX}/mkspecs/CVS ${PREFIX}/mkspecs/*/CVS
-
.include <bsd.port.post.mk>