aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt33
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-03-09 19:41:12 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-03-09 19:41:12 +0000
commitf64c6af4f4d0803346188ad60d5055ea8b8d63dc (patch)
treea4ccebaea6c27a0834589e8629dbcdc5ee328c8b /x11-toolkits/qt33
parente96188d0c88794161a4508f2a16698da04fbba36 (diff)
downloadports-f64c6af4f4d0803346188ad60d5055ea8b8d63dc.tar.gz
ports-f64c6af4f4d0803346188ad60d5055ea8b8d63dc.zip
Notes
Diffstat (limited to 'x11-toolkits/qt33')
-rw-r--r--x11-toolkits/qt33/Makefile20
-rw-r--r--x11-toolkits/qt33/distinfo3
-rw-r--r--x11-toolkits/qt33/files/patch-include-qmlined.h9
-rw-r--r--x11-toolkits/qt33/files/patch-qanimationwriter.cpp10
-rw-r--r--x11-toolkits/qt33/files/patch-src-kernel-qfontdatabase_x11.cpp27
-rw-r--r--x11-toolkits/qt33/files/qapplication.cpp.diff74
-rw-r--r--x11-toolkits/qt33/files/qapplication_p.h.diff16
-rw-r--r--x11-toolkits/qt33/files/qapplication_x11.cpp.diff48
-rw-r--r--x11-toolkits/qt33/files/qeffects.cpp.diff23
-rw-r--r--x11-toolkits/qt33/files/qwidget_x11.cpp.diff15
-rw-r--r--x11-toolkits/qt33/pkg-plist42
11 files changed, 77 insertions, 210 deletions
diff --git a/x11-toolkits/qt33/Makefile b/x11-toolkits/qt33/Makefile
index 1bedde1226ec..ff301cbce322 100644
--- a/x11-toolkits/qt33/Makefile
+++ b/x11-toolkits/qt33/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= qt
-PORTVERSION= 3.2.3
+PORTVERSION= 3.3.1
CATEGORIES?= x11-toolkits
MASTER_SITES= ftp://ftp.trolltech.com/qt/source/ \
ftp://ftp.silug.org/pub/qt/ \
@@ -18,11 +18,11 @@ DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
COMMENT= A C++ X GUI toolkit
-IGNORE= This will become the port of QT 3.3.1. Right now it's just a placeholder.
BUILD_DEPENDS= qmake:${PORTSDIR}/devel/qmake
LIB_DEPENDS+= mng.1:${PORTSDIR}/graphics/libmng \
+ audio:${PORTSDIR}/audio/nas \
png.5:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
@@ -38,10 +38,10 @@ NO_FILTER_SHLIBS=yes
CONFIGURE_ARGS+= -system-libpng -system-libjpeg -system-libmng \
-qt-imgfmt-png -qt-imgfmt-jpeg -qt-imgfmt-mng \
- -system-zlib -no-nas-sound -sm -qt-gif -thread \
- -fast -xinerama -no-g++-exceptions -no-stl \
+ -system-zlib -sm -qt-gif -thread -system-nas-sound \
+ -fast -xinerama -no-g++-exceptions -stl -no-nis \
${CUPS} -shared -prefix ${PREFIX} -datadir ${DATADIR} \
- -verbose -docdir ${DOCSDIR} \
+ -verbose -docdir ${DOCSDIR} -tablet -ipv6 \
-plugindir ${PREFIX}/lib/plugins
CONFIGURE_ENV?= ${ECHO} yes | QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
@@ -80,7 +80,7 @@ LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/Xft
CONFIGURE_ARGS+=-no-xft
.endif
-.if defined(DEBUG)
+.if defined(WANT_QT_DEBUG)
CONFIGURE_ARGS+=-debug
.endif
@@ -123,9 +123,17 @@ post-patch:
.if defined(PLATFORM)
@${REINPLACE_CMD} -e 's|$$outpath/bin/qmake|${QTBASE}/bin/qmake|g' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|$$OUTDIR/bin/qmake|${QTBASE}/bin/qmake|g' \
+ ${WRKSRC}/config.tests/unix/endian.test \
+ ${WRKSRC}/config.tests/unix/largefile.test \
+ ${WRKSRC}/config.tests/unix/ptrsize.test
.else
@${REINPLACE_CMD} -e 's|$$outpath/bin/qmake|${LOCALBASE}/bin/qmake|g' \
${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|$$OUTDIR/bin/qmake|${LOCALBASE}/bin/qmake|g' \
+ ${WRKSRC}/config.tests/unix/endian.test \
+ ${WRKSRC}/config.tests/unix/largefile.test \
+ ${WRKSRC}/config.tests/unix/ptrsize.test
.endif
@${REINPLACE_CMD} -e 's|^ cd qmake.*||' ${WRKSRC}/Makefile
diff --git a/x11-toolkits/qt33/distinfo b/x11-toolkits/qt33/distinfo
index 3d346c5edda8..4de0a153a14c 100644
--- a/x11-toolkits/qt33/distinfo
+++ b/x11-toolkits/qt33/distinfo
@@ -1 +1,2 @@
-MD5 (KDE/qt-x11-free-3.2.3.tar.bz2) = cd6df28c81ac00d97d62bd9942b8da03
+MD5 (KDE/qt-x11-free-3.3.1.tar.bz2) = 4e599bedfcb3fe389bc7ec921c476432
+SIZE (KDE/qt-x11-free-3.3.1.tar.bz2) = 14397600
diff --git a/x11-toolkits/qt33/files/patch-include-qmlined.h b/x11-toolkits/qt33/files/patch-include-qmlined.h
deleted file mode 100644
index 822c77855959..000000000000
--- a/x11-toolkits/qt33/files/patch-include-qmlined.h
+++ /dev/null
@@ -1,9 +0,0 @@
---- include/qmlined.h.orig Sat Feb 15 02:26:37 2003
-+++ include/qmlined.h Sat Feb 15 02:27:45 2003
-@@ -22,5 +22,5 @@
- *****************************************************************************/
- #ifndef QMLINED_H
- #define QMLINED_H
--#include "qtmultilineedit.h"
-+#include "qtextedit.h"
- #endif
diff --git a/x11-toolkits/qt33/files/patch-qanimationwriter.cpp b/x11-toolkits/qt33/files/patch-qanimationwriter.cpp
deleted file mode 100644
index 9e7db8a94a02..000000000000
--- a/x11-toolkits/qt33/files/patch-qanimationwriter.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- tools/qvfb/qanimationwriter.cpp.orig Wed Nov 27 02:45:38 2002
-+++ tools/qvfb/qanimationwriter.cpp Wed Nov 27 02:45:56 2002
-@@ -25,6 +25,7 @@
-
- #include <png.h>
- #include <netinet/in.h> // for htonl
-+#include <limits.h>
-
- class QAnimationWriterData {
- public:
diff --git a/x11-toolkits/qt33/files/patch-src-kernel-qfontdatabase_x11.cpp b/x11-toolkits/qt33/files/patch-src-kernel-qfontdatabase_x11.cpp
new file mode 100644
index 000000000000..b58f36156fad
--- /dev/null
+++ b/x11-toolkits/qt33/files/patch-src-kernel-qfontdatabase_x11.cpp
@@ -0,0 +1,27 @@
+--- src/kernel/qfontdatabase_x11.cpp 2004-03-04 17:53:01.000000000 +0100
++++ src/kernel/qfontdatabase_x11.cpp 2004-03-04 17:47:59.000000000 +0100
+@@ -1508,6 +1516,24 @@
+ XftResult res;
+ XftPattern *result =
+ XftFontMatch( QPaintDevice::x11AppDisplay(), fp->screen, pattern, &res );
++#ifdef QT_XFT2
++ if (script == QFont::Latin) {
++ // since we added the Euro char on top, check we actually got the family
++ // we requested. If we didn't get it correctly, remove the Euro from the pattern
++ // and try again.
++ FcChar8 *f;
++ res = FcPatternGetString(result, FC_FAMILY, 0, &f);
++ if (res == FcResultMatch && QString::fromUtf8((char *)f) != family->rawName) {
++ qDebug("trying without Euro");
++ FcPatternDel(pattern, FC_CHARSET);
++ FcCharSet *cs = FcCharSetCreate();
++ QChar sample = sampleCharacter(script);
++ FcCharSetAddChar(cs, sample.unicode());
++ FcPatternAddCharSet(pattern, FC_CHARSET, cs);
++ result = XftFontMatch( QPaintDevice::x11AppDisplay(), fp->screen, pattern, &res );
++ }
++ }
++#endif
+ XftPatternDestroy(pattern);
+
+ // We pass a duplicate to XftFontOpenPattern because either xft font
diff --git a/x11-toolkits/qt33/files/qapplication.cpp.diff b/x11-toolkits/qt33/files/qapplication.cpp.diff
deleted file mode 100644
index b84fd01f8f74..000000000000
--- a/x11-toolkits/qt33/files/qapplication.cpp.diff
+++ /dev/null
@@ -1,74 +0,0 @@
-===================================================================
-RCS file: /home2/webcvs/mirror/qt-copy/src/kernel/qapplication.cpp,v
-retrieving revision 1.61
-retrieving revision 1.62
-diff -u -p -r1.61 -r1.62
---- qt-copy/src/kernel/qapplication.cpp 2002/11/13 16:46:34 1.61
-+++ qt-copy/src/kernel/qapplication.cpp 2002/11/14 08:57:34 1.62
-@@ -3257,6 +3257,66 @@ Q_EXPORT void qt_dispatchEnterLeave( QWi
- }
-
-
-+#ifdef Q_WS_MACX
-+extern QWidget *qt_tryModalHelperMac( QWidget * top ); //qapplication_mac.cpp
-+#endif
-+
-+
-+/*!\internal
-+
-+ Called from qapplication_<platform>.cpp, returns TRUE
-+ if the widget should accept the event.
-+ */
-+bool qt_tryModalHelper( QWidget *widget, QWidget **rettop ) {
-+ QWidget *modal=0, *top=QApplication::activeModalWidget();
-+ if ( rettop ) *rettop = top;
-+
-+ if ( qApp->activePopupWidget() )
-+ return TRUE;
-+
-+#ifdef Q_WS_MACX
-+ top = qt_tryModalHelperMac( top );
-+ if ( rettop ) *rettop = top;
-+#endif
-+
-+ QWidget* groupLeader = widget;
-+ widget = widget->topLevelWidget();
-+
-+ if ( widget->testWFlags(Qt::WShowModal) ) // widget is modal
-+ modal = widget;
-+ if ( !top || modal == top ) // don't block event
-+ return TRUE;
-+
-+ QWidget * p = widget->parentWidget(); // Check if the active modal widget is a parent of our widget
-+ while ( p ) {
-+ if ( p == top )
-+ return TRUE;
-+ p = p->parentWidget();
-+ }
-+
-+ while ( groupLeader && !groupLeader->testWFlags( Qt::WGroupLeader ) )
-+ groupLeader = groupLeader->parentWidget();
-+
-+ if ( groupLeader ) {
-+ // Does groupLeader have a child in qt_modal_stack?
-+ bool unrelated = TRUE;
-+ modal = qt_modal_stack->first();
-+ while (modal && unrelated) {
-+ QWidget* p = modal->parentWidget();
-+ while ( p && p != groupLeader && !p->testWFlags( Qt::WGroupLeader) ) {
-+ p = p->parentWidget();
-+ }
-+ modal = qt_modal_stack->next();
-+ if ( p == groupLeader ) unrelated = FALSE;
-+ }
-+
-+ if ( unrelated )
-+ return TRUE; // don't block event
-+ }
-+ return FALSE;
-+}
-+
-+
- /*!
- Returns the desktop widget (also called the root window).
-
diff --git a/x11-toolkits/qt33/files/qapplication_p.h.diff b/x11-toolkits/qt33/files/qapplication_p.h.diff
deleted file mode 100644
index 8b9268c696b8..000000000000
--- a/x11-toolkits/qt33/files/qapplication_p.h.diff
+++ /dev/null
@@ -1,16 +0,0 @@
-===================================================================
-RCS file: /home2/webcvs/mirror/qt-copy/src/kernel/qapplication_p.h,v
-retrieving revision 1.21
-retrieving revision 1.22
-diff -u -p -r1.21 -r1.22
---- qt-copy/src/kernel/qapplication_p.h 2002/11/13 16:46:34 1.21
-+++ qt-copy/src/kernel/qapplication_p.h 2002/11/14 08:57:34 1.22
-@@ -83,7 +83,6 @@ extern int qt_ncols_option;
-
-
- extern void qt_dispatchEnterLeave( QWidget*, QWidget* );
--
--
-+extern bool qt_tryModalHelper( QWidget *, QWidget ** = 0 );
-
- #endif
diff --git a/x11-toolkits/qt33/files/qapplication_x11.cpp.diff b/x11-toolkits/qt33/files/qapplication_x11.cpp.diff
deleted file mode 100644
index 877de05c5950..000000000000
--- a/x11-toolkits/qt33/files/qapplication_x11.cpp.diff
+++ /dev/null
@@ -1,48 +0,0 @@
-===================================================================
-RCS file: /home2/webcvs/mirror/qt-copy/src/kernel/qapplication_x11.cpp,v
-retrieving revision 1.81
-retrieving revision 1.82
-diff -u -p -r1.81 -r1.82
---- qt-copy/src/kernel/qapplication_x11.cpp 2002/11/13 16:46:34 1.81
-+++ qt-copy/src/kernel/qapplication_x11.cpp 2002/11/14 08:57:34 1.82
-@@ -3691,39 +3691,9 @@ void qt_leave_modal( QWidget *widget )
-
- bool qt_try_modal( QWidget *widget, XEvent *event )
- {
-- if ( qApp->activePopupWidget() )
-+ if ( qt_tryModalHelper( widget ) )
- return TRUE;
-
-- QWidget *modal=0, *top=QApplication::activeModalWidget();
--
-- QWidget* groupLeader = widget;
-- widget = widget->topLevelWidget();
--
-- if ( widget->testWFlags(Qt::WShowModal) ) // widget is modal
-- modal = widget;
-- if ( !top || modal == top ) // don't block event
-- return TRUE;
--
-- while ( groupLeader && !groupLeader->testWFlags( Qt::WGroupLeader ) )
-- groupLeader = groupLeader->parentWidget();
--
-- if ( groupLeader ) {
-- // Does groupLeader have a child in qt_modal_stack?
-- bool unrelated = TRUE;
-- modal = qt_modal_stack->first();
-- while (modal && unrelated) {
-- QWidget* p = modal->parentWidget();
-- while ( p && p != groupLeader && !p->testWFlags( Qt::WGroupLeader) ) {
-- p = p->parentWidget();
-- }
-- modal = qt_modal_stack->next();
-- if ( p == groupLeader ) unrelated = FALSE;
-- }
--
-- if ( unrelated )
-- return TRUE; // don't block event
-- }
--
- bool block_event = FALSE;
- switch ( event->type ) {
- case ButtonPress: // disallow mouse/key events
diff --git a/x11-toolkits/qt33/files/qeffects.cpp.diff b/x11-toolkits/qt33/files/qeffects.cpp.diff
deleted file mode 100644
index 4ad9ee987455..000000000000
--- a/x11-toolkits/qt33/files/qeffects.cpp.diff
+++ /dev/null
@@ -1,23 +0,0 @@
-===================================================================
-RCS file: /home2/webcvs/mirror/qt-copy/src/widgets/qeffects.cpp,v
-retrieving revision 1.18
-retrieving revision 1.19
-diff -u -p -r1.18 -r1.19
---- qt-copy/src/widgets/qeffects.cpp 2002/10/30 01:54:25 1.18
-+++ qt-copy/src/widgets/qeffects.cpp 2002/11/21 01:30:32 1.19
-@@ -275,6 +275,7 @@ void QAlphaWidget::render()
- q_blend = 0;
- deleteLater();
- } else {
-+ widget->clearWState( WState_ForceHide );
- alphaBlend();
- pm = mixed;
- repaint( FALSE );
-@@ -505,6 +506,7 @@ void QRollEffect::run( int time )
- void QRollEffect::scroll()
- {
- if ( !done ) {
-+ widget->clearWState( WState_ForceHide );
- int tempel = checkTime.elapsed();
- if ( elapsed >= tempel )
- elapsed++;
diff --git a/x11-toolkits/qt33/files/qwidget_x11.cpp.diff b/x11-toolkits/qt33/files/qwidget_x11.cpp.diff
deleted file mode 100644
index de7fa1e41c6f..000000000000
--- a/x11-toolkits/qt33/files/qwidget_x11.cpp.diff
+++ /dev/null
@@ -1,15 +0,0 @@
-===================================================================
-RCS file: /home2/webcvs/mirror/qt-copy/src/kernel/qwidget_x11.cpp,v
-retrieving revision 1.55
-retrieving revision 1.56
-diff -u -p -r1.55 -r1.56
---- qt-copy/src/kernel/qwidget_x11.cpp 2002/11/13 16:46:35 1.55
-+++ qt-copy/src/kernel/qwidget_x11.cpp 2002/11/13 17:28:42 1.56
-@@ -1561,7 +1561,6 @@ void QWidget::showMinimized()
- else {
- topData()->showMode = 1;
- show();
-- hideChildren( FALSE );
- }
- } else {
- show();
diff --git a/x11-toolkits/qt33/pkg-plist b/x11-toolkits/qt33/pkg-plist
index 4bf476a3cffd..58888125ffc4 100644
--- a/x11-toolkits/qt33/pkg-plist
+++ b/x11-toolkits/qt33/pkg-plist
@@ -17,7 +17,6 @@ include/private/qapplication_p.h
include/private/qcolor_p.h
include/private/qcom_p.h
include/private/qcomlibrary_p.h
-include/private/qcomplextext_p.h
include/private/qcomponentfactory_p.h
include/private/qcriticalsection_p.h
include/private/qdialogbuttons_p.h
@@ -29,13 +28,16 @@ include/private/qfontcodecs_p.h
include/private/qfontdata_p.h
include/private/qfontengine_p.h
include/private/qgfxdriverinterface_p.h
+include/private/qgl_x11_p.h
include/private/qgpluginmanager_p.h
include/private/qimageformatinterface_p.h
include/private/qinputcontext_p.h
include/private/qinternal_p.h
+include/private/qisciicodec_p.h
include/private/qkbddriverinterface_p.h
include/private/qlayoutengine_p.h
include/private/qlibrary_p.h
+include/private/qlocale_p.h
include/private/qlock_p.h
include/private/qmousedriverinterface_p.h
include/private/qmutex_p.h
@@ -53,6 +55,7 @@ include/private/qsqlextension_p.h
include/private/qsqlmanager_p.h
include/private/qstyleinterface_p.h
include/private/qsvgdevice_p.h
+include/private/qsyntaxhighlighter_p.h
include/private/qt_x11_p.h
include/private/qtextcodecinterface_p.h
include/private/qtextengine_p.h
@@ -208,6 +211,7 @@ include/qlineedit.h
include/qlist.h
include/qlistbox.h
include/qlistview.h
+include/qlocale.h
include/qlocalfs.h
include/qmainwindow.h
include/qmap.h
@@ -410,8 +414,8 @@ lib/libqnp.prl
lib/libqt-mt.prl
lib/libqt-mt.so
lib/libqt-mt.so.3
-lib/libqt-mt.so.3.2
-lib/libqt-mt.so.3.2.3
+lib/libqt-mt.so.3.3
+lib/libqt-mt.so.3.3.1
lib/libqui.prl
lib/libqui.so
lib/libqui.so.1
@@ -430,7 +434,12 @@ share/doc/qt/html/abstract-connections.png
share/doc/qt/html/abstractwidgets.html
share/doc/qt/html/accelerators.html
share/doc/qt/html/aclock-example.html
+share/doc/qt/html/activeqt-dotnet.html
share/doc/qt/html/activeqt-examples.html
+share/doc/qt/html/activeqt-tools-dumpdoc.html
+share/doc/qt/html/activeqt-tools-idc.html
+share/doc/qt/html/activeqt-tools-testcon.html
+share/doc/qt/html/activeqt-tools.html
share/doc/qt/html/activeqt.html
share/doc/qt/html/addressbook-example.html
share/doc/qt/html/advanced.html
@@ -810,10 +819,8 @@ share/doc/qt/html/qaxbindable-h.html
share/doc/qt/html/qaxbindable-members.html
share/doc/qt/html/qaxbindable.html
share/doc/qt/html/qaxcontainer-example-qutlook.html
-share/doc/qt/html/qaxcontainer-example-testcon.html
share/doc/qt/html/qaxcontainer-example-webbrowser.html
share/doc/qt/html/qaxcontainer-examples.html
-share/doc/qt/html/qaxcontainer-faq.html
share/doc/qt/html/qaxcontainer.html
share/doc/qt/html/qaxfactory-h.html
share/doc/qt/html/qaxfactory-members.html
@@ -821,6 +828,13 @@ share/doc/qt/html/qaxfactory.html
share/doc/qt/html/qaxobject-h.html
share/doc/qt/html/qaxobject-members.html
share/doc/qt/html/qaxobject.html
+share/doc/qt/html/qaxscript-h.html
+share/doc/qt/html/qaxscript-members.html
+share/doc/qt/html/qaxscript.html
+share/doc/qt/html/qaxscriptengine-members.html
+share/doc/qt/html/qaxscriptengine.html
+share/doc/qt/html/qaxscriptmanager-members.html
+share/doc/qt/html/qaxscriptmanager.html
share/doc/qt/html/qaxserver-demo-hierarchy.html
share/doc/qt/html/qaxserver-demo-menus.html
share/doc/qt/html/qaxserver-demo-multiple.html
@@ -836,7 +850,6 @@ share/doc/qt/html/qaxserver-example-simple.html
share/doc/qt/html/qaxserver-example-tetrax.html
share/doc/qt/html/qaxserver-example-wrapper.html
share/doc/qt/html/qaxserver-examples.html
-share/doc/qt/html/qaxserver-faq.html
share/doc/qt/html/qaxserver.html
share/doc/qt/html/qaxwidget-h.html
share/doc/qt/html/qaxwidget-members.html
@@ -995,6 +1008,7 @@ share/doc/qt/html/qd-helptoolbuttons3.png
share/doc/qt/html/qd-mainwinwzd.png
share/doc/qt/html/qd-mainwinwzdpage2.png
share/doc/qt/html/qd-preface.png
+share/doc/qt/html/qd-preferences-dlg.png
share/doc/qt/html/qdatabrowser-h.html
share/doc/qt/html/qdatabrowser-members.html
share/doc/qt/html/qdatabrowser.html
@@ -1263,6 +1277,8 @@ share/doc/qt/html/qhttpresponseheader-members.html
share/doc/qt/html/qhttpresponseheader.html
share/doc/qt/html/qicondrag-members.html
share/doc/qt/html/qicondrag.html
+share/doc/qt/html/qicondragevent-members.html
+share/doc/qt/html/qicondragevent.html
share/doc/qt/html/qicondragitem-members.html
share/doc/qt/html/qicondragitem.html
share/doc/qt/html/qiconfactory-members.html
@@ -1380,6 +1396,9 @@ share/doc/qt/html/qlistviewitem.html
share/doc/qt/html/qlistviewitemiterator-members.html
share/doc/qt/html/qlistviewitemiterator.html
share/doc/qt/html/qlistviewitems.png
+share/doc/qt/html/qlocale-h.html
+share/doc/qt/html/qlocale-members.html
+share/doc/qt/html/qlocale.html
share/doc/qt/html/qlocalfs-h.html
share/doc/qt/html/qlocalfs-members.html
share/doc/qt/html/qlocalfs.html
@@ -1402,6 +1421,7 @@ share/doc/qt/html/qmake-manual-4.html
share/doc/qt/html/qmake-manual-5.html
share/doc/qt/html/qmake-manual-6.html
share/doc/qt/html/qmake-manual-7.html
+share/doc/qt/html/qmake-manual-8.html
share/doc/qt/html/qmake-manual.html
share/doc/qt/html/qmake.dcf
share/doc/qt/html/qmap-h.html
@@ -1543,6 +1563,9 @@ share/doc/qt/html/qplatinumstyle.html
share/doc/qt/html/qpngimagepacker-members.html
share/doc/qt/html/qpngimagepacker.html
share/doc/qt/html/qpngio-h.html
+share/doc/qt/html/qpocketpcstyle-members.html
+share/doc/qt/html/qpocketpcstyle.html
+share/doc/qt/html/qpocketpcstyle_wce-h.html
share/doc/qt/html/qpoint-h.html
share/doc/qt/html/qpoint-members.html
share/doc/qt/html/qpoint.html
@@ -1822,7 +1845,7 @@ share/doc/qt/html/qt-members.html
share/doc/qt/html/qt-template-lib.html
share/doc/qt/html/qt.dcf
share/doc/qt/html/qt.html
-share/doc/qt/html/qt32-class-chart.png
+share/doc/qt/html/qt33-class-chart.png
share/doc/qt/html/qtab-members.html
share/doc/qt/html/qtab.html
share/doc/qt/html/qtabbar-h.html
@@ -1898,6 +1921,7 @@ share/doc/qt/html/qtimerevent-members.html
share/doc/qt/html/qtimerevent.html
share/doc/qt/html/qtl-qvaluelist-example.html
share/doc/qt/html/qtl.html
+share/doc/qt/html/qtmac-as-native.html
share/doc/qt/html/qtoolbar-h.html
share/doc/qt/html/qtoolbar-members.html
share/doc/qt/html/qtoolbar.html
@@ -2081,7 +2105,6 @@ share/doc/qt/html/rd-image.png
share/doc/qt/html/rd-open.png
share/doc/qt/html/rd-pagetitle.png
share/doc/qt/html/rd-prefedit1.png
-share/doc/qt/html/rd-prefgen1.png
share/doc/qt/html/rd-projset.png
share/doc/qt/html/rd-projset2.png
share/doc/qt/html/rd-replace.png
@@ -2096,6 +2119,7 @@ share/doc/qt/html/rd-template.png
share/doc/qt/html/rd-text.png
share/doc/qt/html/rd-title.png
share/doc/qt/html/rd-tunepalette.png
+share/doc/qt/html/regexptester-example.html
share/doc/qt/html/removed20.html
share/doc/qt/html/richtext-example.html
share/doc/qt/html/rintersect.png
@@ -2354,10 +2378,12 @@ share/qt/templates/Dialog_with_Buttons_(Right).ui
share/qt/templates/Tab_Dialog.ui
translations/assistant_de.qm
translations/qt_ar.qm
+translations/qt_cs.qm
translations/qt_de.qm
translations/qt_fr.qm
translations/qt_iw.qm
translations/qt_ru.qm
+translations/qt_sk.qm
@dirrm translations
@dirrm share/qt/templates
@dirrm share/qt/phrasebooks