aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt4-gui
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-03-04 23:06:13 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-03-04 23:06:13 +0000
commit5d9d0e2d2cfe8bf45186697ec6020fdc0b014143 (patch)
treeb04c5ecbcd8f03dd3d88edad5ca494c1a600f013 /x11-toolkits/qt4-gui
parent84bc960e23f64b7640c3f251f0d8958561856e33 (diff)
downloadports-5d9d0e2d2cfe8bf45186697ec6020fdc0b014143.tar.gz
ports-5d9d0e2d2cfe8bf45186697ec6020fdc0b014143.zip
Notes
Diffstat (limited to 'x11-toolkits/qt4-gui')
-rw-r--r--x11-toolkits/qt4-gui/Makefile2
-rw-r--r--x11-toolkits/qt4-gui/files/patch-CVE-2015-029534
2 files changed, 35 insertions, 1 deletions
diff --git a/x11-toolkits/qt4-gui/Makefile b/x11-toolkits/qt4-gui/Makefile
index cec41e89eb6d..be8ed9f90995 100644
--- a/x11-toolkits/qt4-gui/Makefile
+++ b/x11-toolkits/qt4-gui/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gui
DISTVERSION= ${QT4_VERSION}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-toolkits
PKGNAMEPREFIX= qt4-
diff --git a/x11-toolkits/qt4-gui/files/patch-CVE-2015-0295 b/x11-toolkits/qt4-gui/files/patch-CVE-2015-0295
new file mode 100644
index 000000000000..46249856032c
--- /dev/null
+++ b/x11-toolkits/qt4-gui/files/patch-CVE-2015-0295
@@ -0,0 +1,34 @@
+commit e50aa2252cdd5cb53eef7d8c4503c7edff634f68
+Author: Richard J. Moore <rich@kde.org>
+Date: Tue Feb 24 19:02:35 2015 +0000
+
+ Fix a division by zero when processing malformed BMP files.
+
+ This fixes a division by 0 when processing a maliciously crafted BMP
+ file. No impact beyond DoS.
+
+ Backport of 661f6bfd032dacc62841037732816a583640e187
+
+ Task-number: QTBUG-44547
+ Change-Id: I43f06e752b11cb50669101460902a82b885ae618
+ Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
+
+--- src/gui/image/qbmphandler.cpp
++++ src/gui/image/qbmphandler.cpp
+@@ -319,10 +319,16 @@ static bool read_dib_body(QDataStream &s, const BMP_INFOHDR &bi, int offset, int
+ }
+ } else if (comp == BMP_BITFIELDS && (nbits == 16 || nbits == 32)) {
+ red_shift = calc_shift(red_mask);
++ if (((red_mask >> red_shift) + 1) == 0)
++ return false;
+ red_scale = 256 / ((red_mask >> red_shift) + 1);
+ green_shift = calc_shift(green_mask);
++ if (((green_mask >> green_shift) + 1) == 0)
++ return false;
+ green_scale = 256 / ((green_mask >> green_shift) + 1);
+ blue_shift = calc_shift(blue_mask);
++ if (((blue_mask >> blue_shift) + 1) == 0)
++ return false;
+ blue_scale = 256 / ((blue_mask >> blue_shift) + 1);
+ } else if (comp == BMP_RGB && (nbits == 24 || nbits == 32)) {
+ blue_mask = 0x000000ff;