aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt4pas
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2009-08-14 10:46:23 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2009-08-14 10:46:23 +0000
commit664d16aa1f1f3944781d644472bfaeda8037dee0 (patch)
treed5d76dd3b05d970af6e632aa9c3a511065b4f2ab /x11-toolkits/qt4pas
parent930a098812ff5df9c3faa2950c19a7181073b8d5 (diff)
downloadports-664d16aa1f1f3944781d644472bfaeda8037dee0.tar.gz
ports-664d16aa1f1f3944781d644472bfaeda8037dee0.zip
Notes
Diffstat (limited to 'x11-toolkits/qt4pas')
-rw-r--r--x11-toolkits/qt4pas/Makefile6
-rw-r--r--x11-toolkits/qt4pas/distinfo6
-rw-r--r--x11-toolkits/qt4pas/files/patch-compile_lib.sh16
3 files changed, 17 insertions, 11 deletions
diff --git a/x11-toolkits/qt4pas/Makefile b/x11-toolkits/qt4pas/Makefile
index 9ee62dc3edba..87e5bc702254 100644
--- a/x11-toolkits/qt4pas/Makefile
+++ b/x11-toolkits/qt4pas/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qt4pas
-PORTVERSION= 1.68
+PORTVERSION= 1.70
CATEGORIES= x11-toolkits
MASTER_SITES= http://users.telenet.be/Jan.Van.hijfte/qtforfpc/
DISTNAME= ${PORTNAME}-${PORTVERSION:S/^/V/}_Qt${QT4_VER_MIN}
@@ -16,9 +16,9 @@ COMMENT= Qt4 binding for FreePascal
USE_LDCONFIG= yes
USE_QT_VER= 4
-QT_COMPONENTS= corelib gui
+QT_COMPONENTS= corelib gui network script webkit
-QT4_VER_MIN= 4.4.3
+QT4_VER_MIN= 4.5.0
.include <bsd.port.pre.mk>
diff --git a/x11-toolkits/qt4pas/distinfo b/x11-toolkits/qt4pas/distinfo
index 2f431221a08e..36ce2e0929b2 100644
--- a/x11-toolkits/qt4pas/distinfo
+++ b/x11-toolkits/qt4pas/distinfo
@@ -1,3 +1,3 @@
-MD5 (qt4pas-V1.68_Qt4.4.3.tar.gz) = a1b4d51ab85d38126349ce94dbfc6ca8
-SHA256 (qt4pas-V1.68_Qt4.4.3.tar.gz) = b9b5e2725c221f8feae35407186e58b851481aea08291c7f85c1bf1f8721d668
-SIZE (qt4pas-V1.68_Qt4.4.3.tar.gz) = 352932
+MD5 (qt4pas-V1.70_Qt4.5.0.tar.gz) = 1b44cd72a6c226524a54afe93b68ecb8
+SHA256 (qt4pas-V1.70_Qt4.5.0.tar.gz) = d20c6cf48b854074a5449e621aaf1f3fde7d38f13abb945887ef9b642fcbd01e
+SIZE (qt4pas-V1.70_Qt4.5.0.tar.gz) = 403932
diff --git a/x11-toolkits/qt4pas/files/patch-compile_lib.sh b/x11-toolkits/qt4pas/files/patch-compile_lib.sh
index 04999f268c81..52aaa983ff5a 100644
--- a/x11-toolkits/qt4pas/files/patch-compile_lib.sh
+++ b/x11-toolkits/qt4pas/files/patch-compile_lib.sh
@@ -1,10 +1,16 @@
---- compile_lib.sh 2009-01-21 20:18:56.000000000 -0500
-+++ compile_lib.sh 2009-01-21 20:20:21.000000000 -0500
+--- ./compile_lib.sh.orig 2009-04-20 17:59:59.000000000 +0400
++++ ./compile_lib.sh 2009-07-12 15:18:58.000000000 +0400
+@@ -1,4 +1,4 @@
+-#!/bin/env bash
++#!/bin/env sh
+ # get latest from http://users.telenet.be/Jan.Van.hijfte/qtforfpc/fpcqt4.html
+ # for more info, you can visit the links on above page to FreePascal and Lazarus wiki
+
@@ -7,18 +7,16 @@
# do configure and gmake in that Qt4 dir
NAME=libqt4intf.so
--QTDIR=../qt-x11-opensource-src-4.4.3
+-QTDIR=../qt-all-opensource-src-4.5.0
-INCLUDE_PATH="-I. -I$QTDIR/include -I$QTDIR/include/Qt -I$QTDIR/include/QtGui -I$QTDIR/include/QtCore -Iqlcl "
-LIB_PATH=$QTDIR/lib
-export LD_LIBRARY_PATH=$LIB_PATH
@@ -15,10 +21,10 @@
if [ -e "$LIB_PATH/libQtCore.so.4" ]
then
echo please wait for compile to finish ...
-- g++ -D BINUX $INCLUDE_PATH qtpas.cpp -o libqt4intf.so -shared -fPIC -lQtCore -lQtGui -Xlinker -soname=$NAME -Xlinker --library-path -Xlinker $LIB_PATH
+- g++ -D BINUX $INCLUDE_PATH qtpas.cpp -o libqt4intf.so -shared -fPIC -lQtCore -lQtGui -lQtNetwork -lQtWebKit -Xlinker -soname=$NAME -Xlinker --library-path -Xlinker $LIB_PATH
- echo Showing used Qt libraries when LD_LIBRARY_PATH=$LD_LIBRARY_PATH
- ldd $NAME | grep libQt
-+ %%CXX%% -D BINUX $INCLUDE_PATH qtpas.cpp -o libqt4intf.so -shared -fPIC -lQtCore -lQtGui -Xlinker -soname=$NAME -Xlinker --library-path -Xlinker $LIB_PATH
++ %%CXX%% -D BINUX $INCLUDE_PATH qtpas.cpp -o libqt4intf.so -shared -fPIC -lQtCore -lQtGui -lQtNetwork -lQtWebKit -Xlinker -soname=$NAME -Xlinker --library-path -Xlinker $LIB_PATH
echo stripping library
- strip --strip-all $NAME
+ %%STRIP_CMD%% --strip-all $NAME