aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt4pas
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2009-01-22 02:23:43 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2009-01-22 02:23:43 +0000
commitb2d9dd9782540219f32b1a2d2873c133ae2ebd92 (patch)
tree4e7e9c59f641c236deda5da976b8ca3b5c72f108 /x11-toolkits/qt4pas
parent4e9a8d92238dd4091b225b2a8e5987a57c336926 (diff)
downloadports-b2d9dd9782540219f32b1a2d2873c133ae2ebd92.tar.gz
ports-b2d9dd9782540219f32b1a2d2873c133ae2ebd92.zip
Notes
Diffstat (limited to 'x11-toolkits/qt4pas')
-rw-r--r--x11-toolkits/qt4pas/Makefile41
-rw-r--r--x11-toolkits/qt4pas/distinfo3
-rw-r--r--x11-toolkits/qt4pas/files/patch-compile_lib.sh27
-rw-r--r--x11-toolkits/qt4pas/pkg-descr11
-rw-r--r--x11-toolkits/qt4pas/pkg-plist2
5 files changed, 84 insertions, 0 deletions
diff --git a/x11-toolkits/qt4pas/Makefile b/x11-toolkits/qt4pas/Makefile
new file mode 100644
index 000000000000..9ee62dc3edba
--- /dev/null
+++ b/x11-toolkits/qt4pas/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: qt4pas
+# Date created: 2009-01-20
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qt4pas
+PORTVERSION= 1.68
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://users.telenet.be/Jan.Van.hijfte/qtforfpc/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/^/V/}_Qt${QT4_VER_MIN}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Qt4 binding for FreePascal
+
+USE_LDCONFIG= yes
+USE_QT_VER= 4
+QT_COMPONENTS= corelib gui
+
+QT4_VER_MIN= 4.4.3
+
+.include <bsd.port.pre.mk>
+
+.if ${QT4_VERSION:S/.//g} < ${QT4_VER_MIN:S/.//g}
+IGNORE= Please update your current qt4 version to ${QT4_VER_MIN}
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%QT_INCDIR%%|${QT_INCDIR}|' -e 's|%%QT_LIBDIR%%|${QT_LIBDIR}|g' -e \
+ 's|%%CXX%%|${CXX}|g' -e 's|%%STRIP_CMD%%|${STRIP_CMD}|g' -e 's|bash|sh|g' ${WRKSRC}/compile_lib.sh
+
+do-build:
+ @cd ${WRKSRC} && \
+ ${SH} compile_lib.sh
+
+do-install:
+ @${MKDIR} ${PREFIX}/lib/qt4
+ ${INSTALL_PROGRAM} ${WRKSRC}/libqt4intf.so ${PREFIX}/lib/qt4
+
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/qt4pas/distinfo b/x11-toolkits/qt4pas/distinfo
new file mode 100644
index 000000000000..2f431221a08e
--- /dev/null
+++ b/x11-toolkits/qt4pas/distinfo
@@ -0,0 +1,3 @@
+MD5 (qt4pas-V1.68_Qt4.4.3.tar.gz) = a1b4d51ab85d38126349ce94dbfc6ca8
+SHA256 (qt4pas-V1.68_Qt4.4.3.tar.gz) = b9b5e2725c221f8feae35407186e58b851481aea08291c7f85c1bf1f8721d668
+SIZE (qt4pas-V1.68_Qt4.4.3.tar.gz) = 352932
diff --git a/x11-toolkits/qt4pas/files/patch-compile_lib.sh b/x11-toolkits/qt4pas/files/patch-compile_lib.sh
new file mode 100644
index 000000000000..04999f268c81
--- /dev/null
+++ b/x11-toolkits/qt4pas/files/patch-compile_lib.sh
@@ -0,0 +1,27 @@
+--- compile_lib.sh 2009-01-21 20:18:56.000000000 -0500
++++ compile_lib.sh 2009-01-21 20:20:21.000000000 -0500
+@@ -7,18 +7,16 @@
+ # do configure and gmake in that Qt4 dir
+
+ NAME=libqt4intf.so
+-QTDIR=../qt-x11-opensource-src-4.4.3
+-INCLUDE_PATH="-I. -I$QTDIR/include -I$QTDIR/include/Qt -I$QTDIR/include/QtGui -I$QTDIR/include/QtCore -Iqlcl "
+-LIB_PATH=$QTDIR/lib
+-export LD_LIBRARY_PATH=$LIB_PATH
++QTDIR=%%QT_INCDIR%%
++INCLUDE_PATH="-I. -I$QTDIR -I$QTDIR/Qt -I$QTDIR/QtGui -I$QTDIR/QtCore -Iqlcl "
++LIB_PATH=%%QT_LIBDIR%%
++
+ if [ -e "$LIB_PATH/libQtCore.so.4" ]
+ then
+ echo please wait for compile to finish ...
+- g++ -D BINUX $INCLUDE_PATH qtpas.cpp -o libqt4intf.so -shared -fPIC -lQtCore -lQtGui -Xlinker -soname=$NAME -Xlinker --library-path -Xlinker $LIB_PATH
+- echo Showing used Qt libraries when LD_LIBRARY_PATH=$LD_LIBRARY_PATH
+- ldd $NAME | grep libQt
++ %%CXX%% -D BINUX $INCLUDE_PATH qtpas.cpp -o libqt4intf.so -shared -fPIC -lQtCore -lQtGui -Xlinker -soname=$NAME -Xlinker --library-path -Xlinker $LIB_PATH
+ echo stripping library
+- strip --strip-all $NAME
++ %%STRIP_CMD%% --strip-all $NAME
+ echo Done
+ else
+ echo "Please Modify location of Qt4 in this script"
diff --git a/x11-toolkits/qt4pas/pkg-descr b/x11-toolkits/qt4pas/pkg-descr
new file mode 100644
index 000000000000..b45bbcc473cc
--- /dev/null
+++ b/x11-toolkits/qt4pas/pkg-descr
@@ -0,0 +1,11 @@
+Provide a Qt4 binding for FreePascal that may be of use to provide the Lazarus
+LCL library with a Qt interface
+
+This binding does not aim to cover the whole Qt4 framework, but only just
+enough to satisfy the LCL needs. If any LCL/Qt developer needs an extra class,
+just ask and it will be added promptly. Some of the methods that have parameters
+based upon templates have been omitted.
+
+If however you need any of those, just ask.
+
+WWW: http://users.telenet.be/Jan.Van.hijfte/qtforfpc/fpcqt4.html
diff --git a/x11-toolkits/qt4pas/pkg-plist b/x11-toolkits/qt4pas/pkg-plist
new file mode 100644
index 000000000000..a8bb3299eddf
--- /dev/null
+++ b/x11-toolkits/qt4pas/pkg-plist
@@ -0,0 +1,2 @@
+lib/qt4/libqt4intf.so
+@dirrmtry lib/qt4