aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt5-gui
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2018-01-06 21:30:31 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2018-01-06 21:30:31 +0000
commitf6ceca63504679b05ea4fc24a195a301e2303d1f (patch)
treea6e116c43545a3682fe63db4bdca54e6fb24567e /x11-toolkits/qt5-gui
parent78a4d3df994a008dd752fd82307fd6d31aa18f3a (diff)
downloadports-f6ceca63504679b05ea4fc24a195a301e2303d1f.tar.gz
ports-f6ceca63504679b05ea4fc24a195a301e2303d1f.zip
Notes
Diffstat (limited to 'x11-toolkits/qt5-gui')
-rw-r--r--x11-toolkits/qt5-gui/Makefile8
-rw-r--r--x11-toolkits/qt5-gui/pkg-plist243
2 files changed, 172 insertions, 79 deletions
diff --git a/x11-toolkits/qt5-gui/Makefile b/x11-toolkits/qt5-gui/Makefile
index be27ff85b2c1..4a587942d8e3 100644
--- a/x11-toolkits/qt5-gui/Makefile
+++ b/x11-toolkits/qt5-gui/Makefile
@@ -2,13 +2,13 @@
PORTNAME= gui
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 1
CATEGORIES= x11-toolkits graphics
PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt graphical user interface module
+BUILD_DEPENDS= at-spi2-core>=0:accessibility/at-spi2-core
LIB_DEPENDS= libdbus-1.so:devel/dbus \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
@@ -70,6 +70,12 @@ RUN_DEPENDS+= ${LOCALBASE}/share/fonts/encodings/encodings.dir:x11-fonts/encodin
CFLAGS_powerpc64= -mminimal-toc
+post-configure:
+.for d in src/gui ${MORE_WRKSRCS}
+ ${MKDIR} ${WRKSRC}/${d}
+ cd ${WRKSRC}/${d} && ${SETENV} ${QMAKE_ENV} ${_QMAKE} ${QMAKE_ARGS} ${WRKSRC}/${d}
+.endfor
+
post-build:
.for d in ${MORE_WRKSRCS}
@cd ${WRKSRC}/${d} && \
diff --git a/x11-toolkits/qt5-gui/pkg-plist b/x11-toolkits/qt5-gui/pkg-plist
index d2e3003bc4bc..35200028053b 100644
--- a/x11-toolkits/qt5-gui/pkg-plist
+++ b/x11-toolkits/qt5-gui/pkg-plist
@@ -1,3 +1,65 @@
+%%QT_INCDIR%%/QtAccessibilitySupport/%%FULLVER%%/QtAccessibilitySupport/private/qaccessiblebridgeutils_p.h
+%%QT_INCDIR%%/QtAccessibilitySupport/QtAccessibilitySupport
+%%QT_INCDIR%%/QtAccessibilitySupport/QtAccessibilitySupportDepends
+%%QT_INCDIR%%/QtAccessibilitySupport/QtAccessibilitySupportVersion
+%%QT_INCDIR%%/QtAccessibilitySupport/qtaccessibilitysupportversion.h
+%%QT_INCDIR%%/QtDeviceDiscoverySupport/%%FULLVER%%/QtDeviceDiscoverySupport/private/qdevicediscovery_dummy_p.h
+%%QT_INCDIR%%/QtDeviceDiscoverySupport/%%FULLVER%%/QtDeviceDiscoverySupport/private/qdevicediscovery_p.h
+%%QT_INCDIR%%/QtDeviceDiscoverySupport/%%FULLVER%%/QtDeviceDiscoverySupport/private/qdevicediscovery_static_p.h
+%%QT_INCDIR%%/QtDeviceDiscoverySupport/%%FULLVER%%/QtDeviceDiscoverySupport/private/qdevicediscovery_udev_p.h
+%%QT_INCDIR%%/QtDeviceDiscoverySupport/QtDeviceDiscoverySupport
+%%QT_INCDIR%%/QtDeviceDiscoverySupport/QtDeviceDiscoverySupportDepends
+%%QT_INCDIR%%/QtDeviceDiscoverySupport/QtDeviceDiscoverySupportVersion
+%%QT_INCDIR%%/QtDeviceDiscoverySupport/qtdevicediscoverysupportversion.h
+%%QT_INCDIR%%/QtEglSupport/%%FULLVER%%/QtEglSupport/private/qeglconvenience_p.h
+%%QT_INCDIR%%/QtEglSupport/%%FULLVER%%/QtEglSupport/private/qeglpbuffer_p.h
+%%QT_INCDIR%%/QtEglSupport/%%FULLVER%%/QtEglSupport/private/qeglplatformcontext_p.h
+%%QT_INCDIR%%/QtEglSupport/%%FULLVER%%/QtEglSupport/private/qeglstreamconvenience_p.h
+%%QT_INCDIR%%/QtEglSupport/%%FULLVER%%/QtEglSupport/private/qt_egl_p.h
+%%QT_INCDIR%%/QtEglSupport/%%FULLVER%%/QtEglSupport/private/qxlibeglintegration_p.h
+%%QT_INCDIR%%/QtEglSupport/QtEglSupport
+%%QT_INCDIR%%/QtEglSupport/QtEglSupportDepends
+%%QT_INCDIR%%/QtEglSupport/QtEglSupportVersion
+%%QT_INCDIR%%/QtEglSupport/qteglsupportversion.h
+%%QT_INCDIR%%/QtEventDispatcherSupport/%%FULLVER%%/QtEventDispatcherSupport/private/qeventdispatcher_glib_p.h
+%%QT_INCDIR%%/QtEventDispatcherSupport/%%FULLVER%%/QtEventDispatcherSupport/private/qgenericunixeventdispatcher_p.h
+%%QT_INCDIR%%/QtEventDispatcherSupport/%%FULLVER%%/QtEventDispatcherSupport/private/qunixeventdispatcher_qpa_p.h
+%%QT_INCDIR%%/QtEventDispatcherSupport/%%FULLVER%%/QtEventDispatcherSupport/private/qwindowsguieventdispatcher_p.h
+%%QT_INCDIR%%/QtEventDispatcherSupport/QtEventDispatcherSupport
+%%QT_INCDIR%%/QtEventDispatcherSupport/QtEventDispatcherSupportDepends
+%%QT_INCDIR%%/QtEventDispatcherSupport/QtEventDispatcherSupportVersion
+%%QT_INCDIR%%/QtEventDispatcherSupport/qteventdispatchersupportversion.h
+%%QT_INCDIR%%/QtFbSupport/%%FULLVER%%/QtFbSupport/private/qfbbackingstore_p.h
+%%QT_INCDIR%%/QtFbSupport/%%FULLVER%%/QtFbSupport/private/qfbcursor_p.h
+%%QT_INCDIR%%/QtFbSupport/%%FULLVER%%/QtFbSupport/private/qfbscreen_p.h
+%%QT_INCDIR%%/QtFbSupport/%%FULLVER%%/QtFbSupport/private/qfbvthandler_p.h
+%%QT_INCDIR%%/QtFbSupport/%%FULLVER%%/QtFbSupport/private/qfbwindow_p.h
+%%QT_INCDIR%%/QtFbSupport/QtFbSupport
+%%QT_INCDIR%%/QtFbSupport/QtFbSupportDepends
+%%QT_INCDIR%%/QtFbSupport/QtFbSupportVersion
+%%QT_INCDIR%%/QtFbSupport/qtfbsupportversion.h
+%%QT_INCDIR%%/QtFontDatabaseSupport/%%FULLVER%%/QtFontDatabaseSupport/private/qcoretextfontdatabase_p.h
+%%QT_INCDIR%%/QtFontDatabaseSupport/%%FULLVER%%/QtFontDatabaseSupport/private/qfontconfigdatabase_p.h
+%%QT_INCDIR%%/QtFontDatabaseSupport/%%FULLVER%%/QtFontDatabaseSupport/private/qfontengine_coretext_p.h
+%%QT_INCDIR%%/QtFontDatabaseSupport/%%FULLVER%%/QtFontDatabaseSupport/private/qfontengine_ft_p.h
+%%QT_INCDIR%%/QtFontDatabaseSupport/%%FULLVER%%/QtFontDatabaseSupport/private/qfontenginemultifontconfig_p.h
+%%QT_INCDIR%%/QtFontDatabaseSupport/%%FULLVER%%/QtFontDatabaseSupport/private/qfreetypefontdatabase_p.h
+%%QT_INCDIR%%/QtFontDatabaseSupport/%%FULLVER%%/QtFontDatabaseSupport/private/qgenericunixfontdatabase_p.h
+%%QT_INCDIR%%/QtFontDatabaseSupport/%%FULLVER%%/QtFontDatabaseSupport/private/qwindowsfontdatabase_ft_p.h
+%%QT_INCDIR%%/QtFontDatabaseSupport/%%FULLVER%%/QtFontDatabaseSupport/private/qwindowsfontdatabase_p.h
+%%QT_INCDIR%%/QtFontDatabaseSupport/%%FULLVER%%/QtFontDatabaseSupport/private/qwindowsfontengine_p.h
+%%QT_INCDIR%%/QtFontDatabaseSupport/%%FULLVER%%/QtFontDatabaseSupport/private/qwindowsfontenginedirectwrite_p.h
+%%QT_INCDIR%%/QtFontDatabaseSupport/%%FULLVER%%/QtFontDatabaseSupport/private/qwindowsnativeimage_p.h
+%%QT_INCDIR%%/QtFontDatabaseSupport/%%FULLVER%%/QtFontDatabaseSupport/private/qwinrtfontdatabase_p.h
+%%QT_INCDIR%%/QtFontDatabaseSupport/QtFontDatabaseSupport
+%%QT_INCDIR%%/QtFontDatabaseSupport/QtFontDatabaseSupportDepends
+%%QT_INCDIR%%/QtFontDatabaseSupport/QtFontDatabaseSupportVersion
+%%QT_INCDIR%%/QtFontDatabaseSupport/qtfontdatabasesupportversion.h
+%%QT_INCDIR%%/QtGlxSupport/%%FULLVER%%/QtGlxSupport/private/qglxconvenience_p.h
+%%QT_INCDIR%%/QtGlxSupport/QtGlxSupport
+%%QT_INCDIR%%/QtGlxSupport/QtGlxSupportDepends
+%%QT_INCDIR%%/QtGlxSupport/QtGlxSupportVersion
+%%QT_INCDIR%%/QtGlxSupport/qtglxsupportversion.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qabstractlayoutstyleinfo_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qabstracttextdocumentlayout_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qaccessiblecache_p.h
@@ -6,6 +68,8 @@
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qblittable_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qbmphandler_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qcolor_p.h
+%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qcolorprofile_p.h
+%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qcoregraphics_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qcosmeticstroker_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qcssparser_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qcssutil_p.h
@@ -22,13 +86,11 @@
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qevent_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qfixed_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qfont_p.h
-%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qfontengine_ft_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qfontengine_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qfontengine_qpf2_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qfontengineglyphcache_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qfontsubset_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qfragmentmap_p.h
-%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qgifhandler_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qglyphrun_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qgrayraster_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qgridlayoutengine_p.h
@@ -41,16 +103,15 @@
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qimage_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qimagepixmapcleanuphooks_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qimagescale_p.h
+%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qinputcontrol_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qinputdevicemanager_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qinputdevicemanager_p_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qinputmethod_p.h
-%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qjpeghandler_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qkeymapper_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qkeysequence_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qlayoutpolicy_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qmath_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qmemrotate_p.h
-%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qnativeimage_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopengl2pexvertexarray_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopengl_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopenglcontext_p.h
@@ -62,11 +123,10 @@
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopenglgradientcache_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopenglpaintdevice_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopenglpaintengine_p.h
+%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopenglprogrambinarycache_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopenglqueryhelper_p.h
-%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopenglshadercache_meego_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopenglshadercache_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopengltexture_p.h
-%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopengltextureblitter_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopengltexturecache_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopengltextureglyphcache_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopengltexturehelper_p.h
@@ -120,6 +180,8 @@
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qtextodfwriter_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qtexttable_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qtextureglyphcache_p.h
+%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qtgui-config_p.h
+%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qtguiglobal_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qtouchdevice_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qtriangulatingstroker_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qtriangulator_p.h
@@ -249,6 +311,7 @@
%%QT_INCDIR%%/QtGui/QKeyEvent
%%QT_INCDIR%%/QtGui/QKeySequence
%%QT_INCDIR%%/QtGui/QLinearGradient
+%%QT_INCDIR%%/QtGui/QList
%%QT_INCDIR%%/QtGui/QMatrix
%%QT_INCDIR%%/QtGui/QMatrix2x2
%%QT_INCDIR%%/QtGui/QMatrix2x3
@@ -307,6 +370,7 @@
%%QT_INCDIR%%/QtGui/QOpenGLShader
%%QT_INCDIR%%/QtGui/QOpenGLShaderProgram
%%QT_INCDIR%%/QtGui/QOpenGLTexture
+%%QT_INCDIR%%/QtGui/QOpenGLTextureBlitter
%%QT_INCDIR%%/QtGui/QOpenGLTimeMonitor
%%QT_INCDIR%%/QtGui/QOpenGLTimerQuery
%%QT_INCDIR%%/QtGui/QOpenGLVersionFunctions
@@ -334,6 +398,7 @@
%%QT_INCDIR%%/QtGui/QPixmap
%%QT_INCDIR%%/QtGui/QPixmapCache
%%QT_INCDIR%%/QtGui/QPlatformSurfaceEvent
+%%QT_INCDIR%%/QtGui/QPointingDeviceUniqueId
%%QT_INCDIR%%/QtGui/QPolygon
%%QT_INCDIR%%/QtGui/QPolygonF
%%QT_INCDIR%%/QtGui/QQuaternion
@@ -487,6 +552,7 @@
%%QT_INCDIR%%/QtGui/qopenglpixeltransferoptions.h
%%QT_INCDIR%%/QtGui/qopenglshaderprogram.h
%%QT_INCDIR%%/QtGui/qopengltexture.h
+%%QT_INCDIR%%/QtGui/qopengltextureblitter.h
%%QT_INCDIR%%/QtGui/qopengltimerquery.h
%%QT_INCDIR%%/QtGui/qopenglversionfunctions.h
%%QT_INCDIR%%/QtGui/qopenglvertexarrayobject.h
@@ -532,6 +598,8 @@
%%QT_INCDIR%%/QtGui/qtextobject.h
%%QT_INCDIR%%/QtGui/qtextoption.h
%%QT_INCDIR%%/QtGui/qtexttable.h
+%%QT_INCDIR%%/QtGui/qtgui-config.h
+%%QT_INCDIR%%/QtGui/qtguiglobal.h
%%QT_INCDIR%%/QtGui/qtguiversion.h
%%QT_INCDIR%%/QtGui/qtouchdevice.h
%%QT_INCDIR%%/QtGui/qtransform.h
@@ -542,12 +610,34 @@
%%QT_INCDIR%%/QtGui/qwindow.h
%%QT_INCDIR%%/QtGui/qwindowdefs.h
%%QT_INCDIR%%/QtGui/qwindowdefs_win.h
+%%QT_INCDIR%%/QtKmsSupport/%%FULLVER%%/QtKmsSupport/private/qkmsdevice_p.h
+%%QT_INCDIR%%/QtKmsSupport/QtKmsSupport
+%%QT_INCDIR%%/QtKmsSupport/QtKmsSupportDepends
+%%QT_INCDIR%%/QtKmsSupport/QtKmsSupportVersion
+%%QT_INCDIR%%/QtKmsSupport/qtkmssupportversion.h
+%%QT_INCDIR%%/QtLinuxAccessibilitySupport/%%FULLVER%%/QtLinuxAccessibilitySupport/private/application_p.h
+%%QT_INCDIR%%/QtLinuxAccessibilitySupport/%%FULLVER%%/QtLinuxAccessibilitySupport/private/atspiadaptor_p.h
+%%QT_INCDIR%%/QtLinuxAccessibilitySupport/%%FULLVER%%/QtLinuxAccessibilitySupport/private/bridge_p.h
+%%QT_INCDIR%%/QtLinuxAccessibilitySupport/%%FULLVER%%/QtLinuxAccessibilitySupport/private/cache_p.h
+%%QT_INCDIR%%/QtLinuxAccessibilitySupport/%%FULLVER%%/QtLinuxAccessibilitySupport/private/constant_mappings_p.h
+%%QT_INCDIR%%/QtLinuxAccessibilitySupport/%%FULLVER%%/QtLinuxAccessibilitySupport/private/dbusconnection_p.h
+%%QT_INCDIR%%/QtLinuxAccessibilitySupport/%%FULLVER%%/QtLinuxAccessibilitySupport/private/struct_marshallers_p.h
+%%QT_INCDIR%%/QtLinuxAccessibilitySupport/QtLinuxAccessibilitySupport
+%%QT_INCDIR%%/QtLinuxAccessibilitySupport/QtLinuxAccessibilitySupportDepends
+%%QT_INCDIR%%/QtLinuxAccessibilitySupport/QtLinuxAccessibilitySupportVersion
+%%QT_INCDIR%%/QtLinuxAccessibilitySupport/qtlinuxaccessibilitysupportversion.h
%%QT_INCDIR%%/QtOpenGLExtensions/QOpenGLExtensions
%%QT_INCDIR%%/QtOpenGLExtensions/QtOpenGLExtensions
%%QT_INCDIR%%/QtOpenGLExtensions/QtOpenGLExtensionsDepends
%%QT_INCDIR%%/QtOpenGLExtensions/QtOpenGLExtensionsVersion
%%QT_INCDIR%%/QtOpenGLExtensions/qopenglextensions.h
%%QT_INCDIR%%/QtOpenGLExtensions/qtopenglextensionsversion.h
+%%QT_INCDIR%%/QtPlatformCompositorSupport/%%FULLVER%%/QtPlatformCompositorSupport/private/qopenglcompositor_p.h
+%%QT_INCDIR%%/QtPlatformCompositorSupport/%%FULLVER%%/QtPlatformCompositorSupport/private/qopenglcompositorbackingstore_p.h
+%%QT_INCDIR%%/QtPlatformCompositorSupport/QtPlatformCompositorSupport
+%%QT_INCDIR%%/QtPlatformCompositorSupport/QtPlatformCompositorSupportDepends
+%%QT_INCDIR%%/QtPlatformCompositorSupport/QtPlatformCompositorSupportVersion
+%%QT_INCDIR%%/QtPlatformCompositorSupport/qtplatformcompositorsupportversion.h
%%QT_INCDIR%%/QtPlatformHeaders/QCocoaNativeContext
%%QT_INCDIR%%/QtPlatformHeaders/QCocoaWindowFunctions
%%QT_INCDIR%%/QtPlatformHeaders/QEGLNativeContext
@@ -576,78 +666,33 @@
%%QT_INCDIR%%/QtPlatformHeaders/qxcbintegrationfunctions.h
%%QT_INCDIR%%/QtPlatformHeaders/qxcbscreenfunctions.h
%%QT_INCDIR%%/QtPlatformHeaders/qxcbwindowfunctions.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/application_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/atspiadaptor_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/bridge_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/cache_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/cglconvenience_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/constant_mappings_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/dbusconnection_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qaccessiblebridgeutils_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qbasicfontdatabase_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qcoretextfontdatabase_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdbusmenuadaptor_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdbusmenubar_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdbusmenuconnection_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdbusmenuregistrarproxy_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdbusmenutypes_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdbusplatformmenu_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdbustrayicon_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdbustraytypes_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdevicediscovery_dummy_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdevicediscovery_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdevicediscovery_static_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdevicediscovery_udev_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qeglconvenience_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qeglpbuffer_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qeglplatformcontext_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qeglstreamconvenience_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qevdevkeyboard_defaultmap_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qevdevkeyboardhandler_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qevdevkeyboardmanager_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qevdevmousehandler_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qevdevmousemanager_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qevdevtablethandler_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qevdevtabletmanager_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qevdevtouchhandler_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qevdevtouchmanager_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qeventdispatcher_glib_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qfbbackingstore_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qfbcursor_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qfbscreen_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qfbvthandler_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qfbwindow_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qfontconfigdatabase_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qfontengine_coretext_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qfontenginemultifontconfig_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qgenericunixeventdispatcher_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qgenericunixfontdatabase_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qgenericunixservices_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qgenericunixthemes_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qglxconvenience_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qlibinputhandler_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qlibinputkeyboard_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qlibinputpointer_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qlibinputtouch_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qmacmime_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qopenglcompositor_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qopenglcompositorbackingstore_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qrasterbackingstore_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qstatusnotifieritemadaptor_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qt_egl_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qtslib_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qunixeventdispatcher_qpa_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qwindowsguieventdispatcher_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qxdgnotificationproxy_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qxlibeglintegration_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/struct_marshallers_p.h
-%%QT_INCDIR%%/QtPlatformSupport/QtPlatformSupport
-%%QT_INCDIR%%/QtPlatformSupport/QtPlatformSupportDepends
-%%QT_INCDIR%%/QtPlatformSupport/QtPlatformSupportVersion
-%%QT_INCDIR%%/QtPlatformSupport/qtplatformsupportversion.h
+%%QT_INCDIR%%/QtServiceSupport/%%FULLVER%%/QtServiceSupport/private/qgenericunixservices_p.h
+%%QT_INCDIR%%/QtServiceSupport/QtServiceSupport
+%%QT_INCDIR%%/QtServiceSupport/QtServiceSupportDepends
+%%QT_INCDIR%%/QtServiceSupport/QtServiceSupportVersion
+%%QT_INCDIR%%/QtServiceSupport/qtservicesupportversion.h
+%%QT_INCDIR%%/QtThemeSupport/%%FULLVER%%/QtThemeSupport/private/qabstractfileiconengine_p.h
+%%QT_INCDIR%%/QtThemeSupport/%%FULLVER%%/QtThemeSupport/private/qdbusmenuadaptor_p.h
+%%QT_INCDIR%%/QtThemeSupport/%%FULLVER%%/QtThemeSupport/private/qdbusmenubar_p.h
+%%QT_INCDIR%%/QtThemeSupport/%%FULLVER%%/QtThemeSupport/private/qdbusmenuconnection_p.h
+%%QT_INCDIR%%/QtThemeSupport/%%FULLVER%%/QtThemeSupport/private/qdbusmenuregistrarproxy_p.h
+%%QT_INCDIR%%/QtThemeSupport/%%FULLVER%%/QtThemeSupport/private/qdbusmenutypes_p.h
+%%QT_INCDIR%%/QtThemeSupport/%%FULLVER%%/QtThemeSupport/private/qdbusplatformmenu_p.h
+%%QT_INCDIR%%/QtThemeSupport/%%FULLVER%%/QtThemeSupport/private/qdbustrayicon_p.h
+%%QT_INCDIR%%/QtThemeSupport/%%FULLVER%%/QtThemeSupport/private/qdbustraytypes_p.h
+%%QT_INCDIR%%/QtThemeSupport/%%FULLVER%%/QtThemeSupport/private/qgenericunixthemes_p.h
+%%QT_INCDIR%%/QtThemeSupport/%%FULLVER%%/QtThemeSupport/private/qstatusnotifieritemadaptor_p.h
+%%QT_INCDIR%%/QtThemeSupport/%%FULLVER%%/QtThemeSupport/private/qxdgnotificationproxy_p.h
+%%QT_INCDIR%%/QtThemeSupport/QtThemeSupport
+%%QT_INCDIR%%/QtThemeSupport/QtThemeSupportDepends
+%%QT_INCDIR%%/QtThemeSupport/QtThemeSupportVersion
+%%QT_INCDIR%%/QtThemeSupport/qtthemesupportversion.h
%%QT_CMAKEDIR%%/Qt5Gui/Qt5GuiConfig.cmake
%%QT_CMAKEDIR%%/Qt5Gui/Qt5GuiConfigExtras.cmake
%%QT_CMAKEDIR%%/Qt5Gui/Qt5GuiConfigVersion.cmake
+%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QBsdFbIntegrationPlugin.cmake
+%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QBsdKeyboardPlugin.cmake
+%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QBsdMousePlugin.cmake
%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QComposePlatformInputContextPlugin.cmake
%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QGifPlugin.cmake
%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QICOPlugin.cmake
@@ -656,33 +701,71 @@
%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QMinimalIntegrationPlugin.cmake
%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QOffscreenIntegrationPlugin.cmake
%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QTuioTouchPlugin.cmake
+%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QVncIntegrationPlugin.cmake
%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QXcbEglIntegrationPlugin.cmake
%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QXcbGlxIntegrationPlugin.cmake
%%QT_CMAKEDIR%%/Qt5Gui/Qt5Gui_QXcbIntegrationPlugin.cmake
%%QT_CMAKEDIR%%/Qt5OpenGLExtensions/Qt5OpenGLExtensionsConfig.cmake
%%QT_CMAKEDIR%%/Qt5OpenGLExtensions/Qt5OpenGLExtensionsConfigVersion.cmake
+%%QT_LIBDIR%%/libQt5AccessibilitySupport.a
+%%QT_LIBDIR%%/libQt5AccessibilitySupport.prl
+%%QT_LIBDIR%%/libQt5DeviceDiscoverySupport.a
+%%QT_LIBDIR%%/libQt5DeviceDiscoverySupport.prl
+%%QT_LIBDIR%%/libQt5EglSupport.a
+%%QT_LIBDIR%%/libQt5EglSupport.prl
+%%QT_LIBDIR%%/libQt5EventDispatcherSupport.a
+%%QT_LIBDIR%%/libQt5EventDispatcherSupport.prl
+%%QT_LIBDIR%%/libQt5FbSupport.a
+%%QT_LIBDIR%%/libQt5FbSupport.prl
+%%QT_LIBDIR%%/libQt5FontDatabaseSupport.a
+%%QT_LIBDIR%%/libQt5FontDatabaseSupport.prl
+%%QT_LIBDIR%%/libQt5GlxSupport.a
+%%QT_LIBDIR%%/libQt5GlxSupport.prl
%%QT_LIBDIR%%/libQt5Gui.prl
%%QT_LIBDIR%%/libQt5Gui.so
%%QT_LIBDIR%%/libQt5Gui.so.5
%%QT_LIBDIR%%/libQt5Gui.so.%%SHORTVER%%
%%QT_LIBDIR%%/libQt5Gui.so.%%FULLVER%%
%%DEBUG%%%%QT_LIBDIR%%/libQt5Gui.so.%%FULLVER%%.debug
+%%QT_LIBDIR%%/libQt5KmsSupport.a
+%%QT_LIBDIR%%/libQt5KmsSupport.prl
+%%QT_LIBDIR%%/libQt5LinuxAccessibilitySupport.a
+%%QT_LIBDIR%%/libQt5LinuxAccessibilitySupport.prl
%%QT_LIBDIR%%/libQt5OpenGLExtensions.a
%%QT_LIBDIR%%/libQt5OpenGLExtensions.prl
-%%QT_LIBDIR%%/libQt5PlatformSupport.a
-%%QT_LIBDIR%%/libQt5PlatformSupport.prl
+%%QT_LIBDIR%%/libQt5PlatformCompositorSupport.a
+%%QT_LIBDIR%%/libQt5PlatformCompositorSupport.prl
+%%QT_LIBDIR%%/libQt5ServiceSupport.a
+%%QT_LIBDIR%%/libQt5ServiceSupport.prl
+%%QT_LIBDIR%%/libQt5ThemeSupport.a
+%%QT_LIBDIR%%/libQt5ThemeSupport.prl
%%QT_LIBDIR%%/libQt5XcbQpa.prl
%%QT_LIBDIR%%/libQt5XcbQpa.so
%%QT_LIBDIR%%/libQt5XcbQpa.so.5
%%QT_LIBDIR%%/libQt5XcbQpa.so.%%SHORTVER%%
%%QT_LIBDIR%%/libQt5XcbQpa.so.%%FULLVER%%
%%DEBUG%%%%QT_LIBDIR%%/libQt5XcbQpa.so.%%FULLVER%%.debug
+%%QT_MKSPECDIR%%/modules/qt_lib_accessibility_support_private.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_devicediscovery_support_private.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_egl_support_private.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_eventdispatcher_support_private.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_fb_support_private.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_fontdatabase_support_private.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_glx_support_private.pri
%%QT_MKSPECDIR%%/modules/qt_lib_gui.pri
%%QT_MKSPECDIR%%/modules/qt_lib_gui_private.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_kms_support_private.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_linuxaccessibility_support_private.pri
%%QT_MKSPECDIR%%/modules/qt_lib_openglextensions.pri
%%QT_MKSPECDIR%%/modules/qt_lib_openglextensions_private.pri
-%%QT_MKSPECDIR%%/modules/qt_lib_platformsupport_private.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_platformcompositor_support_private.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_service_support_private.pri
+%%QT_MKSPECDIR%%/modules/qt_lib_theme_support_private.pri
%%QT_MKSPECDIR%%/modules/qt_lib_xcb_qpa_lib_private.pri
+%%QT_PLUGINDIR%%/generic/libqbsdkeyboardplugin.so
+%%DEBUG%%%%QT_PLUGINDIR%%/generic/libqbsdkeyboardplugin.so.debug
+%%QT_PLUGINDIR%%/generic/libqbsdmouseplugin.so
+%%DEBUG%%%%QT_PLUGINDIR%%/generic/libqbsdmouseplugin.so.debug
%%QT_PLUGINDIR%%/generic/libqtuiotouchplugin.so
%%DEBUG%%%%QT_PLUGINDIR%%/generic/libqtuiotouchplugin.so.debug
%%QT_PLUGINDIR%%/imageformats/libqgif.so
@@ -695,6 +778,10 @@
%%DEBUG%%%%QT_PLUGINDIR%%/platforminputcontexts/libcomposeplatforminputcontextplugin.so.debug
%%QT_PLUGINDIR%%/platforminputcontexts/libibusplatforminputcontextplugin.so
%%DEBUG%%%%QT_PLUGINDIR%%/platforminputcontexts/libibusplatforminputcontextplugin.so.debug
+%%QT_PLUGINDIR%%/platforms/libqbsdfb.so
+%%DEBUG%%%%QT_PLUGINDIR%%/platforms/libqbsdfb.so.debug
+%%QT_PLUGINDIR%%/platforms/libqvnc.so
+%%DEBUG%%%%QT_PLUGINDIR%%/platforms/libqvnc.so.debug
%%QT_PLUGINDIR%%/platforms/libqminimal.so
%%DEBUG%%%%QT_PLUGINDIR%%/platforms/libqminimal.so.debug
%%QT_PLUGINDIR%%/platforms/libqoffscreen.so