aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt5-gui
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-01-09 13:16:49 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-01-09 13:16:49 +0000
commit9d79e7b1469f6887d302e13ce7c67c54408a2453 (patch)
tree263754af5ddd95f1ad55b06c101378a0cf71009b /x11-toolkits/qt5-gui
parenta0e384abe8236d5d12c69354d90c0de5342f7efb (diff)
- Remove always-true/false conditions after FreeBSD 9, 10.1, 10.2 EOL
Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=430947
Diffstat (limited to 'x11-toolkits/qt5-gui')
-rw-r--r--x11-toolkits/qt5-gui/Makefile4
-rw-r--r--x11-toolkits/qt5-gui/files/extrapatch-src_gui_painting_qcolor.cpp20
2 files changed, 0 insertions, 24 deletions
diff --git a/x11-toolkits/qt5-gui/Makefile b/x11-toolkits/qt5-gui/Makefile
index aebaea1b5e62..e5c4b828186f 100644
--- a/x11-toolkits/qt5-gui/Makefile
+++ b/x11-toolkits/qt5-gui/Makefile
@@ -83,10 +83,6 @@ CFLAGS_powerpc64= -mminimal-toc
CXXFLAGS+= -flax-vector-conversions
.endif
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000
-EXTRA_PATCHES+= ${FILESDIR}/extrapatch-src_gui_painting_qcolor.cpp
-.endif
-
post-build:
.for d in ${MORE_WRKSRCS}
@cd ${WRKSRC}/${d} && \
diff --git a/x11-toolkits/qt5-gui/files/extrapatch-src_gui_painting_qcolor.cpp b/x11-toolkits/qt5-gui/files/extrapatch-src_gui_painting_qcolor.cpp
deleted file mode 100644
index 7760f66a4034..000000000000
--- a/x11-toolkits/qt5-gui/files/extrapatch-src_gui_painting_qcolor.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
-On FreeBSD 9.3 with gcc-4.2 we need to mark the constant as an unsigned long long.
-Else the compiler will choke on it being too large:
-
-c++ -c -O2 -pipe [...] itemmodels/qstandarditemmodel.cpp
-painting/qcolor.cpp:527: error: integer constant is too large for 'long' type
-*** [.obj/qcolor.o] Error code 1
-1 error
-
-
---- src/gui/painting/qcolor.cpp.orig 2016-10-10 16:17:59 UTC
-+++ src/gui/painting/qcolor.cpp
-@@ -524,7 +524,7 @@ QString QColor::name(NameFormat format)
- return QLatin1Char('#') + QString::number(rgba() | 0x1000000, 16).rightRef(6);
- case HexArgb:
- // it's called rgba() but it does return AARRGGBB
-- return QLatin1Char('#') + QString::number(rgba() | 0x100000000, 16).rightRef(8);
-+ return QLatin1Char('#') + QString::number(rgba() | 0x100000000ULL, 16).rightRef(8);
- }
- return QString();
- }