aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt5-uiplugin/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-01-24 18:10:14 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-01-24 18:10:14 +0000
commit4c67812e0161cb63098ede0c2645e53c5060ecd9 (patch)
tree66663b28c2c298161be86b00114ab18d6fad8670 /x11-toolkits/qt5-uiplugin/Makefile
parent7b72d170ba3c89c7e408c333297d8ecfa3ba72f1 (diff)
downloadports-4c67812e0161cb63098ede0c2645e53c5060ecd9.tar.gz
ports-4c67812e0161cb63098ede0c2645e53c5060ecd9.zip
Notes
Diffstat (limited to 'x11-toolkits/qt5-uiplugin/Makefile')
-rw-r--r--x11-toolkits/qt5-uiplugin/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/x11-toolkits/qt5-uiplugin/Makefile b/x11-toolkits/qt5-uiplugin/Makefile
new file mode 100644
index 000000000000..3c1109b18368
--- /dev/null
+++ b/x11-toolkits/qt5-uiplugin/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= uiplugin
+DISTVERSION= ${QT5_VERSION}
+CATEGORIES= x11-toolkits devel
+PKGNAMEPREFIX= qt5-
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Custom Qt widget plugin interface for Qt Designer
+
+# This port used to be part of qt5-designer itself before 5.5.0.
+CONFLICTS= qt5-designer-5.[0-4].*
+
+USE_QT5= core gui widgets
+QT_DIST= tools
+USES= qmake
+
+BUILD_WRKSRC= ${WRKSRC}/src/designer/src/${PORTNAME}
+INSTALL_WRKSRC= ${WRKSRC}/src/designer/src/${PORTNAME}
+
+.include <bsd.port.mk>