aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qt5-widgets
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /x11-toolkits/qt5-widgets
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'x11-toolkits/qt5-widgets')
-rw-r--r--x11-toolkits/qt5-widgets/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/x11-toolkits/qt5-widgets/Makefile b/x11-toolkits/qt5-widgets/Makefile
index a1d8f5c2c6e0..2a0223b0348d 100644
--- a/x11-toolkits/qt5-widgets/Makefile
+++ b/x11-toolkits/qt5-widgets/Makefile
@@ -8,8 +8,8 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt C++ widgets module
-USE_QT5= core gui qmake_build buildtools_build
-QT_DIST= base
+USES= qmake:no_env qt-dist:5,base
+USE_QT= core gui qmake_build buildtools_build
USE_XORG= x11
HAS_CONFIGURE= yes
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
@@ -26,7 +26,7 @@ OPTIONS_DEFINE= GTK3
OPTIONS_SUB= YES
GTK3_DESC= GTK+-based Qt theme
-GTK3_USE= GNOME=gtk30 QT5=dbus
+GTK3_USE= GNOME=gtk30 QT=dbus
GTK3_CONFIGURE_ON= -gtk
GTK3_CONFIGURE_OFF= -no-gtk