aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qwt5
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-05-16 12:27:29 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-05-16 12:27:29 +0000
commita2c4ebdbc392b43487998a4037689c1ac2c3b0d4 (patch)
tree757d5ea30db3e44f53957115177ede62ba40df25 /x11-toolkits/qwt5
parente68ab98087ba2048fe73c61dced4429ac659ecc1 (diff)
downloadports-a2c4ebdbc392b43487998a4037689c1ac2c3b0d4.tar.gz
ports-a2c4ebdbc392b43487998a4037689c1ac2c3b0d4.zip
Notes
Diffstat (limited to 'x11-toolkits/qwt5')
-rw-r--r--x11-toolkits/qwt5/Makefile45
-rw-r--r--x11-toolkits/qwt5/distinfo6
-rw-r--r--x11-toolkits/qwt5/files/Makefile.man4
-rw-r--r--x11-toolkits/qwt5/files/patch-designer__designer.pro11
-rw-r--r--x11-toolkits/qwt5/files/patch-qwtconfig.pri39
-rw-r--r--x11-toolkits/qwt5/files/patch-src__src.pro8
-rw-r--r--x11-toolkits/qwt5/pkg-plist110
7 files changed, 133 insertions, 90 deletions
diff --git a/x11-toolkits/qwt5/Makefile b/x11-toolkits/qwt5/Makefile
index 27963ba3edab..60d598d8ffda 100644
--- a/x11-toolkits/qwt5/Makefile
+++ b/x11-toolkits/qwt5/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= qwt
-PORTVERSION= 5.0.2
-PORTREVISION= 2
+PORTVERSION= 5.1.0
CATEGORIES= x11-toolkits
MASTER_SITES= SF
@@ -15,61 +14,37 @@ MAINTAINER= makc@issp.ac.ru
COMMENT= Qt Widgets for Technical Applications
USE_QT_VER= 4
-QT_COMPONENTS= gui moc_build qmake_build
+QT_COMPONENTS= gui svg moc_build qmake_build
USE_BZIP2= yes
USE_GMAKE= yes
+QMAKE_ARGS+= -unix -recursive PREFIX=${PREFIX}
HAS_CONFIGURE= yes
USE_LDCONFIG= yes
OPTIONS= DESIGNER_PLUGIN "Install plugin for Qt Designer" on
-PLUGINDIR= ${PREFIX}/lib/qt4/plugins/designer
-
.include <bsd.port.pre.mk>
.include <${FILESDIR}/Makefile.man>
-QPRO_DIRS= src
.if !defined(WITHOUT_DESIGNER_PLUGIN)
-QPRO_DIRS+= designer
-#QT_COMPONENTS+= designer xml rcc_build
+#QT_COMPONENTS+= designer rcc_build
BUILD_DEPENDS+= ${LOCALBASE}/bin/rcc:${PORTSDIR}/devel/qt4-rcc
-LIB_DEPENDS+= QtXml:${PORTSDIR}/textproc/qt4-xml \
- QtDesigner:${PORTSDIR}/devel/qt4-designer
+LIB_DEPENDS+= QtDesigner:${PORTSDIR}/devel/qt4-designer
+QMAKE_ARGS+= CONFIG+=QwtDesigner PLUGINDIR=${PREFIX}/lib/qt4/plugins
PLIST_SUB+= DESIGNER_PLUGIN=""
.else
PLIST_SUB+= DESIGNER_PLUGIN="@comment "
.endif
do-configure:
-.for d in ${QPRO_DIRS}
- (cd ${WRKSRC}/${d} && ${SETENV} ${MAKE_ENV} \
- ${QMAKE} -unix)
-.endfor
+ (cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKE_ARGS})
post-configure:
-.for d in ${QPRO_DIRS}
- (cd ${WRKSRC}/${d} && \
- ${REINPLACE_CMD} -e \
- 's|^CC .*|CC=${CC}|; \
- s|^CXX .*|CXX=${CXX}|; \
- s|^LINK .*|LINK=${CXX}|' \
- ${WRKSRC}/${d}/Makefile)
-.endfor
-
-do-build:
-.for d in ${QPRO_DIRS}
- (cd ${WRKSRC}/${d}; ${SETENV} ${MAKE_ENV} ${GMAKE})
-.endfor
+ ${FIND} ${WRKSRC} -name Makefile | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|^CC .*|CC=${CC}|; s|^CXX .*|CXX=${CXX}|; s|^LINK .*|LINK=${CXX}|'
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/lib/libqwt.so.${PORTVERSION} ${PREFIX}/lib/libqwt.so.${PORTVERSION:R:R}
- ${LN} -fs ${PREFIX}/lib/libqwt.so.${PORTVERSION:R:R} ${PREFIX}/lib/libqwt.so
- (cd ${WRKSRC}/src/ && ${COPYTREE_SHARE} '*.h' ${PREFIX}/include/${PORTNAME})
+post-install:
${INSTALL_MAN} ${WRKSRC}/doc/man/man3/Qwt* ${PREFIX}/man/man3
-.if !defined(WITHOUT_DESIGNER_PLUGIN)
- ${MKDIR} ${PLUGINDIR} && \
- ${INSTALL_PROGRAM} ${WRKSRC}/designer/plugins/designer/libqwt_designer_plugin.so ${PLUGINDIR}
-.endif
.if !defined(NOPORTDOCS)
(cd ${WRKSRC}/doc/html/ && ${COPYTREE_SHARE} \* ${DOCSDIR})
.endif
diff --git a/x11-toolkits/qwt5/distinfo b/x11-toolkits/qwt5/distinfo
index e58b9325b788..e35fe45dcd07 100644
--- a/x11-toolkits/qwt5/distinfo
+++ b/x11-toolkits/qwt5/distinfo
@@ -1,3 +1,3 @@
-MD5 (qwt-5.0.2.tar.bz2) = 53adbb313c478dd4aae4f1c864a2037e
-SHA256 (qwt-5.0.2.tar.bz2) = 1e09af748c42f70771334db7bad04c3e39cf0f80fe4da993345c366575b2408d
-SIZE (qwt-5.0.2.tar.bz2) = 1666468
+MD5 (qwt-5.1.0.tar.bz2) = c585dc3b1ea5ad00747721f68687d868
+SHA256 (qwt-5.1.0.tar.bz2) = 286d2d4e09662908b473b8d230e946171ef85f49f80982734aca780a4ef1c855
+SIZE (qwt-5.1.0.tar.bz2) = 1683012
diff --git a/x11-toolkits/qwt5/files/Makefile.man b/x11-toolkits/qwt5/files/Makefile.man
index f75790e81431..b240915c0984 100644
--- a/x11-toolkits/qwt5/files/Makefile.man
+++ b/x11-toolkits/qwt5/files/Makefile.man
@@ -6,6 +6,7 @@ MAN3= QwtAbstractScale.3 \
QwtArrayData.3 \
QwtArrowButton.3 \
QwtCPointerData.3 \
+ QwtClipper.3 \
QwtColorMap.3 \
QwtCompass.3 \
QwtCompassMagnetNeedle.3 \
@@ -28,9 +29,11 @@ MAN3= QwtAbstractScale.3 \
QwtKnob.3 \
QwtLegend.3 \
QwtLegendItem.3 \
+ QwtLegendItemManager.3 \
QwtLinearColorMap.3 \
QwtLinearScaleEngine.3 \
QwtLog10ScaleEngine.3 \
+ QwtMagnifier.3 \
QwtMathMLTextEngine.3 \
QwtMetricsMap.3 \
QwtPainter.3 \
@@ -56,6 +59,7 @@ MAN3= QwtAbstractScale.3 \
QwtPlotPicker.3 \
QwtPlotPrintFilter.3 \
QwtPlotRasterItem.3 \
+ QwtPlotScaleItem.3 \
QwtPlotSpectrogram.3 \
QwtPlotSvgItem.3 \
QwtPlotZoomer.3 \
diff --git a/x11-toolkits/qwt5/files/patch-designer__designer.pro b/x11-toolkits/qwt5/files/patch-designer__designer.pro
new file mode 100644
index 000000000000..030bd15ede67
--- /dev/null
+++ b/x11-toolkits/qwt5/files/patch-designer__designer.pro
@@ -0,0 +1,11 @@
+--- ./designer/designer.pro.orig 2008-05-01 17:43:56.000000000 +0400
++++ ./designer/designer.pro 2008-05-03 02:21:17.000000000 +0400
+@@ -123,7 +123,7 @@
+ RESOURCES += \
+ qwt_designer_plugin.qrc
+
+- target.path = $$[QT_INSTALL_PLUGINS]/designer
++ target.path = $$PLUGINDIR/designer
+ INSTALLS += target
+ }
+ }
diff --git a/x11-toolkits/qwt5/files/patch-qwtconfig.pri b/x11-toolkits/qwt5/files/patch-qwtconfig.pri
new file mode 100644
index 000000000000..e346db43c7e4
--- /dev/null
+++ b/x11-toolkits/qwt5/files/patch-qwtconfig.pri
@@ -0,0 +1,39 @@
+--- ./qwtconfig.pri.orig 2008-05-01 17:43:56.000000000 +0400
++++ ./qwtconfig.pri 2008-05-03 02:21:17.000000000 +0400
+@@ -8,7 +8,7 @@
+ VERSION = $$VER_MAJ.$$VER_MIN.$$VER_PAT
+
+ unix {
+- INSTALLBASE = /usr/local/qwt-5.1.0
++ INSTALLBASE = $$PREFIX
+ }
+
+ win32 {
+@@ -16,8 +16,7 @@
+ }
+
+ target.path = $$INSTALLBASE/lib
+-headers.path = $$INSTALLBASE/include
+-doc.path = $$INSTALLBASE/doc
++headers.path = $$INSTALLBASE/include/qwt
+
+ ######################################################################
+ # qmake internal options
+@@ -97,7 +96,7 @@
+ # QwtSVGItem.
+ ######################################################################
+
+-#CONFIG += QwtSVGItem
++CONFIG += QwtSVGItem
+
+ ######################################################################
+ # If you have a commercial license you can use the MathML renderer
+@@ -114,7 +113,7 @@
+ # Otherwise you have to build it from the designer directory.
+ ######################################################################
+
+-CONFIG += QwtDesigner
++#CONFIG += QwtDesigner
+
+ ######################################################################
+ # If you want to auto build the examples, enable the line below
diff --git a/x11-toolkits/qwt5/files/patch-src__src.pro b/x11-toolkits/qwt5/files/patch-src__src.pro
new file mode 100644
index 000000000000..0c3ddbf32695
--- /dev/null
+++ b/x11-toolkits/qwt5/files/patch-src__src.pro
@@ -0,0 +1,8 @@
+--- ./src/src.pro.orig 2008-05-01 17:43:56.000000000 +0400
++++ ./src/src.pro 2008-05-03 02:23:43.000000000 +0400
+@@ -221,4 +221,4 @@
+ doc.files += $${QWT_ROOT}/doc/man
+ }
+
+-INSTALLS = target headers doc
++INSTALLS = target headers
diff --git a/x11-toolkits/qwt5/pkg-plist b/x11-toolkits/qwt5/pkg-plist
index a9da93c13fbb..29c00c49957a 100644
--- a/x11-toolkits/qwt5/pkg-plist
+++ b/x11-toolkits/qwt5/pkg-plist
@@ -5,6 +5,7 @@ include/qwt/qwt_abstract_slider.h
include/qwt/qwt_analog_clock.h
include/qwt/qwt_array.h
include/qwt/qwt_arrow_button.h
+include/qwt/qwt_clipper.h
include/qwt/qwt_color_map.h
include/qwt/qwt_compass.h
include/qwt/qwt_compass_rose.h
@@ -24,6 +25,8 @@ include/qwt/qwt_knob.h
include/qwt/qwt_layout_metrics.h
include/qwt/qwt_legend.h
include/qwt/qwt_legend_item.h
+include/qwt/qwt_legend_itemmanager.h
+include/qwt/qwt_magnifier.h
include/qwt/qwt_math.h
include/qwt/qwt_paint_buffer.h
include/qwt/qwt_painter.h
@@ -43,6 +46,7 @@ include/qwt/qwt_plot_panner.h
include/qwt/qwt_plot_picker.h
include/qwt/qwt_plot_printfilter.h
include/qwt/qwt_plot_rasteritem.h
+include/qwt/qwt_plot_scaleitem.h
include/qwt/qwt_plot_spectrogram.h
include/qwt/qwt_plot_svgitem.h
include/qwt/qwt_plot_zoomer.h
@@ -66,6 +70,8 @@ include/qwt/qwt_valuelist.h
include/qwt/qwt_wheel.h
lib/libqwt.so
lib/libqwt.so.5
+lib/libqwt.so.5.1
+lib/libqwt.so.5.1.0
%%DESIGNER_PLUGIN%%lib/qt4/plugins/designer/libqwt_designer_plugin.so
%%PORTDOCS%%%%DOCSDIR%%/analogclock.png
%%PORTDOCS%%%%DOCSDIR%%/annotated.html
@@ -121,6 +127,8 @@ lib/libqwt.so.5
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_c_pointer_data__inherit__graph.map
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_c_pointer_data__inherit__graph.md5
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_c_pointer_data__inherit__graph.png
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_clipper-members.html
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_clipper.html
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_color_map-members.html
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_color_map.html
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_color_map__inherit__graph.map
@@ -240,6 +248,11 @@ lib/libqwt.so.5
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_legend_item__inherit__graph.map
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_legend_item__inherit__graph.md5
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_legend_item__inherit__graph.png
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_legend_item_manager-members.html
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_legend_item_manager.html
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_legend_item_manager__inherit__graph.map
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_legend_item_manager__inherit__graph.md5
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_legend_item_manager__inherit__graph.png
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_linear_color_map-members.html
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_linear_color_map.html
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_linear_color_map__coll__graph.map
@@ -264,6 +277,11 @@ lib/libqwt.so.5
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_log10_scale_engine__inherit__graph.map
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_log10_scale_engine__inherit__graph.md5
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_log10_scale_engine__inherit__graph.png
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_magnifier-members.html
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_magnifier.html
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_magnifier__inherit__graph.map
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_magnifier__inherit__graph.md5
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_magnifier__inherit__graph.png
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_math_m_l_text_engine-members.html
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_math_m_l_text_engine.html
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_math_m_l_text_engine__coll__graph.map
@@ -378,6 +396,9 @@ lib/libqwt.so.5
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_grid__inherit__graph.png
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_item-members.html
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_item.html
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_item__coll__graph.map
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_item__coll__graph.md5
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_item__coll__graph.png
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_item__inherit__graph.map
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_item__inherit__graph.md5
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_item__inherit__graph.png
@@ -385,6 +406,12 @@ lib/libqwt.so.5
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_layout.html
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_magnifier-members.html
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_magnifier.html
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_magnifier__coll__graph.map
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_magnifier__coll__graph.md5
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_magnifier__coll__graph.png
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_magnifier__inherit__graph.map
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_magnifier__inherit__graph.md5
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_magnifier__inherit__graph.png
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_marker-members.html
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_marker.html
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_marker__coll__graph.map
@@ -419,6 +446,14 @@ lib/libqwt.so.5
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_raster_item__inherit__graph.map
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_raster_item__inherit__graph.md5
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_raster_item__inherit__graph.png
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_scale_item-members.html
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_scale_item.html
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_scale_item__coll__graph.map
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_scale_item__coll__graph.md5
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_scale_item__coll__graph.png
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_scale_item__inherit__graph.map
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_scale_item__inherit__graph.md5
+%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_scale_item__inherit__graph.png
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_spectrogram-members.html
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_spectrogram.html
%%PORTDOCS%%%%DOCSDIR%%/class_qwt_plot_spectrogram__coll__graph.map
@@ -572,61 +607,13 @@ lib/libqwt.so.5
%%PORTDOCS%%%%DOCSDIR%%/form_2.png
%%PORTDOCS%%%%DOCSDIR%%/formula.repository
%%PORTDOCS%%%%DOCSDIR%%/functions.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x62.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x63.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x64.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x65.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x66.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x67.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x68.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x69.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x6b.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x6c.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x6d.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x6e.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x6f.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x70.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x71.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x72.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x73.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x74.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x75.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x76.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x77.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x78.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x79.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x7a.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_0x7e.html
%%PORTDOCS%%%%DOCSDIR%%/functions_enum.html
%%PORTDOCS%%%%DOCSDIR%%/functions_func.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x62.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x63.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x64.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x65.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x66.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x67.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x68.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x69.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x6b.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x6c.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x6d.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x6e.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x6f.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x70.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x71.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x72.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x73.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x74.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x75.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x76.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x77.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x78.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x79.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x7a.html
-%%PORTDOCS%%%%DOCSDIR%%/functions_func_0x7e.html
%%PORTDOCS%%%%DOCSDIR%%/functions_rela.html
%%PORTDOCS%%%%DOCSDIR%%/functions_type.html
%%PORTDOCS%%%%DOCSDIR%%/functions_vars.html
+%%PORTDOCS%%%%DOCSDIR%%/globals.html
+%%PORTDOCS%%%%DOCSDIR%%/globals_type.html
%%PORTDOCS%%%%DOCSDIR%%/graph.png
%%PORTDOCS%%%%DOCSDIR%%/graph_legend.dot
%%PORTDOCS%%%%DOCSDIR%%/graph_legend.html
@@ -731,6 +718,9 @@ lib/libqwt.so.5
%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__37.map
%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__37.md5
%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__37.png
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__38.map
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__38.md5
+%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__38.png
%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__4.map
%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__4.md5
%%PORTDOCS%%%%DOCSDIR%%/inherit__graph__4.png
@@ -764,6 +754,8 @@ lib/libqwt.so.5
%%PORTDOCS%%%%DOCSDIR%%/qwt__array_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/qwt__arrow__button_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/qwt__arrow__button_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/qwt__clipper_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/qwt__clipper_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/qwt__color__map_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/qwt__color__map_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/qwt__compass_8cpp-source.html
@@ -786,6 +778,10 @@ lib/libqwt.so.5
%%PORTDOCS%%%%DOCSDIR%%/qwt__double__range_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/qwt__double__rect_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/qwt__double__rect_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/qwt__double__rect_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/qwt__double__rect_8h__incl.map
+%%PORTDOCS%%%%DOCSDIR%%/qwt__double__rect_8h__incl.md5
+%%PORTDOCS%%%%DOCSDIR%%/qwt__double__rect_8h__incl.png
%%PORTDOCS%%%%DOCSDIR%%/qwt__dyngrid__layout_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/qwt__dyngrid__layout_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/qwt__event__pattern_8cpp-source.html
@@ -801,6 +797,9 @@ lib/libqwt.so.5
%%PORTDOCS%%%%DOCSDIR%%/qwt__legend_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/qwt__legend__item_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/qwt__legend__item_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/qwt__legend__itemmanager_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/qwt__magnifier_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/qwt__magnifier_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/qwt__math_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/qwt__math_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/qwt__mathml__text__engine_8cpp-source.html
@@ -824,6 +823,10 @@ lib/libqwt.so.5
%%PORTDOCS%%%%DOCSDIR%%/qwt__plot__curve_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/qwt__plot__dict_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/qwt__plot__dict_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/qwt__plot__dict_8h.html
+%%PORTDOCS%%%%DOCSDIR%%/qwt__plot__dict_8h__incl.map
+%%PORTDOCS%%%%DOCSDIR%%/qwt__plot__dict_8h__incl.md5
+%%PORTDOCS%%%%DOCSDIR%%/qwt__plot__dict_8h__incl.png
%%PORTDOCS%%%%DOCSDIR%%/qwt__plot__grid_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/qwt__plot__grid_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/qwt__plot__item_8cpp-source.html
@@ -843,6 +846,8 @@ lib/libqwt.so.5
%%PORTDOCS%%%%DOCSDIR%%/qwt__plot__printfilter_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/qwt__plot__rasteritem_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/qwt__plot__rasteritem_8h-source.html
+%%PORTDOCS%%%%DOCSDIR%%/qwt__plot__scaleitem_8cpp-source.html
+%%PORTDOCS%%%%DOCSDIR%%/qwt__plot__scaleitem_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/qwt__plot__spectrogram_8cpp-source.html
%%PORTDOCS%%%%DOCSDIR%%/qwt__plot__spectrogram_8h-source.html
%%PORTDOCS%%%%DOCSDIR%%/qwt__plot__svgitem_8cpp-source.html
@@ -902,6 +907,7 @@ lib/libqwt.so.5
%%PORTDOCS%%%%DOCSDIR%%/tabs.css
%%PORTDOCS%%%%DOCSDIR%%/todo.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%DESIGNER_PLUGIN%%@dirrmtry lib/plugins/designer
-%%DESIGNER_PLUGIN%%@dirrmtry lib/plugins
+%%DESIGNER_PLUGIN%%@dirrmtry lib/qt4/plugins/designer
+%%DESIGNER_PLUGIN%%@dirrmtry lib/qt4/plugins
+%%DESIGNER_PLUGIN%%@dirrmtry lib/qt4
@dirrm include/qwt