aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/qwt6-designerplugin/Makefile
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-07-24 15:59:51 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-07-24 15:59:51 +0000
commit1780acf1bf594e43200c3266b04bd49756b89bd1 (patch)
tree6e29a044f2511c304a63a1dc284ae897b7b3cb65 /x11-toolkits/qwt6-designerplugin/Makefile
parent165386783ba6531e28f1bca60cd816a88a4f565f (diff)
Notes
Diffstat (limited to 'x11-toolkits/qwt6-designerplugin/Makefile')
-rw-r--r--x11-toolkits/qwt6-designerplugin/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-toolkits/qwt6-designerplugin/Makefile b/x11-toolkits/qwt6-designerplugin/Makefile
new file mode 100644
index 000000000000..3a6e11e33500
--- /dev/null
+++ b/x11-toolkits/qwt6-designerplugin/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: qwt5-designerplugin
+# Date created: 2010-07-02
+# Whom: Max Brazhnikov <makc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qwt
+PORTVERSION= 5.2.1
+CATEGORIES= x11-toolkits
+MASTER_SITES= SF
+PKGNAMESUFFIX= -designerplugin
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT= Qt Designer plugin for Qwt
+
+LIB_DEPENDS= qwt.5:${PORTSDIR}/x11-toolkits/qwt5
+
+USE_QT_VER= 4
+QT_COMPONENTS= designer moc_build qmake_build rcc_build
+USE_BZIP2= yes
+USE_GMAKE= yes
+QMAKE_ARGS+= -unix -recursive CONFIG+=QwtDesigner \
+ PLUGINDIR=${PREFIX}/${QT_PLUGINDIR_REL}
+HAS_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+
+STRIP_FILES= ${QT_PLUGINDIR_REL}/designer/libqwt_designer_plugin.so
+
+CONFIGURE_WRKSRC= ${WRKSRC}/designer
+BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
+INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
+
+do-configure:
+ (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS} ${QMAKE_ARGS})
+
+post-install:
+ ${STRIP_CMD} ${STRIP_FILES:S,^,${PREFIX}/,}
+
+.include <bsd.port.mk>