aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/redkite
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-08-07 01:35:26 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-08-07 01:35:26 +0000
commitb6cf58dffd1c449df79649b63f30e60aeee49c6f (patch)
tree1981a31fa798f6f0a4b4a45e695825cf147279c0 /x11-toolkits/redkite
parentcebeccadcd1ea697b280fc2257dde02eb68cc3f0 (diff)
downloadports-b6cf58dffd1c449df79649b63f30e60aeee49c6f.tar.gz
ports-b6cf58dffd1c449df79649b63f30e60aeee49c6f.zip
Notes
Diffstat (limited to 'x11-toolkits/redkite')
-rw-r--r--x11-toolkits/redkite/Makefile24
-rw-r--r--x11-toolkits/redkite/distinfo3
-rw-r--r--x11-toolkits/redkite/files/patch-CMakeLists.txt20
-rw-r--r--x11-toolkits/redkite/pkg-descr4
-rw-r--r--x11-toolkits/redkite/pkg-plist23
5 files changed, 74 insertions, 0 deletions
diff --git a/x11-toolkits/redkite/Makefile b/x11-toolkits/redkite/Makefile
new file mode 100644
index 000000000000..279f1630b2fb
--- /dev/null
+++ b/x11-toolkits/redkite/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= redkite
+DISTVERSIONPREFIX= v
+DISTVERSION= v0.6-4
+DISTVERSIONSUFFIX= -gad49c91
+CATEGORIES= x11-toolkits
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= GUI toolkit
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake compiler:c++14-lang gnome localbase:ldflags
+USE_GITHUB= yes
+GH_ACCOUNT= quamplex
+USE_GNOME= cairo
+USE_LDCONFIG= yes
+
+CMAKE_ARGS= -DCMAKE_INSTALL_LIBDIR=${PREFIX}/lib
+CMAKE_OFF= ENABLE_EXAMPLES
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/redkite/distinfo b/x11-toolkits/redkite/distinfo
new file mode 100644
index 000000000000..8c041d39338e
--- /dev/null
+++ b/x11-toolkits/redkite/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1565141035
+SHA256 (quamplex-redkite-vv0.6-4-gad49c91_GH0.tar.gz) = eedc7a3bd25038b835e4220c2dae325aefd9ad6bb028d3416d9d5bc717ddfaa2
+SIZE (quamplex-redkite-vv0.6-4-gad49c91_GH0.tar.gz) = 122164
diff --git a/x11-toolkits/redkite/files/patch-CMakeLists.txt b/x11-toolkits/redkite/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..5e725baec9f6
--- /dev/null
+++ b/x11-toolkits/redkite/files/patch-CMakeLists.txt
@@ -0,0 +1,20 @@
+--- CMakeLists.txt.orig 2019-08-06 19:58:51 UTC
++++ CMakeLists.txt
+@@ -10,6 +10,8 @@ elseif(CMAKE_SYSTEM_NAME MATCHES Darwin)
+ message(FATAL_ERROR "Redkite not implemented yet for Mac OS X")
+ elseif (CMAKE_SYSTEM_NAME MATCHES Linux)
+ message(STATUS " Build Redkite for GNU/Linux")
++elseif (CMAKE_SYSTEM_NAME MATCHES "^(FreeBSD|DragonFly)$")
++ message(STATUS " Build Redkite for FreeBSD")
+ else()
+ message(FATAL_ERROR "Redkite not implemented yet for ${CMAKE_SYSTEM_NAME}")
+ endif()
+@@ -174,7 +176,7 @@ else() # defualt GNU/Linux
+ include_directories(${RK_INCLUDE_PATH}/impl/platforms/xwin)
+ endif()
+
+-add_library(redkite STATIC
++add_library(redkite SHARED
+ ${RK_HEADERS}
+ ${RK_HEADERS_IMPL}
+ ${RK_HEADERS_PLATFORM}
diff --git a/x11-toolkits/redkite/pkg-descr b/x11-toolkits/redkite/pkg-descr
new file mode 100644
index 000000000000..08125c592290
--- /dev/null
+++ b/x11-toolkits/redkite/pkg-descr
@@ -0,0 +1,4 @@
+Redkite is a small free software and cross-platform GUI toolkit. It is inspired
+from other well known GUI toolkits.
+
+WWW: https://github.com/iurienistor/redkite
diff --git a/x11-toolkits/redkite/pkg-plist b/x11-toolkits/redkite/pkg-plist
new file mode 100644
index 000000000000..1ef534236468
--- /dev/null
+++ b/x11-toolkits/redkite/pkg-plist
@@ -0,0 +1,23 @@
+bin/rkpng2c
+include/redkite/Rk.h
+include/redkite/RkCanvas.h
+include/redkite/RkColor.h
+include/redkite/RkEvent.h
+include/redkite/RkEventQueue.h
+include/redkite/RkFont.h
+include/redkite/RkImage.h
+include/redkite/RkLabel.h
+include/redkite/RkLineEdit.h
+include/redkite/RkLog.h
+include/redkite/RkMain.h
+include/redkite/RkPainter.h
+include/redkite/RkPen.h
+include/redkite/RkPlatform.h
+include/redkite/RkPoint.h
+include/redkite/RkProgressBar.h
+include/redkite/RkRealPoint.h
+include/redkite/RkRect.h
+include/redkite/RkSize.h
+include/redkite/RkTimer.h
+include/redkite/RkWidget.h
+lib/libredkite.so