aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/rep-gtk/Makefile
diff options
context:
space:
mode:
authorYukihiro Nakai <nakai@FreeBSD.org>2000-03-08 12:11:22 +0000
committerYukihiro Nakai <nakai@FreeBSD.org>2000-03-08 12:11:22 +0000
commitd142e625ccd5c8e598a5148ab6a3a0ad714afb43 (patch)
tree680fbf76c8885e6a8ab4acdb0d097ee1a389dbf8 /x11-toolkits/rep-gtk/Makefile
parent8103cc9c74d51b8f9a92b90a04f60e2c9b53b595 (diff)
downloadports-d142e625ccd5c8e598a5148ab6a3a0ad714afb43.tar.gz
ports-d142e625ccd5c8e598a5148ab6a3a0ad714afb43.zip
Notes
Diffstat (limited to 'x11-toolkits/rep-gtk/Makefile')
-rw-r--r--x11-toolkits/rep-gtk/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/x11-toolkits/rep-gtk/Makefile b/x11-toolkits/rep-gtk/Makefile
index c6db42574282..dffe3f25839a 100644
--- a/x11-toolkits/rep-gtk/Makefile
+++ b/x11-toolkits/rep-gtk/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: rep-gtk
-# Version required: 0.8
+# Version required: 0.9.1
# Date created: 06 October 1999
# Whom: Yukihiro Nakai <nakai@FreeBSD.org>
#
# $FreeBSD$
#
-DISTNAME= rep-gtk-0.8
+DISTNAME= rep-gtk-0.9.1
CATEGORIES= x11-toolkits
MASTER_SITES= ftp://rep-gtk.sourceforge.net/pub/rep-gtk/
@@ -14,7 +14,8 @@ MAINTAINER= nakai@FreeBSD.org
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
.if !defined(NOGNOME)
-LIB_DEPENDS+= glade.2:${PORTSDIR}/devel/libglade
+LIB_DEPENDS+= glade.2:${PORTSDIR}/devel/libglade \
+ gnome.3:${PORTSDIR}/x11/gnomelibs
.endif
BUILD_DEPENDS= rep:${PORTSDIR}/lang/librep
@@ -26,7 +27,9 @@ PLIST_SUB= GNUHOST=${ARCH}--freebsd${OSREL}
USE_GMAKE= yes
GNU_CONFIGURE= yes
.if defined(NOGNOME)
-CONFIGURE_ARGS= --without-libglade
+CONFIGURE_ARGS= --without-libglade --without-gnome
+.else
+CONFIGURE_ARGS= --with-gnome
.endif
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GTK_CONFIG="${GTK_CONFIG}" \