aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/ruby-fox10/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-03-06 14:13:50 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-03-06 14:13:50 +0000
commit7f5566219c3956e65cef4bcd426412c402adae42 (patch)
tree2c54ecf195a1797e41d248ecfdab9a81ef5b7ee2 /x11-toolkits/ruby-fox10/Makefile
parent62da2095477f1483028760ec16a4b3f4ccddd11f (diff)
downloadports-7f5566219c3956e65cef4bcd426412c402adae42.tar.gz
ports-7f5566219c3956e65cef4bcd426412c402adae42.zip
Notes
Diffstat (limited to 'x11-toolkits/ruby-fox10/Makefile')
-rw-r--r--x11-toolkits/ruby-fox10/Makefile55
1 files changed, 55 insertions, 0 deletions
diff --git a/x11-toolkits/ruby-fox10/Makefile b/x11-toolkits/ruby-fox10/Makefile
new file mode 100644
index 000000000000..0ff338c66f91
--- /dev/null
+++ b/x11-toolkits/ruby-fox10/Makefile
@@ -0,0 +1,55 @@
+# New ports collection makefile for: FXRuby
+# Date created: 24 February 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fox
+PORTVERSION= 0.99.161
+CATEGORIES= x11-toolkits ruby
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= fxruby
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= FXRuby-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+#BUILD_DEPENDS= swig1.3:${PORTSDIR}/devel/SWIG-devel
+LIB_DEPENDS= FOX.1:${PORTSDIR}/x11-toolkits/fox \
+ png.4:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+USE_XLIB= yes
+USE_MESA= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+INSTALL_TARGET= site-install
+CONFIGURE_ARGS= --with-fox-include="${LOCALBASE}/include/fox" \
+ --with-fox-lib="${LOCALBASE}/lib"
+#MAKE_ARGS= LOCAL_LIBS="-lgcc"
+
+DOCS_EN= README index.html
+
+post-patch:
+ ${RUBY} -i -pe 'sub %r:/usr/X11R6\b:, "${X11BASE}"' ${WRKSRC}/extconf.rb
+
+pre-build:
+# cd ${WRKSRC}/../swig-interfaces; ${MAKE}
+ ${RUBY} -i -pe 'sub %r:^CXXFLAGS *=.*:, "CXXFLAGS = $$(CFLAGS) $$(CPPFLAGS)"' ${WRKSRC}/Makefile
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/fox
+ ${INSTALL_DATA} ${WRKSRC}/../examples/* ${RUBY_EXAMPLESDIR}/fox/
+ ${MKDIR} ${RUBY_DOCDIR}/fox
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/../${f} ${RUBY_DOCDIR}/fox/
+.endfor
+.endif
+
+.include <bsd.port.mk>