aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/ruby-gnomeprintui/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2008-07-07 03:27:45 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2008-07-07 03:27:45 +0000
commit453bf8ce7a9a41a7b88a682a6c093bb243d1e404 (patch)
treead46b6ca88a3bfcf98ddb7f78ffa103e0cc8baa3 /x11-toolkits/ruby-gnomeprintui/Makefile
parentadff482a33a8297df32f79793367001abd7561ed (diff)
- Update to 0.16.0.20080706, it's more than 0.17 RC1.
- ${RUBY_SITEARCHLIBDIR} -> ${RUBY_SITEARCHLIBDIR:S/${PREFIX}/${LOCALBASE}/} in the *_DEPENDS, that way it will finding correct file when I tweak the PREFIX. - NOPORTDOCS -> NOPORTEXAMPLES on example/demo/test files.
Notes
Notes: svn path=/head/; revision=216428
Diffstat (limited to 'x11-toolkits/ruby-gnomeprintui/Makefile')
-rw-r--r--x11-toolkits/ruby-gnomeprintui/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/x11-toolkits/ruby-gnomeprintui/Makefile b/x11-toolkits/ruby-gnomeprintui/Makefile
index 3a8f3b73465f..eea3d02b3e00 100644
--- a/x11-toolkits/ruby-gnomeprintui/Makefile
+++ b/x11-toolkits/ruby-gnomeprintui/Makefile
@@ -8,7 +8,6 @@
PORTNAME= gnomeprintui
PORTVERSION= ${RUBY_GNOME_PORTVERSION}
-PORTREVISION= 1
CATEGORIES= x11-toolkits ruby gnome
MASTER_SITES= ${RUBY_GNOME_MASTER_SITES}
MASTER_SITE_SUBDIR= ${RUBY_GNOME_MASTER_SITE_SUBDIR}
@@ -19,8 +18,8 @@ DIST_SUBDIR= ruby
MAINTAINER= mezz@FreeBSD.org
COMMENT= Ruby binding for libgnomeprintui
-RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/gtk2.so:${PORTSDIR}/x11-toolkits/ruby-gtk2 \
- ${RUBY_SITEARCHLIBDIR}/gnomeprint2.so:${PORTSDIR}/print/ruby-gnomeprint
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR:S/${PREFIX}/${LOCALBASE}/}/gtk2.so:${PORTSDIR}/x11-toolkits/ruby-gtk2 \
+ ${RUBY_SITEARCHLIBDIR:S/${PREFIX}/${LOCALBASE}/}/gnomeprint2.so:${PORTSDIR}/print/ruby-gnomeprint
USE_RUBY= yes
USE_GNOME= libgnomeprintui
@@ -42,9 +41,11 @@ pre-configure:
${RUBY} ${RUBY_FLAGS} ${RUBY_EXTCONF} ${CONFIGURE_ARGS})
post-install:
-.if !defined(NOPORTDOCS)
+.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${RUBY_MODEXAMPLESDIR}
@${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_MODEXAMPLESDIR}/
+.endif
+.if !defined(NOPORTDOCS)
@${MKDIR} ${RUBY_MODDOCDIR}
.for f in ${DOCS}
@${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/