aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/ruby-qt2
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-03-19 22:15:52 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-03-19 22:15:52 +0000
commit6abf760566c8eae0c89d0fed5cca2a9a0fc03b5c (patch)
tree2c8f25241d1d2e433fa822ee05905813062a7f77 /x11-toolkits/ruby-qt2
parent60efde8367ec048ce37709d84cfc81c34518f197 (diff)
downloadports-6abf760566c8eae0c89d0fed5cca2a9a0fc03b5c.tar.gz
ports-6abf760566c8eae0c89d0fed5cca2a9a0fc03b5c.zip
Notes
Diffstat (limited to 'x11-toolkits/ruby-qt2')
-rw-r--r--x11-toolkits/ruby-qt2/Makefile9
-rw-r--r--x11-toolkits/ruby-qt2/Makefile.common16
2 files changed, 20 insertions, 5 deletions
diff --git a/x11-toolkits/ruby-qt2/Makefile b/x11-toolkits/ruby-qt2/Makefile
index 68f13879d1f1..3cda39abdb7b 100644
--- a/x11-toolkits/ruby-qt2/Makefile
+++ b/x11-toolkits/ruby-qt2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= qt2
PORTVERSION= ${RUBY_QT2_PORTVERSION}
+PORTREVISION= 1
CATEGORIES= x11-toolkits ruby
MASTER_SITES= ${RUBY_QT2_MASTER_SITES}
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -22,13 +23,11 @@ USE_RUBY_EXTCONF= yes
USE_GMAKE= yes
+.include <bsd.port.pre.mk>
.include "${.CURDIR}/Makefile.common"
WRKSRC= ${RUBY_QT2_WRKSRC}
-CONFIGURE_ARGS= --with-qt2-include=${X11BASE}/include/qt2 \
- --with-qt2-lib=${X11BASE}/lib \
- --with-qt2=qt2 \
- --with-x11-dir=${X11BASE}
+CONFIGURE_ARGS= ${RUBY_QT2_CONFIGURE_ARGS}
MAKE_ARGS= LOCAL_LIBS=-lgcc
INSTALL_TARGET= site-install
@@ -48,4 +47,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README.jp ${RUBY_DOCDIR}/${PORTNAME}/ja/
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/ruby-qt2/Makefile.common b/x11-toolkits/ruby-qt2/Makefile.common
index 27b6ce208b43..83a6e0b16bd1 100644
--- a/x11-toolkits/ruby-qt2/Makefile.common
+++ b/x11-toolkits/ruby-qt2/Makefile.common
@@ -8,5 +8,21 @@ RUBY_QT2_DISTNAME= ruby-qt2-${RUBY_QT2_VERSION}
RUBY_QT2_PORTDIR= ${PORTSDIR}/x11-toolkits/ruby-qt2
RUBY_QT2_WRKSRC= ${WRKDIR}/qt2
+RUBY_QT2_CONFIGURE_ARGS= \
+ --with-qt2-include=${X11BASE}/include/qt2 \
+ --with-qt2-lib=${X11BASE}/lib \
+ --with-x11-dir=${X11BASE}
+.if ${OSVERSION} >= 500018
+RUBY_QT2_CONFIGURE_ARGS+= \
+ --with-ldflags=-lc_r \
+ --with-qt2=qt2-mt
+.else
+.if ${PORTNAME} == qt2gl
+BROKEN= "Qt2's GL support is only supported on 5-CURRENT due to a problem with the thread library."
+.endif
+
+RUBY_QT2_CONFIGURE_ARGS+= \
+ --with-qt2=qt2
+.endif
MD5_FILE= ${RUBY_QT2_PORTDIR}/distinfo