aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/ruby-wx
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2005-05-30 14:58:42 +0000
committerMax Khon <fjoe@FreeBSD.org>2005-05-30 14:58:42 +0000
commitb804c3fea90ffb69e89bfcaadef492aa18c9dab7 (patch)
treea11846d5e4d3787f36038c6cdb02e8efdd34277c /x11-toolkits/ruby-wx
parent4a9e32b0cc3e9c966d7605add6aa87a9ff21df53 (diff)
Notes
Diffstat (limited to 'x11-toolkits/ruby-wx')
-rw-r--r--x11-toolkits/ruby-wx/Makefile2
-rw-r--r--x11-toolkits/ruby-wx/files/patch-extconf.rb16
2 files changed, 11 insertions, 7 deletions
diff --git a/x11-toolkits/ruby-wx/Makefile b/x11-toolkits/ruby-wx/Makefile
index ea19dbb3c26f..dddedf65035e 100644
--- a/x11-toolkits/ruby-wx/Makefile
+++ b/x11-toolkits/ruby-wx/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wx
PORTVERSION= 0.6.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits ruby
MASTER_SITES= http://rubyforge.org/frs/download.php/1983/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
diff --git a/x11-toolkits/ruby-wx/files/patch-extconf.rb b/x11-toolkits/ruby-wx/files/patch-extconf.rb
index b018405af9f1..8efacb0c6bd1 100644
--- a/x11-toolkits/ruby-wx/files/patch-extconf.rb
+++ b/x11-toolkits/ruby-wx/files/patch-extconf.rb
@@ -1,15 +1,19 @@
---- extconf.rb.orig Wed Nov 17 15:56:22 2004
-+++ extconf.rb Fri Feb 11 00:42:43 2005
+--- extconf.rb.orig Wed Nov 17 20:56:22 2004
++++ extconf.rb Mon May 30 21:50:18 2005
@@ -32,13 +32,16 @@
end
-if /linux/ =~ RUBY_PLATFORM or /i386-freebsd/ =~ RUBY_PLATFORM
+- CONFIG['CC'] = `wx-config --cxx`
+- CONFIG['LDSHARED'].gsub!("gcc",`wx-config --cxx`.strip)
+- $CFLAGS += " `wx-config --cxxflags`"
+- $LDFLAGS += " `wx-config --libs` -Wl,--version-script,./version-script "
+if /linux/ =~ RUBY_PLATFORM or /freebsd/ =~ RUBY_PLATFORM
- CONFIG['CC'] = `wx-config --cxx`
- CONFIG['LDSHARED'].gsub!("gcc",`wx-config --cxx`.strip)
- $CFLAGS += " `wx-config --cxxflags`"
- $LDFLAGS += " `wx-config --libs` -Wl,--version-script,./version-script "
++ CONFIG['CC'] = `wxgtk2-2.4-config --cxx`
++ CONFIG['LDSHARED'].gsub!("gcc",`wxgtk2-2.4-config --cxx`.strip)
++ $CFLAGS += " `wxgtk2-2.4-config --cxxflags`"
++ $LDFLAGS += " `wxgtk2-2.4-config --libs` -Wl,--version-script,./version-script "
["htmlprocessor.o", "htmlwindow.o", "htmleasyprinting.o"].each do |str|
$objs.delete(str)
+ end