aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/scintilla/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-29 19:48:33 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-29 19:48:33 +0000
commit1918a693d9161b8f13a13fe746f8882c7305ec94 (patch)
tree8f70940b79c37089aa4efc5efcaec2a2597a89d3 /x11-toolkits/scintilla/Makefile
parent8e353ac55899c69618124c2ca8ca94456bac016b (diff)
downloadports-1918a693d9161b8f13a13fe746f8882c7305ec94.tar.gz
ports-1918a693d9161b8f13a13fe746f8882c7305ec94.zip
Notes
Diffstat (limited to 'x11-toolkits/scintilla/Makefile')
-rw-r--r--x11-toolkits/scintilla/Makefile20
1 files changed, 17 insertions, 3 deletions
diff --git a/x11-toolkits/scintilla/Makefile b/x11-toolkits/scintilla/Makefile
index 36c4c45d8de2..b3b52dd6512d 100644
--- a/x11-toolkits/scintilla/Makefile
+++ b/x11-toolkits/scintilla/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= scintilla
-PORTVERSION= 1.54
+PORTVERSION= 1.55
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.scintilla.org/
@@ -21,9 +21,23 @@ WRKSRC= ${WRKDIR}/${PORTNAME}/gtk
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gtk12
-INSTALLS_SHLIB= yes
MAKEFILE= makefile
+INSTALLS_SHLIB= yes
+
+.if defined(WITH_GTK2)
+USE_GNOME= gtk20
+PKGNAMESUFFIX= -gtk2
+.else
+USE_GNOME= gtk12
+MAKE_ARGS= GTK1=yes
+.endif
+
+post-extract:
+.for i in PlatGTK.cxx ScintillaGTK.cxx
+ @cd ${WRKSRC} \
+ && ${MV} ${i} ${i}.pre_tr \
+ && ${TR} -d '\r' < ${i}.pre_tr > ${i}
+.endfor
do-install:
${MKDIR} ${PREFIX}/include/scintilla