aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/scintilla
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-04-17 11:27:22 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-04-17 11:27:22 +0000
commit941461be1f1ac311fd101949c0b124723ace777b (patch)
tree15d6c84055a073d6ff185509a676b62d615b5d27 /x11-toolkits/scintilla
parentcafec0c53a5e0cb9dd948018a258970727d6343c (diff)
downloadports-941461be1f1ac311fd101949c0b124723ace777b.tar.gz
ports-941461be1f1ac311fd101949c0b124723ace777b.zip
Notes
Diffstat (limited to 'x11-toolkits/scintilla')
-rw-r--r--x11-toolkits/scintilla/Makefile2
-rw-r--r--x11-toolkits/scintilla/distinfo2
-rw-r--r--x11-toolkits/scintilla/files/patch-aa32
-rw-r--r--x11-toolkits/scintilla/pkg-plist1
4 files changed, 18 insertions, 19 deletions
diff --git a/x11-toolkits/scintilla/Makefile b/x11-toolkits/scintilla/Makefile
index f972af31fef3..7d4071ec8692 100644
--- a/x11-toolkits/scintilla/Makefile
+++ b/x11-toolkits/scintilla/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= scintilla
-PORTVERSION= 1.36
+PORTVERSION= 1.37
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.scintilla.org/
diff --git a/x11-toolkits/scintilla/distinfo b/x11-toolkits/scintilla/distinfo
index 8cb605b48339..6fc0cf5e5f24 100644
--- a/x11-toolkits/scintilla/distinfo
+++ b/x11-toolkits/scintilla/distinfo
@@ -1 +1 @@
-MD5 (scite136.tgz) = 037829f907809630ff77278ea63ba173
+MD5 (scite137.tgz) = 157c67f633b1b69f297869112e8141d4
diff --git a/x11-toolkits/scintilla/files/patch-aa b/x11-toolkits/scintilla/files/patch-aa
index 4c0e81776908..d99d741cb65f 100644
--- a/x11-toolkits/scintilla/files/patch-aa
+++ b/x11-toolkits/scintilla/files/patch-aa
@@ -1,15 +1,15 @@
$FreeBSD$
---- makefile.orig Thu Feb 1 10:12:22 2001
-+++ makefile Fri Mar 2 11:12:31 2001
-@@ -5,38 +5,42 @@
+--- makefile.orig Sun Apr 15 10:24:36 2001
++++ makefile Tue Apr 17 14:04:58 2001
+@@ -5,10 +5,11 @@
# GNU make does not like \r\n line endings so should be saved to CVS in binary form.
.SUFFIXES: .cxx .o .h .a
-CC = g++
-AR = ar
-+CC ?= c++
++CC ?= g++
+AR = $(CC) -shared
-COMPLIB=../bin/scintilla.a
@@ -18,10 +18,8 @@ $FreeBSD$
vpath %.h ../src ../include
vpath %.cxx ../src
-
- INCLUDEDIRS=-I ../include -I ../src
--CXXBASEFLAGS= -DGTK -DSCI_LEXER -W -Wall
-+CXXBASEFLAGS= -DGTK -DSCI_LEXER -W -Wall $(shell $(GTK_CONFIG) --cflags)
+@@ -17,20 +18,20 @@
+ CXXBASEFLAGS=-W -Wall -DGTK -DSCI_LEXER $(INCLUDEDIRS)
ifdef DEBUG
-CXXFLAGS=-DDEBUG $(CXXBASEFLAGS)
@@ -32,26 +30,28 @@ $FreeBSD$
endif
.cxx.o:
-- $(CC) `gtk-config --cflags` $(INCLUDEDIRS) $(CXXFLAGS) -c $< -o $@
-+ $(CC) -DPIC -fPIC -fpic $(INCLUDEDIRS) $(CXXFLAGS) -c $< -o $@
+- $(CC) `gtk-config --cflags` $(CXXFLAGS) -c $<
++ $(CC) -DPIC -fPIC -fpic $(shell $(GTK_CONFIG) --cflags) $(CXXFLAGS) -c $<
- LEXOBJS = LexAVE.o LexConf.o LexCPP.o LexHTML.o LexLua.o LexOthers.o \
- LexPascal.o LexPerl.o LexPython.o LexSQL.o LexVB.o
+ LEXOBJS = LexAda.o LexAVE.o LexConf.o LexCPP.o LexHTML.o LexLua.o \
+ LexOthers.o LexPascal.o LexPerl.o LexPython.o LexSQL.o LexVB.o
# The LEXOBJS have to be treated specially as the functions in them are not called from external code
-all: $(COMPLIB) $(LEXOBJS)
+all: $(COMPLIB) $(LEXRLIB)
- $(COMPLIB): DocumentAccessor.o WindowAccessor.o KeyWords.o Document.o CallTip.o \
+ clean:
+ rm -f *.o $(COMPLIB)
+@@ -42,7 +43,10 @@
ScintillaBase.o ContractionState.o Editor.o PropSet.o PlatGTK.o \
KeyMap.o LineMarker.o ScintillaGTK.o CellBuffer.o ViewStyle.o \
- Style.o Indicator.o AutoComplete.o
+ RESearch.o Style.o Indicator.o AutoComplete.o
- $(AR) rc $@ $^
+ $(AR) -o $@ $^
+
+$(LEXRLIB): $(LEXOBJS)
+ $(AR) -o $@ $^
- AutoComplete.o: AutoComplete.cxx Platform.h AutoComplete.h
- CallTip.o: CallTip.cxx Platform.h CallTip.h
+ # Automatically generate header dependencies with "make deps"
+ include deps.mak
diff --git a/x11-toolkits/scintilla/pkg-plist b/x11-toolkits/scintilla/pkg-plist
index d96ef82f658e..8ae2e8ebc3c6 100644
--- a/x11-toolkits/scintilla/pkg-plist
+++ b/x11-toolkits/scintilla/pkg-plist
@@ -1,7 +1,6 @@
include/scintilla/Accessor.h
include/scintilla/KeyWords.h
include/scintilla/Platform.h
-include/scintilla/PosRegExp.h
include/scintilla/PropSet.h
include/scintilla/SString.h
include/scintilla/SciLexer.h