aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/sdl_gui
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-08-13 07:17:47 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-08-13 07:17:47 +0000
commit96ff57257e7dc25225a7d242d505608ae6a590f9 (patch)
tree2937fb2f7e5a7cc0021cfa138821eb77ea44d2ff /x11-toolkits/sdl_gui
parent984590a5e37dbc239f3c3b8cc96eca493ee961cc (diff)
downloadports-96ff57257e7dc25225a7d242d505608ae6a590f9.tar.gz
ports-96ff57257e7dc25225a7d242d505608ae6a590f9.zip
Notes
Diffstat (limited to 'x11-toolkits/sdl_gui')
-rw-r--r--x11-toolkits/sdl_gui/Makefile26
-rw-r--r--x11-toolkits/sdl_gui/distinfo1
-rw-r--r--x11-toolkits/sdl_gui/pkg-comment1
-rw-r--r--x11-toolkits/sdl_gui/pkg-descr6
-rw-r--r--x11-toolkits/sdl_gui/pkg-plist5
5 files changed, 39 insertions, 0 deletions
diff --git a/x11-toolkits/sdl_gui/Makefile b/x11-toolkits/sdl_gui/Makefile
new file mode 100644
index 000000000000..b4cb5da4f6de
--- /dev/null
+++ b/x11-toolkits/sdl_gui/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: sdl_gui
+# Date created: Aug 13, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= sdl_gui
+PORTVERSION= 0.10.3
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://www.newimage.com/~rhk/SDL_gui/
+DISTNAME= SDL_gui-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= SDL-1.1:${PORTSDIR}/devel/sdl12 \
+ SDL_image:${PORTSDIR}/graphics/sdl_image \
+ SDL_ttf:${PORTSDIR}/graphics/sdl_ttf
+
+SDL_CONFIG= ${LOCALBASE}/bin/sdl11-config
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/sdl_gui/distinfo b/x11-toolkits/sdl_gui/distinfo
new file mode 100644
index 000000000000..2390a6c03bee
--- /dev/null
+++ b/x11-toolkits/sdl_gui/distinfo
@@ -0,0 +1 @@
+MD5 (SDL_gui-0.10.3.tar.gz) = 3a59241ce6b25b59fc951eaf4ca6a278
diff --git a/x11-toolkits/sdl_gui/pkg-comment b/x11-toolkits/sdl_gui/pkg-comment
new file mode 100644
index 000000000000..8c563d59c246
--- /dev/null
+++ b/x11-toolkits/sdl_gui/pkg-comment
@@ -0,0 +1 @@
+A Graphical User Interface library for SDL
diff --git a/x11-toolkits/sdl_gui/pkg-descr b/x11-toolkits/sdl_gui/pkg-descr
new file mode 100644
index 000000000000..78828eba3de1
--- /dev/null
+++ b/x11-toolkits/sdl_gui/pkg-descr
@@ -0,0 +1,6 @@
+SDL_gui is a library written in C++ for displaying and controlling user
+interface elements in an SDL application. It has the following set of
+widgets: Screen, Button, ToggleButton, Label, Picture, Panel, CardStack,
+TextEntry and ProgressBar.
+
+WWW: http://www.newimage.com/~rhk/SDL_gui/
diff --git a/x11-toolkits/sdl_gui/pkg-plist b/x11-toolkits/sdl_gui/pkg-plist
new file mode 100644
index 000000000000..9bd9e179360c
--- /dev/null
+++ b/x11-toolkits/sdl_gui/pkg-plist
@@ -0,0 +1,5 @@
+include/SDL/SDL_gui.h
+@dirrm include/SDL
+lib/libSDL_gui-0.10.3.so
+lib/libSDL_gui.a
+lib/libSDL_gui.so