aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/soqt
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-06-26 14:29:11 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-06-26 14:29:11 +0000
commit586e52491f7bd939cd3fef091fb6e39d290a4474 (patch)
tree2fb55bacb99a3a3aa3dc4c5210d8292aa62eed27 /x11-toolkits/soqt
parent9ef2d8ff847b1f889287157119142154c5361189 (diff)
downloadports-586e52491f7bd939cd3fef091fb6e39d290a4474.tar.gz
ports-586e52491f7bd939cd3fef091fb6e39d290a4474.zip
Notes
Diffstat (limited to 'x11-toolkits/soqt')
-rw-r--r--x11-toolkits/soqt/Makefile29
-rw-r--r--x11-toolkits/soqt/distinfo1
-rw-r--r--x11-toolkits/soqt/pkg-descr7
-rw-r--r--x11-toolkits/soqt/pkg-plist28
4 files changed, 65 insertions, 0 deletions
diff --git a/x11-toolkits/soqt/Makefile b/x11-toolkits/soqt/Makefile
new file mode 100644
index 000000000000..c56378cb4d58
--- /dev/null
+++ b/x11-toolkits/soqt/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: SoQt
+# Date created: 10 March 2003
+# Whom: roland.jesse@gmx.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= SoQt
+PORTVERSION= 1.0.2
+CATEGORIES= x11-toolkits
+MASTER_SITES= ftp://ftp.coin3d.org/pub/coin/src/
+DIST_SUBDIR= KDE
+
+MAINTAINER= roland.jesse@gmx.net
+COMMENT= Qt toolkit library for Coin
+
+LIB_DEPENDS= Coin.40:${PORTSDIR}/graphics/Coin
+
+USE_QT_VER= 3
+USE_LIBTOOL= yes
+CONFIGURE_ENV+= QTDIR=${QT_PREFIX} CXXFLAGS="-pthread"
+CONFIGURE_ARGS+= --with-pthread=yes --with-coin=${X11BASE}
+# avoid renaming of soqt-config and soqt-config.1
+CONFIGURE_TARGET= --target=""
+MAKE_ENV+= QTDIR=${QT_PREFIX}
+INSTALLS_SHLIB= yes
+MAN1= soqt-config.1
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/soqt/distinfo b/x11-toolkits/soqt/distinfo
new file mode 100644
index 000000000000..318f85277079
--- /dev/null
+++ b/x11-toolkits/soqt/distinfo
@@ -0,0 +1 @@
+MD5 (KDE/SoQt-1.0.2.tar.gz) = 19ad7e1c7b9dcc652c48642ea2599c6f
diff --git a/x11-toolkits/soqt/pkg-descr b/x11-toolkits/soqt/pkg-descr
new file mode 100644
index 000000000000..eb70606270ab
--- /dev/null
+++ b/x11-toolkits/soqt/pkg-descr
@@ -0,0 +1,7 @@
+From the README:
+
+SoQt is a Qt GUI component toolkit library for Coin. It is also compatible
+with SGI and TGS Open Inventor, and the API is based on the API of the
+InventorXt GUI component toolkit.
+
+WWW: http://www.coin3d.org/
diff --git a/x11-toolkits/soqt/pkg-plist b/x11-toolkits/soqt/pkg-plist
new file mode 100644
index 000000000000..53c2b035aa6f
--- /dev/null
+++ b/x11-toolkits/soqt/pkg-plist
@@ -0,0 +1,28 @@
+bin/soqt-config
+include/Inventor/Qt/devices/SoQtDevice.h
+include/Inventor/Qt/devices/SoQtKeyboard.h
+include/Inventor/Qt/devices/SoQtMouse.h
+include/Inventor/Qt/devices/SoQtSpaceball.h
+include/Inventor/Qt/viewers/SoQtViewer.h
+include/Inventor/Qt/viewers/SoQtConstrainedViewer.h
+include/Inventor/Qt/viewers/SoQtFullViewer.h
+include/Inventor/Qt/viewers/SoQtExaminerViewer.h
+include/Inventor/Qt/viewers/SoQtFlyViewer.h
+include/Inventor/Qt/viewers/SoQtPlaneViewer.h
+include/Inventor/Qt/widgets/SoQtPopupMenu.h
+include/Inventor/Qt/SoQt.h
+include/Inventor/Qt/SoQtBasic.h
+include/Inventor/Qt/SoQtObject.h
+include/Inventor/Qt/SoQtCursor.h
+include/Inventor/Qt/SoQtComponent.h
+include/Inventor/Qt/SoQtGLWidget.h
+include/Inventor/Qt/SoQtRenderArea.h
+lib/libSoQt.so.20
+lib/libSoQt.so
+lib/libSoQt.la
+share/aclocal/soqt.m4
+share/Coin/conf/soqt-default.cfg
+@dirrm include/Inventor/Qt/devices
+@dirrm include/Inventor/Qt/viewers
+@dirrm include/Inventor/Qt/widgets
+@dirrm include/Inventor/Qt