aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/swt-devel
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-08-03 21:53:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-08-03 21:53:45 +0000
commit7a922e01bfc18cfe1e785a4c1e76f4997e0cde44 (patch)
tree11f80654f360c8f39698e62449ffcba99b46dfdc /x11-toolkits/swt-devel
parenteedf073f0703afde7b156d800bc1b1748800bb70 (diff)
downloadports-7a922e01bfc18cfe1e785a4c1e76f4997e0cde44.tar.gz
ports-7a922e01bfc18cfe1e785a4c1e76f4997e0cde44.zip
Notes
Diffstat (limited to 'x11-toolkits/swt-devel')
-rw-r--r--x11-toolkits/swt-devel/Makefile1
-rw-r--r--x11-toolkits/swt-devel/distinfo3
-rw-r--r--x11-toolkits/swt-devel/files/patch-os.c21
3 files changed, 22 insertions, 3 deletions
diff --git a/x11-toolkits/swt-devel/Makefile b/x11-toolkits/swt-devel/Makefile
index 63ba81e0b689..99b4b0416181 100644
--- a/x11-toolkits/swt-devel/Makefile
+++ b/x11-toolkits/swt-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= swt-devel
DISTVERSION= 3.3
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= x11-toolkits devel java
MASTER_SITES= ${MASTER_SITE_ECLIPSE}
diff --git a/x11-toolkits/swt-devel/distinfo b/x11-toolkits/swt-devel/distinfo
index f063be8a8337..3fd507757dec 100644
--- a/x11-toolkits/swt-devel/distinfo
+++ b/x11-toolkits/swt-devel/distinfo
@@ -1,6 +1,3 @@
MD5 (swt-3.3-gtk-linux-x86.zip) = 7398cdf9340cb131b76ed98495239520
SHA256 (swt-3.3-gtk-linux-x86.zip) = 08a3b6329c878c99025e9c9b530b65c4315a37ce52e796e89ae6dc62269df163
SIZE (swt-3.3-gtk-linux-x86.zip) = 4448296
-MD5 (swt-3.3-gtk-linux-x86_64.zip) = b0a4b3442e61d2968acecfa18cdd3aa9
-SHA256 (swt-3.3-gtk-linux-x86_64.zip) = f4357ed778da7f0b91b08b0ed67fe2bc907a2c6a1b5808442f6390f56fa85b50
-SIZE (swt-3.3-gtk-linux-x86_64.zip) = 4622274
diff --git a/x11-toolkits/swt-devel/files/patch-os.c b/x11-toolkits/swt-devel/files/patch-os.c
new file mode 100644
index 000000000000..c0f465f77808
--- /dev/null
+++ b/x11-toolkits/swt-devel/files/patch-os.c
@@ -0,0 +1,21 @@
+--- ./os.c 2007-07-22 11:53:22.000000000 +0400
++++ ./os.c 2007-07-22 11:57:56.000000000 +0400
+@@ -17397,11 +17397,16 @@
+ jint rc = 0;
+ OS_NATIVE_ENTER(env, that, realpath_FUNC);
+ if (arg0) if ((lparg0 = (*env)->GetByteArrayElements(env, arg0, NULL)) == NULL) goto fail;
+- if (arg1) if ((lparg1 = (*env)->GetByteArrayElements(env, arg1, NULL)) == NULL) goto fail;
++ if (arg1) {
++ if ((lparg1 = (*env)->GetByteArrayElements(env, arg1, NULL)) == NULL) goto fail;
++ } else
++ lparg1 = malloc(PATH_MAX);
+ rc = (jint)realpath((const char *)lparg0, (char *)lparg1);
+ fail:
+ if (arg1 && lparg1) (*env)->ReleaseByteArrayElements(env, arg1, lparg1, 0);
+ if (arg0 && lparg0) (*env)->ReleaseByteArrayElements(env, arg0, lparg0, 0);
++ if (!arg1 && lparg1 && rc == 0)
++ free(lparg1);
+ OS_NATIVE_EXIT(env, that, realpath_FUNC);
+ return rc;
+ }
+