aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/swt/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-03-26 19:37:41 +0000
committerJohn Marino <marino@FreeBSD.org>2015-03-26 19:37:41 +0000
commit4f6686216b1a8c03056c2c3d8761091beab015f2 (patch)
treec4cb8b7c393a1cfd63e2701a71d5c4dac95431d0 /x11-toolkits/swt/Makefile
parentdb5722415e39af7729000805cda5cd0ed2dd5bca (diff)
x11-toolkits/swt: Add DragonFly support
Bring in fix from dports (port is not maintained)
Notes
Notes: svn path=/head/; revision=382339
Diffstat (limited to 'x11-toolkits/swt/Makefile')
-rw-r--r--x11-toolkits/swt/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/x11-toolkits/swt/Makefile b/x11-toolkits/swt/Makefile
index ec34166faa23..a3665b7f602a 100644
--- a/x11-toolkits/swt/Makefile
+++ b/x11-toolkits/swt/Makefile
@@ -83,6 +83,10 @@ post-extract:
@(cd ${WRKSRC} && ${UNZIP_CMD} -qo "*.zip")
@${RM} -f ${WRKSRC}/*.o ${WRKSRC}/*.so ${WRKSRC}/*.jar
+post-patch:
+ ${SED} -e 's|freebsd|dragonfly|g' ${WRKSRC}/make_freebsd.mak \
+ ${WRKSRC}/make_dragonfly.mak
+
do-install:
@${MKDIR} ${STAGEDIR}${JAVAJARDIR}
${INSTALL_LIB} ${WRKSRC}/libswt-*.so ${STAGEDIR}${PREFIX}/lib