aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/tk83
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-09 09:49:10 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-09 09:49:10 +0000
commit25ea8362a8eb91f875112efac769e67896ae9a36 (patch)
tree33466808ab54bf0b63d5e4569c0324243a54c328 /x11-toolkits/tk83
parented66da00b82767c55935268f2356ab30506b35f2 (diff)
downloadports-25ea8362a8eb91f875112efac769e67896ae9a36.tar.gz
ports-25ea8362a8eb91f875112efac769e67896ae9a36.zip
Notes
Diffstat (limited to 'x11-toolkits/tk83')
-rw-r--r--x11-toolkits/tk83/Makefile16
-rw-r--r--x11-toolkits/tk83/pkg-deinstall.wish22
-rw-r--r--x11-toolkits/tk83/pkg-install.wish32
3 files changed, 12 insertions, 58 deletions
diff --git a/x11-toolkits/tk83/Makefile b/x11-toolkits/tk83/Makefile
index a5141c031f72..d129dbf7af6f 100644
--- a/x11-toolkits/tk83/Makefile
+++ b/x11-toolkits/tk83/Makefile
@@ -13,10 +13,11 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tcl
DISTNAME= ${PORTNAME}${PORTVERSION}-src
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= martin@matuska.org
COMMENT= Graphical toolkit for TCL
-LIB_DEPENDS= tcl83.1:${PORTSDIR}/${TCL83_PORT}
+USE_TCL= 83
+USE_TCL_BUILD= 83
LATEST_LINK= tk83
USE_XLIB= yes
@@ -36,9 +37,16 @@ NOPRECIOUSMAKEVARS= Too many _MLINKS for README.html
TCL83_PORT?= lang/tcl83
MANCOMPRESSED= no
+OPTIONS= TK83_MAN "Install tk 8.3 manpages" on \
+ WISH_WRAPPER "Require wish wrapper from ports" off
+
.include <bsd.port.pre.mk>
-.if defined(WITH_TK83_MAN)
+.if defined(WITH_WISH_WRAPPER)
+RUN_DEPENDS+= wish:${PORTSDIR}/lang/tcl-tk-wrapper
+.endif
+
+.if !defined(NO_INSTALL_MANPAGES) && defined(WITH_TK83_MAN)
MAN1= wish.1
MAN3= 3DBorder.3 AddOption.3 BindTable.3 CanvPsY.3 CanvTkwin.3 \
@@ -330,7 +338,7 @@ post-configure:
${REINPLACE_CMD} \
-e 's|${WRKDIRPREFIX}${.CURDIR}|$${WRKDIRPREFIX}${TKBASE}|' \
${WRKSRC}/tkConfig.sh
-.if !defined(WITH_TK83_MAN)
+.if defined(NO_INSTALL_MANPAGES) || !defined(WITH_TK83_MAN)
${REINPLACE_CMD} -e 's|^MAN_INSTALL_DIR.*$$|MAN_INSTALL_DIR = ${WRKDIR}|' \
${WRKSRC}/Makefile
.endif
diff --git a/x11-toolkits/tk83/pkg-deinstall.wish b/x11-toolkits/tk83/pkg-deinstall.wish
deleted file mode 100644
index 20ca9e8436c4..000000000000
--- a/x11-toolkits/tk83/pkg-deinstall.wish
+++ /dev/null
@@ -1,22 +0,0 @@
-#! /bin/sh
-#
-# Remove the ${PREFIX}/bin/wish script that gets installed by INSTALL.wish
-# if we are the last wish installation to be pkg_delete'd.
-#
-# $FreeBSD$
-#
-
-#
-# Explicitly listing /usr/X11R6/bin here is debatable.
-#
-BINDIR="${PKG_PREFIX}/bin /usr/X11R6/bin"
-WISH=${PKG_PREFIX}/bin/wish
-
-wishes=$(/bin/ls ${BINDIR} 2> /dev/null | \
- egrep '^o?wish(step)?(x|([0-9]+\.[0-9]+))([a-z][a-z])?$')
-
-if [ "$wishes" = "" -a -f ${WISH} ] && \
- (head -3 ${WISH} | grep awieYJFnsuILOnfsYEW) > /dev/null 2>&1
-then
- rm -f ${PKG_PREFIX}/bin/wish
-fi
diff --git a/x11-toolkits/tk83/pkg-install.wish b/x11-toolkits/tk83/pkg-install.wish
deleted file mode 100644
index d526f076a498..000000000000
--- a/x11-toolkits/tk83/pkg-install.wish
+++ /dev/null
@@ -1,32 +0,0 @@
-#!/bin/sh
-
-# The user may have a wish they want to preserve
-ver=`grep -a awieYJFnsuILOnfsYEW ${PKG_PREFIX}/bin/wish 2> /dev/null \
- | sed -e 's/.*\*\*//'`
-if [ ! -e ${PKG_PREFIX}/bin/wish ] || [ "$ver" != "" -a "$ver" -lt 001 ]
-then
- [ -f ${PKG_PREFIX}/bin/wish ] && chmod u+w ${PKG_PREFIX}/bin/wish
-
- mkdir -p ${PKG_PREFIX}/bin
- cat > ${PKG_PREFIX}/bin/wish <<'EOF'
-#!/bin/sh
-# Installed by ports system. id: awieYJFnsuILOnfsYEW**001
-
-(
-echo "In FreeBSD, wish is named with a version number. This is because"
-echo "different versions of wish are not compatible with each other and"
-echo "they can not all be called \"wish\"! You may need multiple versions"
-echo "installed because a given port may depend on a specific version."
-echo
-echo "On your system, wish is installed under at least the following names:"
-echo
-for name in $(/bin/ls $(echo $PATH | sed 's/:/ /g') 2> /dev/null | egrep '^wish(step)?(x|([0-9]+\.[0-9]+))([a-z][a-z])?$')
-do
- echo $name
-done
-[ "$name" = "" ] && echo "No wish installations found, sorry."
-) 1>&2
-exit 1
-EOF
- chmod a+rx ${PKG_PREFIX}/bin/wish
-fi