aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/tk84/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-08-17 05:00:53 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-08-17 05:00:53 +0000
commitbf30172cbf5f17badcfff40a747d1d7747b84c91 (patch)
treebad742ae8a2852a8ad8201c28a63a409af67c164 /x11-toolkits/tk84/Makefile
parent866436d78f6dbd7b614c00956ac85fa0e72753b6 (diff)
downloadports-bf30172cbf5f17badcfff40a747d1d7747b84c91.tar.gz
ports-bf30172cbf5f17badcfff40a747d1d7747b84c91.zip
Notes
Diffstat (limited to 'x11-toolkits/tk84/Makefile')
-rw-r--r--x11-toolkits/tk84/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/x11-toolkits/tk84/Makefile b/x11-toolkits/tk84/Makefile
index 9aaa7c39e6f5..82767bacfedd 100644
--- a/x11-toolkits/tk84/Makefile
+++ b/x11-toolkits/tk84/Makefile
@@ -43,6 +43,10 @@ CONFIGURE_ARGS+= --enable-threads
PKGNAMESUFFIX?= -threads
.endif
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_TK84_MAN)
+
MAN1= wish.1
MAN3= 3DBorder.3 AddOption.3 BindTable.3 CanvPsY.3 CanvTkwin.3 \
CanvTxtInfo.3 Clipboard.3 ClrSelect.3 ConfigWidg.3 ConfigWind.3 \
@@ -344,7 +348,7 @@ MLINKS= 3DBorder.3 Tk_Alloc3DBorderFromObj.3 \
text.n tk_textCut.n \
text.n tk_textPaste.n
-.include <bsd.port.pre.mk>
+.endif
pre-everything::
@if ${TEST} -e "${NONEXISTENT}"; then ${ECHO_MSG} "=== Aborted, please remove ${NONEXISTENT}"; exit 1; fi
@@ -356,6 +360,10 @@ post-patch:
post-configure:
${REINPLACE_CMD} -e 's=${WRKDIRPREFIX}${PORTSDIR}=$${WRKDIRPREFIX}${PORTSDIR}=' \
${WRKSRC}/tkConfig.sh
+.if defined(WITHOUT_TK84_MAN)
+ ${REINPLACE_CMD} -e 's|^MAN_INSTALL_DIR.*$$|MAN_INSTALL_DIR = ${WRKDIR}|' \
+ ${WRKSRC}/Makefile
+.endif
post-install:
${INSTALL_DATA} ${FILESDIR}/pkgIndex.tcl ${PREFIX}/lib/tk${TK_VER}/