aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/tkshape
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-05-15 09:44:44 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-05-15 09:44:44 +0000
commit0c2458a66c869b4469750ee673254b371badb903 (patch)
treebae90e88c7b7acacfeeb800ed5fa7a709cf17671 /x11-toolkits/tkshape
parent42db07025c640a9b7bb30d853087f3d08accd82d (diff)
downloadports-0c2458a66c869b4469750ee673254b371badb903.tar.gz
ports-0c2458a66c869b4469750ee673254b371badb903.zip
Notes
Diffstat (limited to 'x11-toolkits/tkshape')
-rw-r--r--x11-toolkits/tkshape/Makefile4
-rw-r--r--x11-toolkits/tkshape/files/patch-test-syntax.text139
-rw-r--r--x11-toolkits/tkshape/files/patch-unix-Makefile.in11
3 files changed, 152 insertions, 2 deletions
diff --git a/x11-toolkits/tkshape/Makefile b/x11-toolkits/tkshape/Makefile
index 3a0a3b39ccb9..520514bee107 100644
--- a/x11-toolkits/tkshape/Makefile
+++ b/x11-toolkits/tkshape/Makefile
@@ -35,8 +35,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME:C/^tk//1}${PORTVERSION}
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-tclconf=${LOCALBASE}/lib/tcl${TCL_VER} \
- --with-tkconf=${LOCALBASE}/lib/tk${TK_VER}
+CONFIGURE_ARGS= --with-tclconf=${TCL_LIBDIR} \
+ --with-tkconf=${TK_LIBDIR}
CONFIGURE_WRKSRC= ${WRKSRC}/unix
BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
diff --git a/x11-toolkits/tkshape/files/patch-test-syntax.text b/x11-toolkits/tkshape/files/patch-test-syntax.text
new file mode 100644
index 000000000000..d16fdf28e4bf
--- /dev/null
+++ b/x11-toolkits/tkshape/files/patch-test-syntax.text
@@ -0,0 +1,139 @@
+--- tests/syntax.test.orig 2013-05-13 17:26:43.000000000 +0200
++++ tests/syntax.test 2013-05-13 17:26:27.000000000 +0200
+@@ -15,20 +15,20 @@
+ namespace import ::tcltest::*
+ }
+
+-package require shape
++package require Shape
+
+ # top-level error messages
+ test syntax-1.1 {Shape needs subcommand} {
+ list [catch {
+ shape
+ } msg] $msg
+-} {1 "wrong # args: should be \"shape subcommand ?window arg ...?\""}
++} {1 {wrong # args: should be "shape subcommand ?window arg ...?"}}
+ test syntax-1.2 {Shape subcommand list} {
+ list [catch {
+ shape Dummy
+ } msg] $msg
+-} {1 "bad subcommand \"Dummy\": must be\
+- bounds, get, offset, set, update, or version"}
++} {1 {bad subcommand "Dummy": must be\
++ bounds, get, offset, set, update, or version}}
+ test syntax-1.3 {Variables were created} {
+ list [info exist shape_version] [info exist shape_patchLevel]
+ } {1 1}
+@@ -38,7 +38,7 @@
+ list [catch {
+ shape version Dummy
+ } msg] $msg
+-} {1 " wrong # args: should be \"shape version\""}
++} {1 {wrong # args: should be "shape version"}}
+ test syntax-2.2 {Shape version: result format} {
+ string is double -strict [shape version]
+ } {1}
+@@ -48,84 +48,84 @@
+ list [catch {
+ shape set
+ } msg] $msg
+-} {1 "wrong # args: should be \"shape set pathName ?options?\""}
++} {1 {wrong # args: should be "shape set pathName ?options?"}}
+ test syntax-3.2 {Shape set: needs window pathname} {
+ list [catch {
+ shape set not-a-window
+ } msg] $msg
+-} {1 "bad window path name \"not-a-window\""}
++} {1 {bad window path name "not-a-window"}}
+
+ # get subcommand
+ test syntax-4.1 {Shape get: command format} {
+ list [catch {
+ shape get
+ } msg] $msg
+-} {1 "wrong # args: should be \"shape get pathName ?-bounding/-clip?\""}
++} {1 {wrong # args: should be "shape get pathName ?-bounding/-clip?"}}
+ test syntax-4.2 {Shape get: command format} {
+ list [catch {
+ shape get ? ? ?
+ } msg] $msg
+-} {1 "wrong # args: should be \"shape get pathName ?-bounding/-clip?\""}
++} {1 {wrong # args: should be "shape get pathName ?-bounding/-clip?"}}
+ test syntax-4.3 {Shape get: needs window pathname} {
+ list [catch {
+ shape get not-a-window
+ } msg] $msg
+-} {1 "bad window path name \"not-a-window\""}
++} {1 {bad window path name "not-a-window"}}
+
+ # update subcommand
+ test syntax-5.1 {Shape update: command format} {
+ list [catch {
+ shape update
+ } msg] $msg
+-} {1 "wrong # args: should be \"shape update pathName operation ?options?\""}
++} {1 {wrong # args: should be "shape update pathName operation ?options?"}}
+
+ # offset subcommand
+ test syntax-6.1 {Shape offset: command format} {
+ list [catch {
+ shape offset
+ } msg] $msg
+-} {1 "wrong # args: should be\
+- \"shape offset pathName ?-bounding/-clip/-both? x y\""}
++} {1 {wrong # args: should be\
++ "shape offset pathName ?-bounding/-clip/-both? x y"}}
+ test syntax-6.2 {Shape offset: command format} {
+ list [catch {
+ shape offset ?
+ } msg] $msg
+-} {1 "wrong # args: should be\
+- \"shape offset pathName ?-bounding/-clip/-both? x y\""}
++} {1 {wrong # args: should be\
++ "shape offset pathName ?-bounding/-clip/-both? x y"}}
+ test syntax-6.3 {Shape offset: command format} {
+ list [catch {
+ shape offset ? ?
+ } msg] $msg
+-} {1 "wrong # args: should be\
+- \"shape offset pathName ?-bounding/-clip/-both? x y\""}
++} {1 {wrong # args: should be\
++ "shape offset pathName ?-bounding/-clip/-both? x y"}}
+ test syntax-6.4 {Shape offset: command format} {
+ list [catch {
+ shape offset ? ? ? ? ?
+ } msg] $msg
+-} {1 "wrong # args: should be\
+- \"shape offset pathName ?-bounding/-clip/-both? x y\""}
++} {1 {wrong # args: should be\
++ "shape offset pathName ?-bounding/-clip/-both? x y"}}
+ test syntax-6.5 {Shape offset: needs window pathname} {
+ list [catch {
+ shape offset not-a-window 0 0
+ } msg] $msg
+-} {1 "bad window path name \"not-a-window\""}
++} {1 {bad window path name "not-a-window"}}
+
+ # bounds subcommand
+ test syntax-7.1 {Shape bounds: command format} {
+ list [catch {
+ shape bounds
+ } msg] $msg
+-} {1 "wrong # args: should be \"shape bounds pathName ?-bounding/-clip?\""}
++} {1 {wrong # args: should be "shape bounds pathName ?-bounding/-clip?"}}
+ test syntax-7.2 {Shape bounds: command format} {
+ list [catch {
+ shape bounds ? ? ?
+ } msg] $msg
+-} {1 "wrong # args: should be \"shape bounds pathName ?-bounding/-clip?\""}
++} {1 {wrong # args: should be "shape bounds pathName ?-bounding/-clip?"}}
+ test syntax-7.3 {Shape bounds: needs window pathname} {
+ list [catch {
+ shape bounds not-a-window
+ } msg] $msg
+-} {1 "bad window path name \"not-a-window\""}
++} {1 {bad window path name "not-a-window"}}
+
+ # cleanup
+ ::tcltest::cleanupTests
diff --git a/x11-toolkits/tkshape/files/patch-unix-Makefile.in b/x11-toolkits/tkshape/files/patch-unix-Makefile.in
new file mode 100644
index 000000000000..1e78851bde6e
--- /dev/null
+++ b/x11-toolkits/tkshape/files/patch-unix-Makefile.in
@@ -0,0 +1,11 @@
+--- unix/Makefile.in.orig 2000-09-11 17:10:01.000000000 +0200
++++ unix/Makefile.in 2013-05-13 17:20:31.000000000 +0200
+@@ -71,7 +71,7 @@
+ $(CC) -c $(CC_SWITCHES) $(UNIX_DIR)/shapeUnixText.c
+ # ----------------------------------------------------------------------
+ $(SOFILE): $(OBJS)
+- ${SHLIB_LD} -o $@ $^ @SHLIB_LD_LIBS@
++ ${SHLIB_LD} -o $@ $^ @SHLIB_LD_LIBS@ ${TK_LIB_SPEC} ${TCL_LIB_SPEC} ${TK_LIBS}
+ $(EXEFILE): $(OBJS) tkAppInit.o
+ $(CC) -o $@ $^ @SHLIB_LD_LIBS@ ${TK_LIB_SPEC} ${TCL_LIB_SPEC} ${TK_LIBS}
+ # ----------------------------------------------------------------------