aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/tktreectrl
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-10-08 11:22:29 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-10-08 11:22:29 +0000
commit414485f9972c47b2f4126322a71149cb49571e80 (patch)
treed2b50fbe104601ee13839a6e18d5ca9cb2267159 /x11-toolkits/tktreectrl
parent6b81740d8e2b9352e1eb21c8e7f5b6b38b600a95 (diff)
downloadports-414485f9972c47b2f4126322a71149cb49571e80.tar.gz
ports-414485f9972c47b2f4126322a71149cb49571e80.zip
Notes
Diffstat (limited to 'x11-toolkits/tktreectrl')
-rw-r--r--x11-toolkits/tktreectrl/Makefile36
-rw-r--r--x11-toolkits/tktreectrl/distinfo3
-rw-r--r--x11-toolkits/tktreectrl/pkg-descr3
-rw-r--r--x11-toolkits/tktreectrl/pkg-plist9
4 files changed, 51 insertions, 0 deletions
diff --git a/x11-toolkits/tktreectrl/Makefile b/x11-toolkits/tktreectrl/Makefile
new file mode 100644
index 000000000000..2e82ac20cd8f
--- /dev/null
+++ b/x11-toolkits/tktreectrl/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: tktreectrl
+# Date created: 08 October 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tktreectrl
+PORTVERSION= 2.1.1
+CATEGORIES= x11-toolkits tk84
+MASTER_SITES= SF
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Multi-column hierarchical listbox widget
+
+LIB_DEPENDS= tk${USE_TK}.1:${PORTSDIR}/x11-toolkits/tk${USE_TK}
+
+USE_TK= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl${TK_VER} \
+ --with-tk=${LOCALBASE}/lib/tk${TK_VER} \
+ --exec-prefix=${PREFIX} --enable-shared
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} ${TCL_INCLUDES} ${TK_INCLUDES}"
+TCL_INCLUDES= -I${LOCALBASE}/include/tcl${TK_VER} -I${LOCALBASE}/include/tcl${TK_VER}/generic
+TK_INCLUDES= -I${LOCALBASE}/include/tk${TK_VER} -I${LOCALBASE}/include/tk${TK_VER}/generic \
+ -I${LOCALBASE}/include/tk${TK_VER}/unix
+TKPKG= treectrl${PORTVERSION}
+TKLIBVER= 2.1
+PLIST_SUB= VER=${PORTVERSION} TKPKG=${TKPKG} TKLIBVER=${TKLIBVER}
+USE_LDCONFIG= ${PREFIX}/lib/${TKPKG}
+
+post-install:
+ @${LN} -sf ${PREFIX}/lib/${TKPKG}/libtreectrl${TKLIBVER}.so \
+ ${PREFIX}/lib/${TKPKG}/libtreectrl${TKLIBVER}.so.0
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/tktreectrl/distinfo b/x11-toolkits/tktreectrl/distinfo
new file mode 100644
index 000000000000..71300540035b
--- /dev/null
+++ b/x11-toolkits/tktreectrl/distinfo
@@ -0,0 +1,3 @@
+MD5 (tktreectrl-2.1.1.tar.gz) = 9e6bd98dbefcd034862ef8f90641dade
+SHA256 (tktreectrl-2.1.1.tar.gz) = d781f6c4facad7e05e85c57f2edeb24c0602c8e7993ae4a56456f3a05b442f6e
+SIZE (tktreectrl-2.1.1.tar.gz) = 503363
diff --git a/x11-toolkits/tktreectrl/pkg-descr b/x11-toolkits/tktreectrl/pkg-descr
new file mode 100644
index 000000000000..900aba5b6387
--- /dev/null
+++ b/x11-toolkits/tktreectrl/pkg-descr
@@ -0,0 +1,3 @@
+TkTreeCtrl is a multi-column hierarchical listbox widget for Tk
+
+WWW: http://tktreectrl.sourceforge.net/
diff --git a/x11-toolkits/tktreectrl/pkg-plist b/x11-toolkits/tktreectrl/pkg-plist
new file mode 100644
index 000000000000..6980fb93c337
--- /dev/null
+++ b/x11-toolkits/tktreectrl/pkg-plist
@@ -0,0 +1,9 @@
+lib/%%TKPKG%%/filelist-bindings.tcl
+lib/%%TKPKG%%/htmldoc/What's New in TkTreeCtrl.html
+lib/%%TKPKG%%/htmldoc/treectrl.html
+lib/%%TKPKG%%/libtreectrl%%TKLIBVER%%.so
+lib/%%TKPKG%%/libtreectrl%%TKLIBVER%%.so.0
+lib/%%TKPKG%%/pkgIndex.tcl
+lib/%%TKPKG%%/treectrl.tcl
+@dirrm lib/%%TKPKG%%/htmldoc
+@dirrm lib/%%TKPKG%%