aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/vdk/Makefile
diff options
context:
space:
mode:
authorJeremy Lea <reg@FreeBSD.org>2000-10-05 07:22:56 +0000
committerJeremy Lea <reg@FreeBSD.org>2000-10-05 07:22:56 +0000
commit7b4c77811e89d7fc1131ca6e63df3e719bc86b1d (patch)
tree9695733a1620c4c290c86f161a4f1b73160ed39a /x11-toolkits/vdk/Makefile
parentc76cf46929051f9dd322487d888c82f104026e6d (diff)
Notes
Diffstat (limited to 'x11-toolkits/vdk/Makefile')
-rw-r--r--x11-toolkits/vdk/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/x11-toolkits/vdk/Makefile b/x11-toolkits/vdk/Makefile
index ef2487324a6e..7a61bba5a5d6 100644
--- a/x11-toolkits/vdk/Makefile
+++ b/x11-toolkits/vdk/Makefile
@@ -12,18 +12,22 @@ MASTER_SITES= http://download.sourceforge.net/vdkbuilder/
MAINTAINER= nakai@FreeBSD.org
-LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
-
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-
USE_NEWGCC= yes
USE_X_PREFIX= yes
+USE_GTK= yes
+WANT_GNOME= yes
+USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
MAN1= vdk-config.1
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(HAVE_GNOME)
+USE_GNOME= yes
+CONFIGURE_ARGS+= --enable-gnome
+.endif
+
+.include <bsd.port.post.mk>