aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/vdk/Makefile
diff options
context:
space:
mode:
authorYukihiro Nakai <nakai@FreeBSD.org>2000-01-31 03:52:18 +0000
committerYukihiro Nakai <nakai@FreeBSD.org>2000-01-31 03:52:18 +0000
commitfc100fa93614f723ad40bfcfbff19eac50d4aec7 (patch)
treed4a3899fdd751e6595ec0893f0b06057a2f9775d /x11-toolkits/vdk/Makefile
parent2c01d8fee6a40583e2fd982b79e62e5f2ea94dfc (diff)
downloadports-fc100fa93614f723ad40bfcfbff19eac50d4aec7.tar.gz
ports-fc100fa93614f723ad40bfcfbff19eac50d4aec7.zip
Notes
Diffstat (limited to 'x11-toolkits/vdk/Makefile')
-rw-r--r--x11-toolkits/vdk/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-toolkits/vdk/Makefile b/x11-toolkits/vdk/Makefile
new file mode 100644
index 000000000000..72ad623c97ef
--- /dev/null
+++ b/x11-toolkits/vdk/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: vdk
+# Version required: 1.0.6
+# Date created: 30 January 2000
+# Whom: Yukihiro Nakai <nakai@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= vdk-1.0.6
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://www.programmers.net/artic/Motta/vdk/
+
+MAINTAINER= nakai@FreeBSD.org
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+USE_NEWGCC= yes
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+MAN1= vdk-config.1
+
+.include <bsd.port.mk>