aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/vdk/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-22 09:15:46 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-22 09:15:46 +0000
commitd2c6beffc9ce5e3091e2c9b23b88562acc6fe06f (patch)
tree981f125171260684eb07596e62ffde4b3dd05f4a /x11-toolkits/vdk/Makefile
parent411ad31409382790b7abde18a1f22235870663bd (diff)
downloadports-d2c6beffc9ce5e3091e2c9b23b88562acc6fe06f.tar.gz
ports-d2c6beffc9ce5e3091e2c9b23b88562acc6fe06f.zip
Notes
Diffstat (limited to 'x11-toolkits/vdk/Makefile')
-rw-r--r--x11-toolkits/vdk/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/x11-toolkits/vdk/Makefile b/x11-toolkits/vdk/Makefile
index 118a0954cad9..02af51825542 100644
--- a/x11-toolkits/vdk/Makefile
+++ b/x11-toolkits/vdk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vdk
PORTVERSION= 2.5.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits
MASTER_SITES= SF/${PORTNAME}lib/VDK%20for%20both%20Linux%20and%20Windows%20%28this%20is%20the%20new%20version%29/VDKLIB%20%28C%2B%2B%20wrapper%20for%20GTK%2B%29
@@ -13,20 +13,16 @@ COMMENT= C++ wrapper for GTK+ toolkit
LICENSE= LGPL20
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= pathfix pkgconfig
+USES= libtool pathfix pkgconfig
USE_GNOME= gtk20
-USE_AUTOTOOLS= libtool
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-opt=no --enable-doc-html=no --enable-testvdk=no
USE_LDCONFIG= yes
-
-MAN1= vdk-config-2.1
+INSTALL_TARGET= install-strip
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib -lgnuregex ${PTHREAD_LIBS}
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|CXXFLAGS="-s"|CXXFLAGS="$$CXXFLAGS"|g ; \
s|uname -rmpo|uname -rmp|g' ${WRKSRC}/configure
@@ -38,4 +34,4 @@ post-patch:
's|<.*regex\.h>|<gnu/regex.h>|g' ${WRKSRC}/include/vdk/${file}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>