aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/viewkit/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-07 04:19:54 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-07 04:19:54 +0000
commit9160b5d8a3e4c3685d565d7a0779e13df3906943 (patch)
tree86738136b30f9946c3624eb54ca16f6f439d2282 /x11-toolkits/viewkit/Makefile
parent539dbbf75e2299e7da4a4d02b5ff2349f0f43583 (diff)
Notes
Diffstat (limited to 'x11-toolkits/viewkit/Makefile')
-rw-r--r--x11-toolkits/viewkit/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-toolkits/viewkit/Makefile b/x11-toolkits/viewkit/Makefile
new file mode 100644
index 000000000000..a63d3f959750
--- /dev/null
+++ b/x11-toolkits/viewkit/Makefile
@@ -0,0 +1,32 @@
+#
+# ports collection makefile for: Viewkit from Hungry Programming.
+# Date created: Aug 2000
+# Whom: peterho@ned.dem.csiro.au
+#
+# $FreeBSD$
+#
+#
+#
+
+PORTNAME= viewkit
+PORTVERSION= 0.00
+CATEGORIES= x11-toolkits
+MASTER_SITES= ftp://ftp.hungry.com/pub/hungry/viewkit/
+DISTNAME= libvk-Apr19-2243
+
+MAINTAINER= peterho@ned.dem.csiro.au
+
+BUILD_DEPENDS= ${AUTOCONFIG}:${PORTSDIR}/devel/${AUTOCONFIG}
+
+AUTOCONFIG= autoconf
+
+MOTIFPACKAGE?= open-motif
+USE_X_PREFIX= yes
+REQUIRES_MOTIF = yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-${MOTIFPACKAGE}
+
+pre-configure:
+ @cd ${WRKSRC}; ${CHMOD} +w configure; ${AUTOCONFIG}
+
+.include <bsd.port.mk>