aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/vte3
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2016-02-14 18:57:53 +0000
committerKoop Mast <kwm@FreeBSD.org>2016-02-14 18:57:53 +0000
commitb93a80c99281466281db26011356c75bd54ea36c (patch)
treecb5a8a1108829deee66dbb334ff2a733162448c6 /x11-toolkits/vte3
parentb78527376a1d11bef820d5e9fe86d3c524ea6acf (diff)
downloadports-b93a80c99281466281db26011356c75bd54ea36c.tar.gz
ports-b93a80c99281466281db26011356c75bd54ea36c.zip
Notes
Diffstat (limited to 'x11-toolkits/vte3')
-rw-r--r--x11-toolkits/vte3/Makefile45
-rw-r--r--x11-toolkits/vte3/distinfo4
-rw-r--r--x11-toolkits/vte3/files/patch-gnome-pty-helper_config.h.in12
-rw-r--r--x11-toolkits/vte3/files/patch-gnome-pty-helper_configure11
-rw-r--r--x11-toolkits/vte3/files/patch-gnome-pty-helper_gnome-pty-helper.c10
-rw-r--r--x11-toolkits/vte3/files/patch-gnome-pty-helper_gnome-utmp.c11
-rw-r--r--x11-toolkits/vte3/files/patch-src_vteseq.c10
-rw-r--r--x11-toolkits/vte3/pkg-plist4
8 files changed, 15 insertions, 92 deletions
diff --git a/x11-toolkits/vte3/Makefile b/x11-toolkits/vte3/Makefile
index 96e1eddcaa09..4160d9bb2355 100644
--- a/x11-toolkits/vte3/Makefile
+++ b/x11-toolkits/vte3/Makefile
@@ -1,47 +1,32 @@
# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-PORTNAME?= vte
-PORTVERSION= 0.40.2
-PORTREVISION?= 0
+PORTNAME= vte
+PORTVERSION= 0.42.3
CATEGORIES= x11-toolkits gnome
-MASTER_SITES= GNOME/sources/${PORTNAME:S/gnome-pty-helper/vte/}/${PORTVERSION:R}
-DISTNAME= vte-${PORTVERSION}
-PKGNAMESUFFIX?= 3
+MASTER_SITES= GNOME
+PKGNAMESUFFIX= 3
DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
-COMMENT?= Terminal widget with improved accessibility and I18N support
+COMMENT= Terminal widget with improved accessibility and I18N support
-USES= tar:xz
-
-.if !defined(REFERENCE_PORT)
-VTE3_SLAVE?= no
-PORTSCOUT= limitw:1,even
-
-.if ${VTE3_SLAVE} != yes
BUILD_DEPENDS+= vapigen:${PORTSDIR}/lang/vala \
bash:${PORTSDIR}/shells/bash
LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
-RUN_DEPENDS+= ${LOCALBASE}/libexec/gnome-pty-helper:${PORTSDIR}/x11-toolkits/gnome-pty-helper
-.else
-# we need gnutls for configure to pass for gnome-pty-helper ..
-BUILD_DEPENDS+= gnutls>=0:${PORTSDIR}/security/gnutls
-.endif
-USES+= bison gettext gmake libtool pathfix pkgconfig
+PORTSCOUT= limitw:1,even
+
+USES= bison compiler:c++0x gettext gmake gnome libtool pathfix \
+ pkgconfig tar:xz
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_GNOME?= gtk30 intltool referencehack introspection:build
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS?=--disable-python \
- --with-gtk=3.0 \
- --enable-introspection \
+CONFIGURE_ARGS= --enable-introspection \
--disable-static \
- --disable-Bsymbolic \
- --disable-gnome-pty-helper \
- --disable-freetypetest
+ --disable-Bsymbolic
INSTALL_TARGET= install-strip
PLIST_SUB= VERSION=2.91
@@ -53,10 +38,8 @@ LIBS+= -lz
.endif
post-patch:
-.if ${VTE3_SLAVE} != yes
@${REINPLACE_CMD} -e 's|-Wno-unused-but-set-variable||g' \
${WRKSRC}/src/Makefile.in
-.endif
# zlib.pc only is available on 10.1-R and newer.
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000000 || ${OPSYS} == DragonFly
@${REINPLACE_CMD} -e 's|gio-unix-2.0 zlib|gio-unix-2.0|g' \
@@ -68,11 +51,5 @@ post-patch:
s|-fstack-protector||g' \
${WRKSRC}/configure
.endif
- @${REINPLACE_CMD} -e 's|(AM_MAKEFLAGS) install-exec-hook|(AM_MAKEFLAGS)|g' \
- ${WRKSRC}/gnome-pty-helper/Makefile.in
.include <bsd.port.mk>
-
-.else
-PORTSCOUT= ignore:1
-.endif
diff --git a/x11-toolkits/vte3/distinfo b/x11-toolkits/vte3/distinfo
index f51564204901..1147d21bff82 100644
--- a/x11-toolkits/vte3/distinfo
+++ b/x11-toolkits/vte3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome3/vte-0.40.2.tar.xz) = 9b68fbc16b27f2d79e6271f2b0708808594ac5acf979d0fccea118608199fd2d
-SIZE (gnome3/vte-0.40.2.tar.xz) = 923852
+SHA256 (gnome3/vte-0.42.3.tar.xz) = 96e98a40eae82d04c08f2ca1d2672659596e5b75626ba7d78df2412878ae62a0
+SIZE (gnome3/vte-0.42.3.tar.xz) = 927988
diff --git a/x11-toolkits/vte3/files/patch-gnome-pty-helper_config.h.in b/x11-toolkits/vte3/files/patch-gnome-pty-helper_config.h.in
deleted file mode 100644
index d07c7bce3919..000000000000
--- a/x11-toolkits/vte3/files/patch-gnome-pty-helper_config.h.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- gnome-pty-helper/config.h.in.orig 2012-03-24 17:31:26.000000000 -0400
-+++ gnome-pty-helper/config.h.in 2012-03-24 17:31:43.000000000 -0400
-@@ -24,6 +24,9 @@
- /* Define to 1 if you have the `getutmpx' function. */
- #undef HAVE_GETUTMPX
-
-+/* Define to 1 if you have the `getutxid' function. */
-+#undef HAVE_GETUTXID
-+
- /* Define to 1 if you have the `grantpt' function. */
- #undef HAVE_GRANTPT
-
diff --git a/x11-toolkits/vte3/files/patch-gnome-pty-helper_configure b/x11-toolkits/vte3/files/patch-gnome-pty-helper_configure
deleted file mode 100644
index 737b74e59ca5..000000000000
--- a/x11-toolkits/vte3/files/patch-gnome-pty-helper_configure
+++ /dev/null
@@ -1,11 +0,0 @@
---- gnome-pty-helper/configure.orig 2012-03-24 17:31:04.000000000 -0400
-+++ gnome-pty-helper/configure 2012-03-24 17:31:21.000000000 -0400
-@@ -5699,7 +5699,7 @@ fi
-
- fi
-
--for ac_func in endutent fcntl forkpty getttyent getutent getutmpx grantpt flock login_tty openpty revoke sendmsg seteuid setreuid setutent strrchr updwtmp updwtmpx utmpname utmpxname
-+for ac_func in endutent fcntl forkpty getttyent getutent getutmpx grantpt flock login_tty openpty revoke sendmsg seteuid setreuid setutent strrchr updwtmp updwtmpx utmpname utmpxname getutxid
- do :
- as_ac_var=`$as_echo "ac_cv_func_$ac_func" | $as_tr_sh`
- ac_fn_c_check_func "$LINENO" "$ac_func" "$as_ac_var"
diff --git a/x11-toolkits/vte3/files/patch-gnome-pty-helper_gnome-pty-helper.c b/x11-toolkits/vte3/files/patch-gnome-pty-helper_gnome-pty-helper.c
deleted file mode 100644
index ab80c5364b55..000000000000
--- a/x11-toolkits/vte3/files/patch-gnome-pty-helper_gnome-pty-helper.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- gnome-pty-helper/gnome-pty-helper.c
-+++ gnome-pty-helper/gnome-pty-helper.c
-@@ -51,7 +51,6 @@
- #include <stdlib.h>
- #include <string.h>
- #include <stdio.h>
--#include <utmp.h>
- #include <grp.h>
- #include "gnome-pty.h"
- #include "gnome-login-support.h"
diff --git a/x11-toolkits/vte3/files/patch-gnome-pty-helper_gnome-utmp.c b/x11-toolkits/vte3/files/patch-gnome-pty-helper_gnome-utmp.c
deleted file mode 100644
index fa2750ccd5ba..000000000000
--- a/x11-toolkits/vte3/files/patch-gnome-pty-helper_gnome-utmp.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- gnome-pty-helper/gnome-utmp.c.orig 2012-03-24 17:30:46.000000000 -0400
-+++ gnome-pty-helper/gnome-utmp.c 2012-03-24 17:30:25.000000000 -0400
-@@ -152,7 +152,7 @@ update_wtmp (char *file, UTMP *putmp)
- #endif /* !HAVE_GETUTMPX */
-
-
--#if defined(HAVE_GETUTMPX)
-+#if defined(HAVE_GETUTMPX) || defined(HAVE_GETUTXID)
- static void
- update_utmp (UTMP *ut)
- {
diff --git a/x11-toolkits/vte3/files/patch-src_vteseq.c b/x11-toolkits/vte3/files/patch-src_vteseq.c
deleted file mode 100644
index e5afb288b0d8..000000000000
--- a/x11-toolkits/vte3/files/patch-src_vteseq.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/vteseq.c.orig Mon Jun 12 20:27:00 2006
-+++ src/vteseq.c Mon Jun 12 20:27:19 2006
-@@ -20,6 +20,7 @@
- #include "../config.h"
-
- #ifdef HAVE_SYS_SYSLIMITS_H
-+#include <sys/cdefs.h>
- #include <sys/syslimits.h>
- #endif
-
diff --git a/x11-toolkits/vte3/pkg-plist b/x11-toolkits/vte3/pkg-plist
index a06db59797c2..5b567f5f6c39 100644
--- a/x11-toolkits/vte3/pkg-plist
+++ b/x11-toolkits/vte3/pkg-plist
@@ -12,11 +12,10 @@ include/vte-%%VERSION%%/vte/vteversion.h
lib/girepository-1.0/Vte-%%VERSION%%.typelib
lib/libvte-%%VERSION%%.so
lib/libvte-%%VERSION%%.so.0
-lib/libvte-%%VERSION%%.so.0.4000.2
+lib/libvte-%%VERSION%%.so.0.4200.3
libdata/pkgconfig/vte-%%VERSION%%.pc
share/gir-1.0/Vte-%%VERSION%%.gir
share/gtk-doc/html/vte-%%VERSION%%/VteTerminal.html
-share/gtk-doc/html/vte-%%VERSION%%/annotation-glossary.html
share/gtk-doc/html/vte-%%VERSION%%/api-index-0-40.html
share/gtk-doc/html/vte-%%VERSION%%/api-index-deprecated.html
share/gtk-doc/html/vte-%%VERSION%%/api-index-full.html
@@ -40,6 +39,7 @@ share/gtk-doc/html/vte-%%VERSION%%/vte-%%VERSION%%.devhelp2
share/gtk-doc/html/vte-%%VERSION%%/vte-Version-Information.html
share/gtk-doc/html/vte-%%VERSION%%/vte-Vte-PTY.html
share/locale/am/LC_MESSAGES/vte-%%VERSION%%.mo
+share/locale/an/LC_MESSAGES/vte-%%VERSION%%.mo
share/locale/ang/LC_MESSAGES/vte-%%VERSION%%.mo
share/locale/ar/LC_MESSAGES/vte-%%VERSION%%.mo
share/locale/as/LC_MESSAGES/vte-%%VERSION%%.mo