aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/wxgtk24
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2005-05-12 16:39:59 +0000
committerMax Khon <fjoe@FreeBSD.org>2005-05-12 16:39:59 +0000
commitd164e5eed292f9d38bcae24ae5a022d4398498fb (patch)
tree0624ea58421e1b1ee60ff22ecb3eff4e2b60f382 /x11-toolkits/wxgtk24
parentf2e04afc00d5f1a1504497a0ba282336df14f721 (diff)
downloadports-d164e5eed292f9d38bcae24ae5a022d4398498fb.tar.gz
ports-d164e5eed292f9d38bcae24ae5a022d4398498fb.zip
Notes
Diffstat (limited to 'x11-toolkits/wxgtk24')
-rw-r--r--x11-toolkits/wxgtk24/Makefile54
-rw-r--r--x11-toolkits/wxgtk24/files/patch-ac68
-rw-r--r--x11-toolkits/wxgtk24/files/patch-contrib-src-Makefile.in10
-rw-r--r--x11-toolkits/wxgtk24/files/patch-src-makelib.env.in15
-rw-r--r--x11-toolkits/wxgtk24/pkg-plist431
5 files changed, 447 insertions, 131 deletions
diff --git a/x11-toolkits/wxgtk24/Makefile b/x11-toolkits/wxgtk24/Makefile
index 9b0fc3d7bfa3..6b794593695a 100644
--- a/x11-toolkits/wxgtk24/Makefile
+++ b/x11-toolkits/wxgtk24/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wx
PORTVERSION= 2.4.2
-PORTREVISION?= 8
+PORTREVISION?= 9
PKGNAMESUFFIX= ${WXGTK_FLAVOR}
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -29,11 +29,13 @@ USE_ICONV= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
+USE_GNOME= gtk20
CONFIGURE_ARGS= --with-libpng=sys \
--with-libjpeg=sys \
--with-libtiff=sys \
--with-zlib=sys \
- --with-opengl
+ --with-opengl\
+ --enable-gtk2 ${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${WRKSRC}/include \
-I${LOCALBASE}/include \
-I${X11BASE}/include \
@@ -41,58 +43,14 @@ CONFIGURE_ENV= CPPFLAGS="-I${WRKSRC}/include \
LDFLAGS="-L${LOCALBASE}/lib -liconv \
-L${X11BASE}/lib \
${PTHREAD_LIBS}"
-MAKE_ENV= WXGTK_FLAVOR="${WXGTK_FLAVOR}"
+NO_LATEST_LINK= yes
PLIST= ${.CURDIR}/pkg-plist
-WXGTK_FLAVOR?= gtk
-
-.if ${WXGTK_FLAVOR} != "gtk-common"
-RUN_DEPENDS= ${X11BASE}/include/wx/wx.h:${PORTSDIR}/x11-toolkits/wxgtk-common
-.endif
-
-.if ${WXGTK_FLAVOR:M*-common} != ""
-NO_BUILD= yes
-INSTALL_TARGET= install-common
-.endif # *-common
-
-.if ${WXGTK_FLAVOR:M*-contrib*} != ""
-BUILD_WRKSRC= ${WRKSRC}/contrib/src
-INSTALL_WRKSRC= ${BUILD_WRKSRC}
-
-.if ${WXGTK_FLAVOR} != "gtk-contrib-common"
-RUN_DEPENDS= ${X11BASE}/include/wx/stc/stc.h:${PORTSDIR}/x11-toolkits/wxgtk-contrib-common
-.if ${WXGTK_FLAVOR} == "gtk-contrib"
-LIB_DEPENDS+= wx_gtk-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk
-.elif ${WXGTK_FLAVOR} == "gtk2-contrib"
-LIB_DEPENDS+= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2
-.elif ${WXGTK_FLAVOR} == "gtk2-unicode-contrib"
-LIB_DEPENDS+= wx_gtk2u-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2-unicode
-.endif
-.endif # !gtk-contrib-common
-.endif # *-contrib*
-
-.if ${WXGTK_FLAVOR:Mgtk2*} != ""
-USE_GNOME= gtk20
-CONFIGURE_ARGS+=--enable-gtk2 ${MACHINE_ARCH}-portbld-freebsd${OSREL}
-.else
-USE_GNOME= gtk12
-CONFIGURE_ARGS+=--host=${CONFIGURE_TARGET} --build=${CONFIGURE_TARGET}
-.endif
+WXGTK_FLAVOR?= gtk2
.include <bsd.port.pre.mk>
-.if ${WXGTK_FLAVOR:M*-unicode*} != ""
-.if ${OSVERSION} < 500000
-IGNORE= Systems prior to FreeBSD 5.0 currently out of support
-.endif
-CONFIGURE_ARGS+=--enable-unicode
-.endif # *-unicode*
-
pre-patch:
-.if ${WXGTK_FLAVOR:Mgtk2*} != ""
@${REINPLACE_CMD} -e 's|lgdk|lgdk-x11-2.0|g' ${WRKSRC}/configure
-.else
- @${REINPLACE_CMD} -e 's|lgdk|lgdk12|g' ${WRKSRC}/configure
-.endif
.include <bsd.port.post.mk>
diff --git a/x11-toolkits/wxgtk24/files/patch-ac b/x11-toolkits/wxgtk24/files/patch-ac
index b95baddfc8c5..416b9fe2ad50 100644
--- a/x11-toolkits/wxgtk24/files/patch-ac
+++ b/x11-toolkits/wxgtk24/files/patch-ac
@@ -1,5 +1,5 @@
--- Makefile.in.orig Sun Sep 21 18:31:27 2003
-+++ Makefile.in Tue Nov 4 22:33:54 2003
++++ Makefile.in Sat May 7 01:10:14 2005
@@ -332,17 +332,13 @@
$(build_libdir)/@WX_LIBRARY_LINK1@: $(build_libdir)/@WX_LIBRARY_NAME_SHARED@
@@ -20,7 +20,7 @@
$(OBJECTS): $(WXDIR)/include/wx/defs.h $(WXDIR)/include/wx/object.h
-@@ -371,28 +367,23 @@
+@@ -371,26 +367,21 @@
CREATE_INSTALLED_LINKS: preinstall
$(RM) $(libdir)/@WX_LIBRARY_LINK1@
@@ -38,8 +38,7 @@
- && $(LN_S) @WX_LIBRARY_NAME_SHARED_GL@ @WX_LIBRARY_LINK2_GL@
+ && $(LN_S) @WX_LIBRARY_NAME_SHARED_GL@ @WX_LIBRARY_LINK1_GL@
--afminstall: preinstall
-+afminstall:
+ afminstall: preinstall
@if test ! -d $(datadir); then $(INSTALL) -d $(datadir); fi
$(INSTALL) -d $(datadir)/wx
- $(INSTALL) -d $(datadir)/wx/$(VER_MAJMIN)
@@ -52,38 +51,28 @@
+ $(INSTALL_DATA) $(top_srcdir)/misc/afm/*.afm $(datadir)/wx/afm
+ $(INSTALL_DATA) $(top_srcdir)/misc/gs_afm/*.afm $(datadir)/wx/gs_afm
--m4datainstall: preinstall
-+m4datainstall:
+ m4datainstall: preinstall
$(INSTALL) -d $(datadir)/aclocal
- $(INSTALL_DATA) $(top_srcdir)/wxwin.m4 $(datadir)/aclocal
-
-@@ -410,7 +401,7 @@
-
- # this is the real install target: copies the library, wx-config and the
- # headers to the installation directory
--preinstall: $(build_libdir)/@WX_TARGET_LIBRARY@ $(top_builddir)/wx@TOOLCHAIN_NAME@-config
-+install-common: @AFMINSTALL@ m4datainstall @WIN32INSTALL@
- @echo " "
- @echo " Installing wxWindows..."
- @echo " "
-@@ -419,26 +410,11 @@
- @if test ! -d $(bindir); then $(INSTALL) -d $(bindir); fi
+@@ -420,25 +411,19 @@
@if test ! -d $(libdir); then $(INSTALL) -d $(libdir); fi
-- $(INSTALL_SCRIPT) $(top_builddir)/wx@TOOLCHAIN_NAME@-config $(bindir)/wx@TOOLCHAIN_NAME@-config
+ $(INSTALL_SCRIPT) $(top_builddir)/wx@TOOLCHAIN_NAME@-config $(bindir)/wx@TOOLCHAIN_NAME@-config
- cd $(bindir) && rm -f wx-config && $(LN_S) wx@TOOLCHAIN_NAME@-config wx-config
-- @INSTALL_LIBRARY@ $(build_libdir)/@WX_TARGET_LIBRARY@ $(libdir)/@WX_TARGET_LIBRARY@
-- @if test "x@WX_LIBRARY_IMPORTLIB@" != "x"; then \
-- $(INSTALL_PROGRAM) $(top_builddir)/lib/@WX_LIBRARY_IMPORTLIB@ $(libdir)/@WX_LIBRARY_IMPORTLIB@; fi
+ @INSTALL_LIBRARY@ $(build_libdir)/@WX_TARGET_LIBRARY@ $(libdir)/@WX_TARGET_LIBRARY@
+ @if test "x@WX_LIBRARY_IMPORTLIB@" != "x"; then \
+ $(INSTALL_PROGRAM) $(top_builddir)/lib/@WX_LIBRARY_IMPORTLIB@ $(libdir)/@WX_LIBRARY_IMPORTLIB@; fi
-
- $(INSTALL) -d $(libdir)/wx
- $(INSTALL) -d $(libdir)/wx/include
- $(INSTALL) -d $(libdir)/wx/include/univ
- $(INSTALL) -d $(libdir)/wx/include/@TOOLCHAIN_NAME@
- $(INSTALL) -d $(libdir)/wx/include/@TOOLCHAIN_NAME@/wx
-- $(INSTALL_DATA) $(build_libdir)/wx/include/@TOOLCHAIN_NAME@/wx/setup.h \
++ $(INSTALL) -d $(prefix)/include/wx/@TOOLCHAIN_NAME@
++ $(INSTALL) -d $(prefix)/include/wx/@TOOLCHAIN_NAME@/wx
+ $(INSTALL_DATA) $(build_libdir)/wx/include/@TOOLCHAIN_NAME@/wx/setup.h \
- $(libdir)/wx/include/@TOOLCHAIN_NAME@/wx/setup.h
--
++ $(prefix)/include/wx/@TOOLCHAIN_NAME@/wx/setup.h
+
$(INSTALL) -d $(includedir)/wx
@# FIXME: This will erroneously install a wx/base dir for wxBase..
@if test "$(USE_GUI)" = 1; then $(INSTALL) -d $(includedir)/wx/@TOOLKIT_DIR@; fi
@@ -93,32 +82,3 @@
@if test "@TOOLKIT_DIR@" = "msw"; then $(INSTALL) -d $(includedir)/wx/msw/ole; fi
@# always install msw headers for wxBase, it's much simpler
-@@ -459,6 +435,19 @@
- echo "$(INSTALL_DATA) $(top_srcdir)/locale/$$p.mo $(localedir)/$$p/LC_MESSAGES/wxstd.mo"; \
- done
-
-+preinstall: $(build_libdir)/@WX_TARGET_LIBRARY@ $(top_builddir)/wx@TOOLCHAIN_NAME@-config
-+ $(INSTALL_SCRIPT) $(top_builddir)/wx@TOOLCHAIN_NAME@-config $(bindir)/wx@TOOLCHAIN_NAME@-config
-+ @if test "$(WXGTK_FLAVOR)" = "gtk2"; then \
-+ cd $(bindir) && rm -f wx-config && $(LN_S) wx@TOOLCHAIN_NAME@-config wx-config; \
-+ fi
-+ @INSTALL_LIBRARY@ $(build_libdir)/@WX_TARGET_LIBRARY@ $(libdir)/@WX_TARGET_LIBRARY@
-+ @if test "x@WX_LIBRARY_IMPORTLIB@" != "x"; then \
-+ $(INSTALL_PROGRAM) $(top_builddir)/lib/@WX_LIBRARY_IMPORTLIB@ $(libdir)/@WX_LIBRARY_IMPORTLIB@; fi
-+ $(INSTALL) -d $(prefix)/include/wx/@TOOLCHAIN_NAME@
-+ $(INSTALL) -d $(prefix)/include/wx/@TOOLCHAIN_NAME@/wx
-+ $(INSTALL_DATA) $(build_libdir)/wx/include/@TOOLCHAIN_NAME@/wx/setup.h \
-+ $(prefix)/include/wx/@TOOLCHAIN_NAME@/wx/setup.h
-+
- preinstall_res: $(build_libdir)/@WX_RESOURCES_MACOSX_ASCII@ $(build_libdir)/@WX_RESOURCES_MACOSX_DATA@
- @echo " "
- @echo " Installing wxWindows Mac resource ..."
-@@ -474,7 +463,7 @@
- @if test ! -d $(libdir); then $(INSTALL) -d $(libdir); fi
- @INSTALL_LIBRARY@ $(build_libdir)/@WX_TARGET_LIBRARY_GL@ $(libdir)/@WX_TARGET_LIBRARY_GL@
-
--install: @AFMINSTALL@ @WX_ALL_INSTALLED@ m4datainstall @WIN32INSTALL@
-+install: @WX_ALL_INSTALLED@
- @echo " "
- @echo " The installation of wxWindows is finished. On certain"
- @echo " platforms (e.g. Linux) you'll now have to run ldconfig"
diff --git a/x11-toolkits/wxgtk24/files/patch-contrib-src-Makefile.in b/x11-toolkits/wxgtk24/files/patch-contrib-src-Makefile.in
index 5d9fe0443f8e..497bbca104e8 100644
--- a/x11-toolkits/wxgtk24/files/patch-contrib-src-Makefile.in
+++ b/x11-toolkits/wxgtk24/files/patch-contrib-src-Makefile.in
@@ -8,13 +8,3 @@
all:
@for d in $(CONTRIB_SUBDIRS); do (cd $$d && $(MAKE)); done
-@@ -10,6 +10,9 @@
-
- install:
- @for d in $(CONTRIB_SUBDIRS); do (cd $$d && $(MAKE) install); done
-+
-+install-common:
-+ @for d in $(CONTRIB_SUBDIRS); do (cd $$d && $(MAKE) install-common); done
-
- uninstall:
- @for d in $(CONTRIB_SUBDIRS); do (cd $$d && $(MAKE) uninstall); done
diff --git a/x11-toolkits/wxgtk24/files/patch-src-makelib.env.in b/x11-toolkits/wxgtk24/files/patch-src-makelib.env.in
index 17ce4b33fced..af05f435d3a8 100644
--- a/x11-toolkits/wxgtk24/files/patch-src-makelib.env.in
+++ b/x11-toolkits/wxgtk24/files/patch-src-makelib.env.in
@@ -1,5 +1,5 @@
--- src/makelib.env.in.orig Sun Sep 21 18:31:38 2003
-+++ src/makelib.env.in Tue Nov 4 22:33:31 2003
++++ src/makelib.env.in Sat May 7 00:33:13 2005
@@ -35,8 +35,8 @@
INSTALL_DATA = @INSTALL_DATA@
@@ -23,14 +23,7 @@
$(top_builddir)/lib/$(TARGETLIB_STATIC): $(OBJECTS)
@$(INSTALL) -d $(top_builddir)/lib
-@@ -82,14 +81,15 @@
- $(AR) $(AROPTIONS) $@ $(OBJECTS)
- $(RANLIB) $@
-
--install: install_@WX_TARGET_LIBRARY_TYPE@ install_headers
-+install: install_@WX_TARGET_LIBRARY_TYPE@
-+
-+install-common: install_headers
+@@ -86,10 +85,9 @@
install_so:
$(INSTALL_PROGRAM) $(top_builddir)/lib/$(TARGETLIB_SHARED) $(libdir)/$(TARGETLIB_SHARED)
@@ -43,7 +36,7 @@
install_a:
$(INSTALL_PROGRAM) $(top_builddir)/lib/$(TARGETLIB_STATIC) $(libdir)/$(TARGETLIB_STATIC)
-@@ -105,7 +105,6 @@
+@@ -105,7 +103,6 @@
$(RM) $(libdir)/$(TARGETLIB_STATIC)
$(RM) $(libdir)/$(TARGETLIB_SHARED)
$(RM) $(libdir)/$(TARGETLIB_LINK1)
@@ -51,7 +44,7 @@
@echo "removing headers"
@for h in $(HEADERS); do \
$(RM) $(includedir)/wx/$(HEADER_SUBDIR)/$$h; \
-@@ -118,7 +117,6 @@
+@@ -118,7 +115,6 @@
clean:
$(RM) $(OBJECTS) $(top_builddir)/lib/$(TARGETLIB_SHARED) \
$(top_builddir)/lib/$(TARGETLIB_LINK1) \
diff --git a/x11-toolkits/wxgtk24/pkg-plist b/x11-toolkits/wxgtk24/pkg-plist
index c4b6537e54b5..426a83b11df6 100644
--- a/x11-toolkits/wxgtk24/pkg-plist
+++ b/x11-toolkits/wxgtk24/pkg-plist
@@ -1,8 +1,423 @@
-bin/wxgtk-2.4-config
-include/wx/gtk-2.4/wx/setup.h
-lib/libwx_gtk-2.4.so
-lib/libwx_gtk-2.4.so.0
-lib/libwx_gtk_gl-2.4.so
-lib/libwx_gtk_gl-2.4.so.0
-@dirrm include/wx/gtk-2.4/wx
-@dirrm include/wx/gtk-2.4
+bin/wxgtk2-2.4-config
+include/wx/accel.h
+include/wx/app.h
+include/wx/arrimpl.cpp
+include/wx/artprov.h
+include/wx/bitmap.h
+include/wx/bmpbuttn.h
+include/wx/brush.h
+include/wx/buffer.h
+include/wx/build.h
+include/wx/busyinfo.h
+include/wx/button.h
+include/wx/calctrl.h
+include/wx/caret.h
+include/wx/checkbox.h
+include/wx/checklst.h
+include/wx/chkconf.h
+include/wx/choicdlg.h
+include/wx/choice.h
+include/wx/clipbrd.h
+include/wx/clntdata.h
+include/wx/cmdline.h
+include/wx/cmdproc.h
+include/wx/cmndata.h
+include/wx/colordlg.h
+include/wx/colour.h
+include/wx/combobox.h
+include/wx/confbase.h
+include/wx/config.h
+include/wx/containr.h
+include/wx/control.h
+include/wx/cshelp.h
+include/wx/ctrlsub.h
+include/wx/cursor.h
+include/wx/dataobj.h
+include/wx/date.h
+include/wx/datetime.h
+include/wx/datetime.inl
+include/wx/datstrm.h
+include/wx/db.h
+include/wx/dbgrid.h
+include/wx/dbkeyg.h
+include/wx/dbtable.h
+include/wx/dc.h
+include/wx/dcbuffer.h
+include/wx/dcclient.h
+include/wx/dcmemory.h
+include/wx/dcprint.h
+include/wx/dcps.h
+include/wx/dcscreen.h
+include/wx/dde.h
+include/wx/debug.h
+include/wx/defs.h
+include/wx/dialog.h
+include/wx/dialup.h
+include/wx/dir.h
+include/wx/dirctrl.h
+include/wx/dirdlg.h
+include/wx/dnd.h
+include/wx/docmdi.h
+include/wx/docview.h
+include/wx/dragimag.h
+include/wx/dynarray.h
+include/wx/dynlib.h
+include/wx/dynload.h
+include/wx/effects.h
+include/wx/encconv.h
+include/wx/event.h
+include/wx/expr.h
+include/wx/fdrepdlg.h
+include/wx/features.h
+include/wx/ffile.h
+include/wx/file.h
+include/wx/fileconf.h
+include/wx/filedlg.h
+include/wx/filefn.h
+include/wx/filename.h
+include/wx/filesys.h
+include/wx/font.h
+include/wx/fontdlg.h
+include/wx/fontenc.h
+include/wx/fontenum.h
+include/wx/fontmap.h
+include/wx/fontutil.h
+include/wx/frame.h
+include/wx/fs_inet.h
+include/wx/fs_mem.h
+include/wx/fs_zip.h
+include/wx/gauge.h
+include/wx/gdicmn.h
+include/wx/gdiobj.h
+include/wx/generic/accel.h
+include/wx/generic/calctrl.h
+include/wx/generic/caret.h
+include/wx/generic/choicdgg.h
+include/wx/generic/colrdlgg.h
+include/wx/generic/dcpsg.h
+include/wx/generic/dirctrlg.h
+include/wx/generic/dirdlgg.h
+include/wx/generic/dragimgg.h
+include/wx/generic/fdrepdlg.h
+include/wx/generic/filedlgg.h
+include/wx/generic/fontdlgg.h
+include/wx/generic/grid.h
+include/wx/generic/gridctrl.h
+include/wx/generic/gridg.h
+include/wx/generic/helpext.h
+include/wx/generic/helphtml.h
+include/wx/generic/imaglist.h
+include/wx/generic/laywin.h
+include/wx/generic/listctrl.h
+include/wx/generic/msgdlgg.h
+include/wx/generic/notebook.h
+include/wx/generic/paletteg.h
+include/wx/generic/panelg.h
+include/wx/generic/printps.h
+include/wx/generic/prntdlgg.h
+include/wx/generic/progdlgg.h
+include/wx/generic/sashwin.h
+include/wx/generic/scrolwin.h
+include/wx/generic/spinctlg.h
+include/wx/generic/splash.h
+include/wx/generic/splitter.h
+include/wx/generic/statusbr.h
+include/wx/generic/tabg.h
+include/wx/generic/textdlgg.h
+include/wx/generic/timer.h
+include/wx/generic/treectlg.h
+include/wx/generic/wizard.h
+include/wx/geometry.h
+include/wx/gifdecod.h
+include/wx/glcanvas.h
+include/wx/grid.h
+include/wx/gsocket.h
+include/wx/gtk/accel.h
+include/wx/gtk/app.h
+include/wx/gtk/bitmap.h
+include/wx/gtk/bmpbuttn.h
+include/wx/gtk/brush.h
+include/wx/gtk/button.h
+include/wx/gtk/checkbox.h
+include/wx/gtk/checklst.h
+include/wx/gtk/choice.h
+include/wx/gtk/clipbrd.h
+include/wx/gtk/colour.h
+include/wx/gtk/combobox.h
+include/wx/gtk/control.h
+include/wx/gtk/cursor.h
+include/wx/gtk/dataform.h
+include/wx/gtk/dataobj.h
+include/wx/gtk/dataobj2.h
+include/wx/gtk/dc.h
+include/wx/gtk/dcclient.h
+include/wx/gtk/dcmemory.h
+include/wx/gtk/dcscreen.h
+include/wx/gtk/dialog.h
+include/wx/gtk/dnd.h
+include/wx/gtk/filedlg.h
+include/wx/gtk/font.h
+include/wx/gtk/fontdlg.h
+include/wx/gtk/frame.h
+include/wx/gtk/gauge.h
+include/wx/gtk/gdiobj.h
+include/wx/gtk/glcanvas.h
+include/wx/gtk/icon.h
+include/wx/gtk/joystick.h
+include/wx/gtk/listbox.h
+include/wx/gtk/mdi.h
+include/wx/gtk/menu.h
+include/wx/gtk/menuitem.h
+include/wx/gtk/minifram.h
+include/wx/gtk/notebook.h
+include/wx/gtk/pen.h
+include/wx/gtk/popupwin.h
+include/wx/gtk/radiobox.h
+include/wx/gtk/radiobut.h
+include/wx/gtk/region.h
+include/wx/gtk/scrolbar.h
+include/wx/gtk/scrolwin.h
+include/wx/gtk/slider.h
+include/wx/gtk/spinbutt.h
+include/wx/gtk/spinctrl.h
+include/wx/gtk/statbmp.h
+include/wx/gtk/statbox.h
+include/wx/gtk/statline.h
+include/wx/gtk/stattext.h
+include/wx/gtk/tbargtk.h
+include/wx/gtk/textctrl.h
+include/wx/gtk/tglbtn.h
+include/wx/gtk/timer.h
+include/wx/gtk/tooltip.h
+include/wx/gtk/toplevel.h
+include/wx/gtk/treectrl.h
+include/wx/gtk/wave.h
+include/wx/gtk/win_gtk.h
+include/wx/gtk/window.h
+include/wx/gtk2-2.4/wx/setup.h
+include/wx/hash.h
+include/wx/hashmap.h
+include/wx/help.h
+include/wx/helpbase.h
+include/wx/helphtml.h
+include/wx/helpwin.h
+include/wx/html/forcelnk.h
+include/wx/html/helpctrl.h
+include/wx/html/helpdata.h
+include/wx/html/helpfrm.h
+include/wx/html/htmlcell.h
+include/wx/html/htmldefs.h
+include/wx/html/htmlfilt.h
+include/wx/html/htmlpars.h
+include/wx/html/htmltag.h
+include/wx/html/htmlwin.h
+include/wx/html/htmprint.h
+include/wx/html/m_templ.h
+include/wx/html/winpars.h
+include/wx/icon.h
+include/wx/iconbndl.h
+include/wx/imagbmp.h
+include/wx/image.h
+include/wx/imaggif.h
+include/wx/imagiff.h
+include/wx/imagjpeg.h
+include/wx/imaglist.h
+include/wx/imagpcx.h
+include/wx/imagpng.h
+include/wx/imagpnm.h
+include/wx/imagtiff.h
+include/wx/imagxpm.h
+include/wx/intl.h
+include/wx/ioswrap.h
+include/wx/ipc.h
+include/wx/ipcbase.h
+include/wx/isql.h
+include/wx/isqlext.h
+include/wx/joystick.h
+include/wx/layout.h
+include/wx/laywin.h
+include/wx/list.h
+include/wx/listbase.h
+include/wx/listbox.h
+include/wx/listctrl.h
+include/wx/listimpl.cpp
+include/wx/log.h
+include/wx/longlong.h
+include/wx/matrix.h
+include/wx/mdi.h
+include/wx/memconf.h
+include/wx/memory.h
+include/wx/memtext.h
+include/wx/menu.h
+include/wx/menuitem.h
+include/wx/metafile.h
+include/wx/mimetype.h
+include/wx/minifram.h
+include/wx/module.h
+include/wx/msgdlg.h
+include/wx/msgout.h
+include/wx/mstream.h
+include/wx/notebook.h
+include/wx/object.h
+include/wx/odbc.h
+include/wx/ownerdrw.h
+include/wx/palette.h
+include/wx/panel.h
+include/wx/paper.h
+include/wx/pen.h
+include/wx/platform.h
+include/wx/popupwin.h
+include/wx/print.h
+include/wx/printdlg.h
+include/wx/prntbase.h
+include/wx/process.h
+include/wx/progdlg.h
+include/wx/prop.h
+include/wx/propform.h
+include/wx/proplist.h
+include/wx/protocol/file.h
+include/wx/protocol/ftp.h
+include/wx/protocol/http.h
+include/wx/protocol/protocol.h
+include/wx/quantize.h
+include/wx/radiobox.h
+include/wx/radiobut.h
+include/wx/regex.h
+include/wx/region.h
+include/wx/resource.h
+include/wx/sashwin.h
+include/wx/sckaddr.h
+include/wx/sckipc.h
+include/wx/sckstrm.h
+include/wx/scrolbar.h
+include/wx/scrolwin.h
+include/wx/settings.h
+include/wx/sizer.h
+include/wx/slider.h
+include/wx/snglinst.h
+include/wx/socket.h
+include/wx/spinbutt.h
+include/wx/spinctrl.h
+include/wx/splash.h
+include/wx/splitter.h
+include/wx/stack.h
+include/wx/statbmp.h
+include/wx/statbox.h
+include/wx/statline.h
+include/wx/stattext.h
+include/wx/statusbr.h
+include/wx/strconv.h
+include/wx/stream.h
+include/wx/string.h
+include/wx/sysopt.h
+include/wx/tab.h
+include/wx/tabctrl.h
+include/wx/taskbar.h
+include/wx/tbarbase.h
+include/wx/tbarsmpl.h
+include/wx/textbuf.h
+include/wx/textctrl.h
+include/wx/textdlg.h
+include/wx/textfile.h
+include/wx/tglbtn.h
+include/wx/thread.h
+include/wx/thrimpl.cpp
+include/wx/time.h
+include/wx/timer.h
+include/wx/tipdlg.h
+include/wx/tipwin.h
+include/wx/tokenzr.h
+include/wx/toolbar.h
+include/wx/tooltip.h
+include/wx/toplevel.h
+include/wx/treebase.h
+include/wx/treectrl.h
+include/wx/txtstrm.h
+include/wx/types.h
+include/wx/unix/execute.h
+include/wx/unix/fontutil.h
+include/wx/unix/gsockunx.h
+include/wx/unix/mimetype.h
+include/wx/unix/utilsx11.h
+include/wx/url.h
+include/wx/utils.h
+include/wx/valgen.h
+include/wx/validate.h
+include/wx/valtext.h
+include/wx/variant.h
+include/wx/vector.h
+include/wx/version.h
+include/wx/volume.h
+include/wx/wave.h
+include/wx/wfstream.h
+include/wx/window.h
+include/wx/wizard.h
+include/wx/wx.h
+include/wx/wx_cw.h
+include/wx/wx_cw_cm.h
+include/wx/wx_cw_d.h
+include/wx/wxchar.h
+include/wx/wxexpr.h
+include/wx/wxhtml.h
+include/wx/wxprec.h
+include/wx/xpmdecod.h
+include/wx/zipstrm.h
+include/wx/zstream.h
+lib/libwx_gtk2-2.4.so
+lib/libwx_gtk2-2.4.so.0
+lib/libwx_gtk2_gl-2.4.so
+lib/libwx_gtk2_gl-2.4.so.0
+share/aclocal/wxwin.m4
+share/locale/cs/LC_MESSAGES/wxstd.mo
+share/locale/da/LC_MESSAGES/wxstd.mo
+share/locale/de/LC_MESSAGES/wxstd.mo
+share/locale/es/LC_MESSAGES/wxstd.mo
+share/locale/fi/LC_MESSAGES/wxstd.mo
+share/locale/fr/LC_MESSAGES/wxstd.mo
+share/locale/hu/LC_MESSAGES/wxstd.mo
+share/locale/id/LC_MESSAGES/wxstd.mo
+share/locale/it/LC_MESSAGES/wxstd.mo
+share/locale/nl/LC_MESSAGES/wxstd.mo
+share/locale/pl/LC_MESSAGES/wxstd.mo
+share/locale/ru/LC_MESSAGES/wxstd.mo
+share/locale/sl/LC_MESSAGES/wxstd.mo
+share/locale/sv/LC_MESSAGES/wxstd.mo
+share/locale/tr/LC_MESSAGES/wxstd.mo
+share/locale/zh/LC_MESSAGES/wxstd.mo
+share/wx/afm/Cour.afm
+share/wx/afm/CourBo.afm
+share/wx/afm/CourBoO.afm
+share/wx/afm/CourO.afm
+share/wx/afm/Helv.afm
+share/wx/afm/HelvBo.afm
+share/wx/afm/HelvBoO.afm
+share/wx/afm/HelvO.afm
+share/wx/afm/TimesBo.afm
+share/wx/afm/TimesBoO.afm
+share/wx/afm/TimesO.afm
+share/wx/afm/TimesRo.afm
+share/wx/afm/Zapf.afm
+share/wx/gs_afm/Cour.afm
+share/wx/gs_afm/CourBo.afm
+share/wx/gs_afm/CourBoO.afm
+share/wx/gs_afm/CourO.afm
+share/wx/gs_afm/Helv.afm
+share/wx/gs_afm/HelvBo.afm
+share/wx/gs_afm/HelvBoO.afm
+share/wx/gs_afm/HelvO.afm
+share/wx/gs_afm/TimesBo.afm
+share/wx/gs_afm/TimesBoO.afm
+share/wx/gs_afm/TimesO.afm
+share/wx/gs_afm/TimesRo.afm
+share/wx/gs_afm/Zapf.afm
+@dirrm share/wx/gs_afm
+@dirrm share/wx/afm
+@dirrm share/wx
+@dirrm include/wx/unix
+@dirrm include/wx/protocol
+@dirrm include/wx/html
+@dirrm include/wx/gtk2-2.4/wx
+@dirrm include/wx/gtk2-2.4
+@dirrm include/wx/gtk
+@dirrm include/wx/generic
+@dirrm include/wx