aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/wxgtk24
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /x11-toolkits/wxgtk24
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'x11-toolkits/wxgtk24')
-rw-r--r--x11-toolkits/wxgtk24/Makefile4
-rw-r--r--x11-toolkits/wxgtk24/files/patch-src-common-imagpng.cpp44
2 files changed, 46 insertions, 2 deletions
diff --git a/x11-toolkits/wxgtk24/Makefile b/x11-toolkits/wxgtk24/Makefile
index 571d7e23c828..336f4176d2c6 100644
--- a/x11-toolkits/wxgtk24/Makefile
+++ b/x11-toolkits/wxgtk24/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wx
PORTVERSION= 2.4.2
-PORTREVISION?= 20
+PORTREVISION?= 21
PKGNAMESUFFIX= ${WXGTK_FLAVOR}
CATEGORIES= x11-toolkits
MASTER_SITES= SF/wxwindows/wxGTK/${PORTVERSION}
@@ -16,7 +16,7 @@ DISTNAME= wxGTK-${PORTVERSION}
MAINTAINER?= fjoe@FreeBSD.org
COMMENT?= The wxWidgets GUI toolkit with GTK+ bindings
-LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png \
+LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png \
jpeg.11:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
diff --git a/x11-toolkits/wxgtk24/files/patch-src-common-imagpng.cpp b/x11-toolkits/wxgtk24/files/patch-src-common-imagpng.cpp
new file mode 100644
index 000000000000..9c0bd30beb19
--- /dev/null
+++ b/x11-toolkits/wxgtk24/files/patch-src-common-imagpng.cpp
@@ -0,0 +1,44 @@
+--- src/common/imagpng.cpp.orig 2003-09-21 13:31:39.000000000 +0200
++++ src/common/imagpng.cpp 2012-05-06 07:07:48.000000000 +0200
+@@ -30,6 +30,7 @@
+ #include "wx/log.h"
+ #include "wx/app.h"
+ #include "png.h"
++#include "pngpriv.h"
+ #include "wx/filefn.h"
+ #include "wx/wfstream.h"
+ #include "wx/intl.h"
+@@ -127,7 +128,7 @@
+ #ifdef USE_FAR_KEYWORD
+ {
+ jmp_buf jmpbuf;
+- png_memcpy(jmpbuf,info->jmpbuf,sizeof(jmp_buf));
++ png_memcpy(jmpbuf,png_jmpbuf(info),sizeof(jmp_buf));
+ longjmp(jmpbuf, 1);
+ }
+ #else
+@@ -167,13 +168,13 @@
+ image->Destroy();
+
+ png_structp png_ptr = png_create_read_struct( PNG_LIBPNG_VER_STRING,
+- (voidp) NULL,
++ NULL,
+ (png_error_ptr) NULL,
+ (png_error_ptr) NULL );
+ if (!png_ptr)
+ goto error_nolines;
+
+- png_set_error_fn(png_ptr, (png_voidp)NULL, wx_png_error, wx_png_warning);
++ png_set_error_fn(png_ptr, NULL, wx_png_error, wx_png_warning);
+
+ // NB: please see the comment near wxPNGInfoStruct declaration for
+ // explanation why this line is mandatory
+@@ -349,7 +350,7 @@
+ return FALSE;
+ }
+
+- png_set_error_fn(png_ptr, (png_voidp)NULL, wx_png_error, wx_png_warning);
++ png_set_error_fn(png_ptr, NULL, wx_png_error, wx_png_warning);
+
+ png_infop info_ptr = png_create_info_struct(png_ptr);
+ if (info_ptr == NULL)