aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/wxgtk26
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2007-01-08 18:34:04 +0000
committerMax Khon <fjoe@FreeBSD.org>2007-01-08 18:34:04 +0000
commitfbe17914b1d735d3480b450377f7c3d5e6b83fb5 (patch)
tree984d51e2607c2993294faa5be9aaa7597be5ef52 /x11-toolkits/wxgtk26
parent33854f81fa15ccdd704720b0149544fa6422207f (diff)
downloadports-fbe17914b1d735d3480b450377f7c3d5e6b83fb5.tar.gz
ports-fbe17914b1d735d3480b450377f7c3d5e6b83fb5.zip
Notes
Diffstat (limited to 'x11-toolkits/wxgtk26')
-rw-r--r--x11-toolkits/wxgtk26/Makefile2
-rw-r--r--x11-toolkits/wxgtk26/files/patch-Makefile.in21
-rw-r--r--x11-toolkits/wxgtk26/files/patch-src-common-intl.cpp20
3 files changed, 37 insertions, 6 deletions
diff --git a/x11-toolkits/wxgtk26/Makefile b/x11-toolkits/wxgtk26/Makefile
index ab643d3cc2c1..76c47b24505b 100644
--- a/x11-toolkits/wxgtk26/Makefile
+++ b/x11-toolkits/wxgtk26/Makefile
@@ -52,7 +52,7 @@ PLIST= ${.CURDIR}/pkg-plist
WXGTK_FLAVOR?= gtk2
.if ${WXGTK_FLAVOR} == "gtk2"
-PORTREVISION= 1
+PORTREVISION= 2
CONFLICTS= wxgtk2-contrib-devel-2.5.2*
.endif
diff --git a/x11-toolkits/wxgtk26/files/patch-Makefile.in b/x11-toolkits/wxgtk26/files/patch-Makefile.in
index c4a0015bafa5..0ba321f4834c 100644
--- a/x11-toolkits/wxgtk26/files/patch-Makefile.in
+++ b/x11-toolkits/wxgtk26/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Tue Mar 21 11:39:27 2006
-+++ Makefile.in Tue Mar 21 11:54:48 2006
+--- Makefile.in.orig Wed Mar 22 05:42:05 2006
++++ Makefile.in Tue Jan 9 00:08:38 2007
@@ -24,6 +24,7 @@
SONAME_FLAG = @SONAME_FLAG@
STRIP = @STRIP@
@@ -17,11 +17,12 @@
+ $(INSTALL_DIR) $(DESTDIR)$(includedir)/wx-$(WX_RELEASE)/$(TOOLCHAIN_FULLNAME)/wx
+ (cd ./ ; $(INSTALL_DATA) lib/wx/include/$(TOOLCHAIN_FULLNAME)/wx/setup.h $(DESTDIR)$(includedir)/wx-$(WX_RELEASE)/$(TOOLCHAIN_FULLNAME)/wx)
+
-+install-common: locale_install locale_msw_install
++install-common: locale_install
$(INSTALL_DIR) $(DESTDIR)$(datadir)/aclocal
- (cd $(srcdir) ; $(INSTALL_DATA) wxwin.m4 $(DESTDIR)$(datadir)/aclocal)
+- (cd $(srcdir) ; $(INSTALL_DATA) wxwin.m4 $(DESTDIR)$(datadir)/aclocal)
++ (cd $(srcdir) ; $(INSTALL_DATA) wxwin.m4 $(DESTDIR)$(datadir)/aclocal/wxwin$(WX_RELEASE_NODOT).m4)
$(INSTALL_DIR) $(DESTDIR)$(datadir)/bakefile/presets
- (cd $(srcdir)/build/bakefiles/wxpresets/presets/ ; $(INSTALL_DATA) wx.bkl wx_unix.bkl wx_win32.bkl $(DESTDIR)$(datadir)/bakefile/presets)
+- (cd $(srcdir)/build/bakefiles/wxpresets/presets/ ; $(INSTALL_DATA) wx.bkl wx_unix.bkl wx_win32.bkl $(DESTDIR)$(datadir)/bakefile/presets)
- $(INSTALL_DIR) $(DESTDIR)$(libdir)/wx/include/$(TOOLCHAIN_FULLNAME)/wx
- for f in setup.h $(RCDEFS_H); do \
- if test ! -d $(DESTDIR)$(libdir)/wx/include/$(TOOLCHAIN_FULLNAME)/wx/`dirname $$f` ; then \
@@ -29,6 +30,7 @@
- fi; \
- $(INSTALL_DATA) ./lib/wx/include/$(TOOLCHAIN_FULLNAME)/wx//$$f $(DESTDIR)$(libdir)/wx/include/$(TOOLCHAIN_FULLNAME)/wx/$$f; \
- done
++ (cd $(srcdir)/build/bakefiles/wxpresets/presets/ ; for i in wx.bkl wx_unix.bkl wx_win32.bkl; do $(INSTALL_DATA) $$i $(DESTDIR)$(datadir)/bakefile/presets/wx$(WX_RELEASE_NODOT)$${i##wx}; done)
$(INSTALL_DIR) $(DESTDIR)$(includedir)/wx-$(WX_RELEASE)$(WX_FLAVOUR)
for f in $(ALL_HEADERS); do \
if test ! -d $(DESTDIR)$(includedir)/wx-$(WX_RELEASE)$(WX_FLAVOUR)/`dirname $$f` ; then \
@@ -43,3 +45,12 @@
locale_install:
$(INSTALL_DIR) $(DESTDIR)$(datadir)/locale
+@@ -9941,7 +9937,7 @@
+ $(INSTALL_DIR) $(DESTDIR)$(datadir)/locale/$$l ; \
+ $(INSTALL_DIR) $(DESTDIR)$(datadir)/locale/$$l/LC_MESSAGES ; \
+ if test -f $(srcdir)/locale/$$l.mo ; then \
+- $(INSTALL_DATA) $(srcdir)/locale/$$l.mo $(DESTDIR)$(datadir)/locale/$$l/LC_MESSAGES/wxstd.mo ; \
++ $(INSTALL_DATA) $(srcdir)/locale/$$l.mo $(DESTDIR)$(datadir)/locale/$$l/LC_MESSAGES/wxstd$(WX_RELEASE_NODOT).mo ; \
+ fi ; \
+ done
+
diff --git a/x11-toolkits/wxgtk26/files/patch-src-common-intl.cpp b/x11-toolkits/wxgtk26/files/patch-src-common-intl.cpp
new file mode 100644
index 000000000000..7d964d6826d1
--- /dev/null
+++ b/x11-toolkits/wxgtk26/files/patch-src-common-intl.cpp
@@ -0,0 +1,20 @@
+--- src/common/intl.cpp.orig Wed Mar 22 05:42:10 2006
++++ src/common/intl.cpp Tue Jan 9 00:27:17 2007
+@@ -1452,6 +1452,8 @@
+ m_initialized = false;
+ }
+
++#define wxSTRINGIZE2(x) wxSTRINGIZE(x)
++
+ // NB: this function has (desired) side effect of changing current locale
+ bool wxLocale::Init(const wxChar *szName,
+ const wxChar *szShort,
+@@ -1520,7 +1522,7 @@
+ bool bOk = true;
+ if ( bLoadDefault )
+ {
+- bOk = AddCatalog(wxT("wxstd"));
++ bOk = AddCatalog(wxT("wxstd" wxSTRINGIZE2(wxMAJOR_VERSION) wxSTRINGIZE2(wxMINOR_VERSION)));
+
+ // there may be a catalog with toolkit specific overrides, it is not
+ // an error if this does not exist