aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/wxgtk29/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-03-24 14:11:02 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-03-24 14:11:02 +0000
commitccf772b806ca72c170748b80c6012fa34fb1bc99 (patch)
treedbc82c20d9d870644745ee21eda5cca72ea4b76b /x11-toolkits/wxgtk29/Makefile
parent8ad8bd969b4a510af943bc7b13ca57f79de8fa22 (diff)
downloadports-ccf772b806ca72c170748b80c6012fa34fb1bc99.tar.gz
ports-ccf772b806ca72c170748b80c6012fa34fb1bc99.zip
Notes
Diffstat (limited to 'x11-toolkits/wxgtk29/Makefile')
-rw-r--r--x11-toolkits/wxgtk29/Makefile70
1 files changed, 0 insertions, 70 deletions
diff --git a/x11-toolkits/wxgtk29/Makefile b/x11-toolkits/wxgtk29/Makefile
deleted file mode 100644
index 9b86193a9a6f..000000000000
--- a/x11-toolkits/wxgtk29/Makefile
+++ /dev/null
@@ -1,70 +0,0 @@
-# Created by: fjoe@FreeBSD.org
-# $FreeBSD$
-
-PORTNAME= wx
-PORTVERSION= 2.9.4
-PORTREVISION= 1
-CATEGORIES= x11-toolkits
-MASTER_SITES= SF/wxwindows/${PORTVERSION}
-PKGNAMESUFFIX= 29-gtk2
-DISTNAME= wxWidgets-${PORTVERSION}
-
-MAINTAINER?= fjoe@FreeBSD.org
-COMMENT?= The wxWidgets GUI toolkit with GTK+ bindings
-
-LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png\
- jpeg.11:${PORTSDIR}/graphics/jpeg\
- tiff.4:${PORTSDIR}/graphics/tiff\
- expat.6:${PORTSDIR}/textproc/expat2\
- inotify.0:${PORTSDIR}/devel/libinotify\
- webkitgtk-1.0.0:${PORTSDIR}/www/webkit-gtk2
-
-USES+= iconv gmake pkgconfig
-USE_BZIP2= yes
-USE_XORG= x11 sm xxf86vm xinerama
-USE_GL= glu
-USE_GNOME= gtk20
-USE_LDCONFIG= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libpng=sys\
- --with-libjpeg=sys\
- --with-libtiff=sys\
- --with-zlib=sys\
- --with-expat=sys\
- --with-opengl\
- --with-mspack\
- --with-gtk\
- --enable-mediactrl\
- --disable-backtrace\
- --enable-graphics_ctx
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS} -linotify"\
- PTHREAD_LIBS="${PTHREAD_LIBS}"\
- X11BASE="${LOCALBASE}"
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-NO_LATEST_LINK= yes
-
-OPTIONS_DEFINE= GSTREAMER MSPACK
-OPTIONS_DEFAULT= GSTREAMER MSPACK
-MSPACK_DESC= MS archives support
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MGSTREAMER}
-CONFIGURE_ARGS+=--enable-mediactrl
-USE_GNOME+= gconf2
-USE_GSTREAMER= yes
-PLIST_SUB+= GSTREAMER=""
-.else
-CONFIGURE_ARGS+=--disable-mediactrl
-PLIST_SUB+= GSTREAMER="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MMSPACK}
-CONFIGURE_ARGS+=--with-libmspack
-LIB_DEPENDS+= mspack.1:${PORTSDIR}/archivers/libmspack
-.else
-CONFIGURE_ARGS+=--without-libmspack
-.endif
-
-.include <bsd.port.mk>