aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/wxgtk29
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2009-11-28 20:06:37 +0000
commitf76d32b8e89fed7c0e459c1a7fe7a4b57661b01c (patch)
treead29e6808ff698f84e08dab8e047f0ae72838df9 /x11-toolkits/wxgtk29
parent873cae3ab41a109b6f9cf9f4149f101d6d996235 (diff)
downloadports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.tar.gz
ports-f76d32b8e89fed7c0e459c1a7fe7a4b57661b01c.zip
Notes
Diffstat (limited to 'x11-toolkits/wxgtk29')
-rw-r--r--x11-toolkits/wxgtk29/Makefile2
-rw-r--r--x11-toolkits/wxgtk29/files/patch-include__wx__gtk__win_gtk.h12
-rw-r--r--x11-toolkits/wxgtk29/files/patch-src-gtk-gsockgtk.cpp16
3 files changed, 29 insertions, 1 deletions
diff --git a/x11-toolkits/wxgtk29/Makefile b/x11-toolkits/wxgtk29/Makefile
index 321c75cc900a..e8510b09c18d 100644
--- a/x11-toolkits/wxgtk29/Makefile
+++ b/x11-toolkits/wxgtk29/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wx
PORTVERSION= 2.8.10
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= x11-toolkits
MASTER_SITES= SF/wxwindows/wxGTK/${PORTVERSION}
PKGNAMESUFFIX= ${WXGTK_FLAVOR}
diff --git a/x11-toolkits/wxgtk29/files/patch-include__wx__gtk__win_gtk.h b/x11-toolkits/wxgtk29/files/patch-include__wx__gtk__win_gtk.h
new file mode 100644
index 000000000000..d9c66f279bee
--- /dev/null
+++ b/x11-toolkits/wxgtk29/files/patch-include__wx__gtk__win_gtk.h
@@ -0,0 +1,12 @@
+--- include/wx/gtk/win_gtk.h.orig 2009-11-27 01:59:18.000000000 +0100
++++ include/wx/gtk/win_gtk.h 2009-11-27 01:59:33.000000000 +0100
+@@ -15,7 +15,9 @@
+ extern "C" {
+ #endif /* __cplusplus */
+
++#define GSocket GlibGSocket
+ #include <gtk/gtkcontainer.h>
++#undef GSocket
+
+ #include "wx/dlimpexp.h"
+
diff --git a/x11-toolkits/wxgtk29/files/patch-src-gtk-gsockgtk.cpp b/x11-toolkits/wxgtk29/files/patch-src-gtk-gsockgtk.cpp
new file mode 100644
index 000000000000..113f73e51ced
--- /dev/null
+++ b/x11-toolkits/wxgtk29/files/patch-src-gtk-gsockgtk.cpp
@@ -0,0 +1,16 @@
+--- src/gtk//gsockgtk.cpp.orig 2007-03-20 16:50:07.000000000 +0100
++++ src/gtk/gsockgtk.cpp 2009-09-18 14:46:47.000000000 +0200
+@@ -14,8 +14,13 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+
++// newer versions of glib define its own GSocket but we unfortunately use this
++// name in our own (semi-)public header and so can't change it -- rename glib
++// one instead
++#define GSocket GlibGSocket
+ #include <gdk/gdk.h>
+ #include <glib.h>
++#undef GSocket
+
+ #include "wx/gsocket.h"
+ #include "wx/unix/gsockunx.h"