aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/xmhtml
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /x11-toolkits/xmhtml
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
- update png to 1.5.10
Notes
Notes: svn path=/head/; revision=297915
Diffstat (limited to 'x11-toolkits/xmhtml')
-rw-r--r--x11-toolkits/xmhtml/Makefile6
-rw-r--r--x11-toolkits/xmhtml/files/patch-lib_common_readPNG.c28
2 files changed, 32 insertions, 2 deletions
diff --git a/x11-toolkits/xmhtml/Makefile b/x11-toolkits/xmhtml/Makefile
index 271aa17fbe49..541322ac14b1 100644
--- a/x11-toolkits/xmhtml/Makefile
+++ b/x11-toolkits/xmhtml/Makefile
@@ -7,20 +7,22 @@
PORTNAME= XmHTML
PORTVERSION= 1.1.7
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= x11-toolkits www
MASTER_SITES= ${MASTER_SITE_NETBSD}
MAINTAINER= ports@FreeBSD.org
COMMENT= A Motif widget set for displaying HTML 3.2 documents
-LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png \
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
jpeg.11:${PORTSDIR}/graphics/jpeg
USE_AUTOTOOLS= libtool:env
USE_MOTIF= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
+USE_XORG= xmu
+CFLAGS+= -I${LOCALBASE}/include/libpng15
do-configure:
@${DO_NADA}
diff --git a/x11-toolkits/xmhtml/files/patch-lib_common_readPNG.c b/x11-toolkits/xmhtml/files/patch-lib_common_readPNG.c
new file mode 100644
index 000000000000..5bbffea2ef9e
--- /dev/null
+++ b/x11-toolkits/xmhtml/files/patch-lib_common_readPNG.c
@@ -0,0 +1,28 @@
+--- lib/common/readPNG.c.orig 1998-11-16 23:56:19.000000000 +0100
++++ lib/common/readPNG.c 2012-05-26 14:16:45.000000000 +0200
+@@ -82,6 +82,7 @@
+
+ #ifdef HAVE_LIBPNG
+ #include <png.h>
++#include <pngpriv.h>
+ #include <setjmp.h>
+ #include <math.h> /* required for full alpha channel processing */
+ #endif
+@@ -132,7 +133,7 @@
+
+ _XmHTMLWarning(__WFUNC__(NULL, "png_error"), XMHTML_MSG_121, "png",
+ ib->file, msg);
+- longjmp(png_ptr->jmpbuf, 1);
++ longjmp(png_jmpbuf(png_ptr), 1);
+ }
+
+ /*****
+@@ -232,7 +233,7 @@
+ return((XmHTMLRawImageData*)NULL);
+ }
+ /* now set error handler */
+- if(setjmp(png_ptr->jmpbuf))
++ if(setjmp(png_jmpbuf(png_ptr)))
+ {
+ /*
+ * PNG signalled an error. Destroy image data, free any allocated