aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits/xscoop
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-11-24 11:49:40 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-11-24 11:49:40 +0000
commit12818d23bf6f5699f6a808f8bc5614570b924dea (patch)
tree60e8bbc9908b47d1859b2d4a44f11581eb79e87e /x11-toolkits/xscoop
parent1c9dca221a90bcf74d9f355826ab4d1fcbe43f11 (diff)
downloadports-12818d23bf6f5699f6a808f8bc5614570b924dea.tar.gz
ports-12818d23bf6f5699f6a808f8bc5614570b924dea.zip
Notes
Diffstat (limited to 'x11-toolkits/xscoop')
-rw-r--r--x11-toolkits/xscoop/Makefile27
-rw-r--r--x11-toolkits/xscoop/distinfo3
-rw-r--r--x11-toolkits/xscoop/pkg-descr6
3 files changed, 36 insertions, 0 deletions
diff --git a/x11-toolkits/xscoop/Makefile b/x11-toolkits/xscoop/Makefile
new file mode 100644
index 000000000000..46f9c0022cf3
--- /dev/null
+++ b/x11-toolkits/xscoop/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: xscoop
+# Date created: Sa 04 Nov 2005 00:00:00 MET DST
+# Whom: Ron Scheckelhoff <rscheckelhoff@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xscoop
+PORTVERSION= 1.0.1
+CATEGORIES= x11-toolkits
+MASTER_SITES= ftp://ftp.datazygte.com/ports/x11-toolkits/xscoop/
+
+MAINTAINER= rscheckelhoff@yahoo.com
+COMMENT= An X library detective
+
+MAN7= xscoop.7
+PLIST_FILES= bin/xscoop
+PORTDOCS= xscoop.pdf
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xscoop ${PREFIX}/bin/xscoop
+ ${INSTALL_MAN} ${WRKSRC}/xscoop.7 ${MAN7PREFIX}/man/man7/xscoop.7
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/xscoop.pdf ${DOCSDIR}/xscoop.pdf
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/xscoop/distinfo b/x11-toolkits/xscoop/distinfo
new file mode 100644
index 000000000000..57907c0a2b86
--- /dev/null
+++ b/x11-toolkits/xscoop/distinfo
@@ -0,0 +1,3 @@
+MD5 (xscoop-1.0.1.tar.gz) = a407dd3e7fae0cd1559d935008f15d67
+SHA256 (xscoop-1.0.1.tar.gz) = b2ba1530768e14d0f3e6e10b61f2e50ea3fb5cb8076ddb4d37b7cecf7ad67c11
+SIZE (xscoop-1.0.1.tar.gz) = 89457
diff --git a/x11-toolkits/xscoop/pkg-descr b/x11-toolkits/xscoop/pkg-descr
new file mode 100644
index 000000000000..b482766dc5eb
--- /dev/null
+++ b/x11-toolkits/xscoop/pkg-descr
@@ -0,0 +1,6 @@
+XScoop provides the ability to quickly determine which underlying X libraries
+were statically linked into an application, even when the source is not
+available. XScoop parses an executable, looking for matches on a subset of
+sample keywords that may identify the library being used. It does not produce
+absolute results, and instead supplies a report with key-hits which represent
+the likelihood that a particular library is present in the binary.