aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorMichael Reifenberger <mr@FreeBSD.org>2018-09-14 15:32:20 +0000
committerMichael Reifenberger <mr@FreeBSD.org>2018-09-14 15:32:20 +0000
commita08fe0f3c8e677d189677199a3e5dab95907e668 (patch)
tree2cc2dda27868737ca9076cc676b9e4f618b19774 /x11-toolkits
parent16ddded550d48ac65ee409b292a31b06394708c9 (diff)
downloadports-a08fe0f3c8e677d189677199a3e5dab95907e668.tar.gz
ports-a08fe0f3c8e677d189677199a3e5dab95907e668.zip
Add Wx::GLCanvas
Notes
Notes: svn path=/head/; revision=479774
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/p5-Wx-GLCanvas/Makefile41
-rw-r--r--x11-toolkits/p5-Wx-GLCanvas/distinfo3
-rw-r--r--x11-toolkits/p5-Wx-GLCanvas/pkg-descr5
-rw-r--r--x11-toolkits/p5-Wx-GLCanvas/pkg-plist5
5 files changed, 55 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index ed6ee769f485..a9fa5c2a3d28 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -188,6 +188,7 @@
SUBDIR += p5-Tk-ToolBar
SUBDIR += p5-Tk-WaitBox
SUBDIR += p5-Wx
+ SUBDIR += p5-Wx-GLCanvas
SUBDIR += p5-Wx-Perl-ProcessStream
SUBDIR += pango
SUBDIR += pango-reference
diff --git a/x11-toolkits/p5-Wx-GLCanvas/Makefile b/x11-toolkits/p5-Wx-GLCanvas/Makefile
new file mode 100644
index 000000000000..592817550493
--- /dev/null
+++ b/x11-toolkits/p5-Wx-GLCanvas/Makefile
@@ -0,0 +1,41 @@
+# Created by: mr
+# $FreeBSD$
+
+PORTNAME= Wx-GLCanvas
+PORTVERSION= 0.09
+PORTREVISION= 1
+CATEGORIES= x11-toolkits perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:MBARBON
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mr@FreeBSD.org
+COMMENT= Perl interface to wxWidgets' OpenGL canvas
+
+BUILD_DEPENDS= p5-OpenGL>=0.66:graphics/p5-OpenGL \
+ p5-Wx>=0.5000:x11-toolkits/p5-Wx
+RUN_DEPENDS= p5-OpenGL>=0.66:graphics/p5-OpenGL \
+ p5-Wx>=0.5000:x11-toolkits/p5-Wx
+
+#MANUAL_PACKAGE_BUILD= needs the X server it will be used with to build
+
+PORTSCOUT= limit:^[0-9\.]*$$
+
+USES= compiler:c++11-lib perl5
+USE_CXXSTD= c++11
+USE_PERL5= configure
+USE_WX= 3.0
+CONFIGURE_ENV= CXX="${CXX}"
+
+CFLAGS+= -pthread -Wno-write-strings -I${LOCALBASE}/include
+
+post-configure:
+ @${FIND} ${WRKSRC} -name "Makefile" -type f | ${XARGS} \
+ ${REINPLACE_CMD} -e \
+ 's|$$(CC)|$$(CXX)|g ; \
+ s|$$(CCFLAGS)|$$(CXXFLAGS)|g'
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/p5-Wx-GLCanvas/distinfo b/x11-toolkits/p5-Wx-GLCanvas/distinfo
new file mode 100644
index 000000000000..429a3271f154
--- /dev/null
+++ b/x11-toolkits/p5-Wx-GLCanvas/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1536929122
+SHA256 (Wx-GLCanvas-0.09.tar.gz) = 6ad2c29ff06ff80a5c8b4b9d1d6bf0aed57489e831be59c94494f4f688dc8fe0
+SIZE (Wx-GLCanvas-0.09.tar.gz) = 13910
diff --git a/x11-toolkits/p5-Wx-GLCanvas/pkg-descr b/x11-toolkits/p5-Wx-GLCanvas/pkg-descr
new file mode 100644
index 000000000000..5ca6979bf127
--- /dev/null
+++ b/x11-toolkits/p5-Wx-GLCanvas/pkg-descr
@@ -0,0 +1,5 @@
+Wx::GLCanvas - interface to wxWidgets' OpenGL canvas
+
+The documentation for this module is included in the main wxPerl distribution (wxGLCanvas).
+
+WWW: https://metacpan.org/release/Wx-GLCanvas
diff --git a/x11-toolkits/p5-Wx-GLCanvas/pkg-plist b/x11-toolkits/p5-Wx-GLCanvas/pkg-plist
new file mode 100644
index 000000000000..4999d65b6bb6
--- /dev/null
+++ b/x11-toolkits/p5-Wx-GLCanvas/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_ARCH%%/Wx/DemoModules/wxGLCanvas.pm
+%%SITE_ARCH%%/Wx/GLCanvas.pm
+%%SITE_ARCH%%/auto/Wx/GLCanvas/.packlist
+%%SITE_ARCH%%/auto/Wx/GLCanvas/GLCanvas.so
+%%PERL5_MAN3%%/Wx::GLCanvas.3.gz