aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2014-02-11 20:43:46 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2014-02-11 20:43:46 +0000
commitf37fa386ed61192d13be5de65196b1e08b6335bd (patch)
treeeffcb76ec7bf17e04e83ec7a6c889f4aec1e248d /x11-toolkits
parent228483239730b544d11d2a279baa05a0a86ee7c5 (diff)
downloadports-f37fa386ed61192d13be5de65196b1e08b6335bd.tar.gz
ports-f37fa386ed61192d13be5de65196b1e08b6335bd.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/granite/Makefile1
-rw-r--r--x11-toolkits/granite/files/patch-lib__CMakeLists.txt8
2 files changed, 5 insertions, 4 deletions
diff --git a/x11-toolkits/granite/Makefile b/x11-toolkits/granite/Makefile
index 30f0ff3aa543..801b90095918 100644
--- a/x11-toolkits/granite/Makefile
+++ b/x11-toolkits/granite/Makefile
@@ -4,6 +4,7 @@
PORTNAME= granite
PORTVERSION= 0.2.3
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= https://launchpadlibrarian.net/159802745/ \
https://launchpad.net/${PORTNAME}/${PORTVERSION:R}/${PORTVERSION}/+download/
diff --git a/x11-toolkits/granite/files/patch-lib__CMakeLists.txt b/x11-toolkits/granite/files/patch-lib__CMakeLists.txt
index 58a9e0036037..fd7137421488 100644
--- a/x11-toolkits/granite/files/patch-lib__CMakeLists.txt
+++ b/x11-toolkits/granite/files/patch-lib__CMakeLists.txt
@@ -1,12 +1,12 @@
---- ./lib/CMakeLists.txt.orig 2013-08-10 02:01:58.000000000 +0000
-+++ ./lib/CMakeLists.txt 2013-09-28 15:05:02.000000000 +0000
-@@ -63,7 +63,12 @@
+--- ./lib/CMakeLists.txt.orig 2013-12-15 12:43:00.000000000 +0000
++++ ./lib/CMakeLists.txt 2014-02-11 21:08:46.000000000 +0000
+@@ -64,7 +64,12 @@
if(NOT DEFINED LIB_INSTALL_DIR)
set(LIB_INSTALL_DIR "${CMAKE_INSTALL_PREFIX}/lib")
endif()
-install (FILES ${CMAKE_CURRENT_BINARY_DIR}/${PKG_NAME}.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)
+
-+if (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD")
++if (${CMAKE_SYSTEM_NAME} MATCHES "FreeBSD" OR ${CMAKE_SYSTEM_NAME} MATCHES "DragonFly")
+ install (FILES ${CMAKE_CURRENT_BINARY_DIR}/${PKG_NAME}.pc DESTINATION ${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig)
+else ()
+ install (FILES ${CMAKE_CURRENT_BINARY_DIR}/${PKG_NAME}.pc DESTINATION ${LIB_INSTALL_DIR}/pkgconfig)