aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-09-13 18:37:25 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-09-13 18:37:25 +0000
commitf3b14481cbbb0bb6a5a1dbcdaf9fa00e5e062796 (patch)
treea5a46ae770d5c5a508c001be86a241a8a7113402 /x11-toolkits
parent76e871178375de9a41b5852a8c01fad501567a9d (diff)
downloadports-f3b14481cbbb0bb6a5a1dbcdaf9fa00e5e062796.tar.gz
ports-f3b14481cbbb0bb6a5a1dbcdaf9fa00e5e062796.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/wxd/Makefile46
-rw-r--r--x11-toolkits/wxd/distinfo3
-rw-r--r--x11-toolkits/wxd/files/patch-Makefile35
-rw-r--r--x11-toolkits/wxd/files/patch-wx-Makefile38
-rw-r--r--x11-toolkits/wxd/files/patch-wxc-Makefile35
-rw-r--r--x11-toolkits/wxd/pkg-descr14
-rw-r--r--x11-toolkits/wxd/pkg-plist474
8 files changed, 646 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index e63548869357..69474ca53d8b 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -226,6 +226,7 @@
SUBDIR += vte
SUBDIR += vte-reference
SUBDIR += wmapp
+ SUBDIR += wxd
SUBDIR += wxgtk24
SUBDIR += wxgtk24-contrib
SUBDIR += wxgtk24-docs
diff --git a/x11-toolkits/wxd/Makefile b/x11-toolkits/wxd/Makefile
new file mode 100644
index 000000000000..fcbf16b61922
--- /dev/null
+++ b/x11-toolkits/wxd/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: wxd
+# Date created: 29 August 2006
+# Whom: Jona Joachim <walkingshadow@grummel.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wxd
+PORTVERSION= 0.07
+CATEGORIES= x11-toolkits devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= walkingshadow@grummel.net
+COMMENT= wxWidgets bindings for the D programming language
+
+BUILD_DEPENDS= gdc:${PORTSDIR}/lang/gdc
+
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_WX= 2.6
+WX_UNICODE= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+pre-patch:
+ @${RM} ${WRKSRC}/Makefile
+ @${MV} ${WRKSRC}/GNUmakefile ${WRKSRC}/Makefile
+ @${RM} ${WRKSRC}/wxc/Makefile
+ @${MV} ${WRKSRC}/wxc/GNUmakefile ${WRKSRC}/wxc/Makefile
+ @${RM} ${WRKSRC}/wx/Makefile
+ @${MV} ${WRKSRC}/wx/GNUmakefile ${WRKSRC}/wx/Makefile
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${CP} -R ${WRKSRC}/Samples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= needs FreeBSD 5.x or later
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/wxd/distinfo b/x11-toolkits/wxd/distinfo
new file mode 100644
index 000000000000..d1819a912472
--- /dev/null
+++ b/x11-toolkits/wxd/distinfo
@@ -0,0 +1,3 @@
+MD5 (wxd-0.07.tgz) = 13408508a459c89a2e4c104935b7e6a3
+SHA256 (wxd-0.07.tgz) = 68e813775f2bf3d057650e097659107fb2e1d8ecf9dc9879a9bcda2f267c7d49
+SIZE (wxd-0.07.tgz) = 1025177
diff --git a/x11-toolkits/wxd/files/patch-Makefile b/x11-toolkits/wxd/files/patch-Makefile
new file mode 100644
index 000000000000..54c4328f087a
--- /dev/null
+++ b/x11-toolkits/wxd/files/patch-Makefile
@@ -0,0 +1,35 @@
+--- /home/default/ports/wxd/work/wxd/GNUmakefile Sat Aug 26 23:30:32 2006
++++ Makefile Thu Aug 31 19:14:34 2006
+@@ -1,26 +1,21 @@
+-MAKE=make
+-
++#Makefile
++#call: gmake MAKE=gmake WX_CONFIG=wxgtk2-2.6-config (wxgtk2u-2.6-config)
+ OS=$(shell uname)
+-ARCH=$(shell (arch 2>/dev/null || echo i386) | sed -e s/i.86/x86/ )
++ARCH=$(shell (uname -m) | sed -e s/i.86/x86/ )
+
+-ifeq ("$(OS) $(ARCH)","Linux x86")
+-COMPILER=DMD
+-DMD=dmd
+-else
+ COMPILER=GDC
+-DMD=gdmd
+-endif
++DMD=gdc
+
+ PLATFORM=$(shell cat wxc/platform 2>/dev/null )
+ export PLATFORM
+
+ CXX_WXD = $(CXX) -D__$(COMPILER)__
+-DMD_WXD = $(DMD) -version=__$(PLATFORM)__
++DMD_WXD = $(DMD) -fversion=__$(PLATFORM)__
+
+ all: wxc/platform
+ $(MAKE) CXX="$(CXX_WXD)" -C wxc
+ $(MAKE) DMD="$(DMD_WXD)" -C wx
+- $(MAKE) DMD="$(DMD_WXD)" -C Samples
++# $(MAKE) DMD="$(DMD_WXD)" -C Samples
+
+ install:
+ $(MAKE) CXX="$(CXX_WXD)" install -C wxc
diff --git a/x11-toolkits/wxd/files/patch-wx-Makefile b/x11-toolkits/wxd/files/patch-wx-Makefile
new file mode 100644
index 000000000000..a63c2f30dbba
--- /dev/null
+++ b/x11-toolkits/wxd/files/patch-wx-Makefile
@@ -0,0 +1,38 @@
+--- /home/default/ports/wxd/work/wxd/wx/GNUmakefile Sat Aug 26 23:26:21 2006
++++ wx/Makefile Thu Aug 31 19:36:21 2006
+@@ -1,3 +1,4 @@
++#wx/Makefile
+ LIBTARGET = ../libwxd.a
+
+ OBJECTS = \
+@@ -167,10 +168,10 @@
+
+ all: $(LIBTARGET)
+
+-DMD = dmd
+-DFLAGS = -O -w -g
++DMD = gdc
++DFLAGS += -O2
+
+-prefix=/usr/local
++prefix=$(PREFIX)
+ exec_prefix=$(prefix)
+ includedir=$(prefix)/include
+ libdir=$(exec_prefix)/lib
+@@ -179,11 +180,11 @@
+ RANLIB = ranlib
+
+ install: $(LIBTARGET)
+- $(INSTALL) -d $(DESTDIR)$(libdir)
+- $(INSTALL) -p $(LIBTARGET) $(DESTDIR)$(libdir)
+- $(INSTALL) -d $(DESTDIR)$(includedir)/d/wx
+- $(INSTALL) -p *.d $(DESTDIR)$(libdir)/d/wx
+- -$(RANLIB) $(DESTDIR)$(libdir)/`basename $(LIBTARGET)`
++ $(INSTALL) -d $(libdir)
++ $(INSTALL) -p $(LIBTARGET) $(libdir)
++ $(INSTALL) -d $(includedir)/d/wx
++ $(INSTALL) -p *.d $(includedir)/d/wx/
++ -$(RANLIB) $(libdir)/`basename $(LIBTARGET)`
+
+ ddoc:
+ $(DMD) -c -o- -D $(DFLAGS) -I.. $(SOURCES)
diff --git a/x11-toolkits/wxd/files/patch-wxc-Makefile b/x11-toolkits/wxd/files/patch-wxc-Makefile
new file mode 100644
index 000000000000..2f2c6707a8ac
--- /dev/null
+++ b/x11-toolkits/wxd/files/patch-wxc-Makefile
@@ -0,0 +1,35 @@
+--- /home/default/ports/wxd/work/wxd/wxc/GNUmakefile Sat Aug 26 23:25:11 2006
++++ wxc/Makefile Thu Aug 31 19:09:15 2006
+@@ -1,3 +1,4 @@
++#wxc/Makefile
+ LIBTARGET=../libwxc.a
+
+ OBJECTS = \
+@@ -158,12 +159,10 @@
+
+ all: platform $(LIBTARGET)
+
+-WX_CONFIG = wx-config
+-
+ CXX = $(shell $(WX_CONFIG) --cxx)
+-CXXFLAGS = -O2 -Wall
++CXXFLAGS += -O2 -Wall -I/usr/X11R6/include
+
+-prefix=/usr/local
++prefix=$(PREFIX)
+ exec_prefix=$(prefix)
+ includedir=$(prefix)/include
+ libdir=$(exec_prefix)/lib
+@@ -172,9 +171,9 @@
+ RANLIB = ranlib
+
+ install: $(LIBTARGET)
+- $(INSTALL) -d $(DESTDIR)$(libdir)
+- $(INSTALL) -p $(LIBTARGET) $(DESTDIR)$(libdir)
+- -$(RANLIB) $(DESTDIR)$(libdir)/`basename $(LIBTARGET)`
++ $(INSTALL) -d $(libdir)
++ $(INSTALL) -p $(LIBTARGET) $(libdir)
++ -$(RANLIB) $(libdir)/`basename $(LIBTARGET)`
+
+ platform:
+ $(WX_CONFIG) --cflags | sed -e 's/.*\-D__\(WX.*\)__.*/\1/' > $@
diff --git a/x11-toolkits/wxd/pkg-descr b/x11-toolkits/wxd/pkg-descr
new file mode 100644
index 000000000000..ec13fe32c5eb
--- /dev/null
+++ b/x11-toolkits/wxd/pkg-descr
@@ -0,0 +1,14 @@
+wxWidgets is a C++ cross-platform GUI toolkit.
+Link with the appropriate library for your platform and
+compiler, and your application will adopt the look and
+feel appropriate to that platform.
+
+D is a general purpose systems and applications programming
+language. It is a higher level language than C++, but retains the
+ability to write high performance code and interface directly
+with the operating system API's and with hardware. D is not a
+scripting language, nor an interpreted language.
+
+wxD is wxWidgets bindings for the D programming language.
+
+WWW: http://wxd.sourceforge.net/
diff --git a/x11-toolkits/wxd/pkg-plist b/x11-toolkits/wxd/pkg-plist
new file mode 100644
index 000000000000..029eb3603e47
--- /dev/null
+++ b/x11-toolkits/wxd/pkg-plist
@@ -0,0 +1,474 @@
+include/d/wx/Accelerator.d
+include/d/wx/ActivateEvent.d
+include/d/wx/App.d
+include/d/wx/ArrayInt.d
+include/d/wx/ArrayString.d
+include/d/wx/ArtProvider.d
+include/d/wx/Bitmap.d
+include/d/wx/BitmapButton.d
+include/d/wx/BoxSizer.d
+include/d/wx/Brush.d
+include/d/wx/Button.d
+include/d/wx/CalendarCtrl.d
+include/d/wx/Caret.d
+include/d/wx/CheckBox.d
+include/d/wx/ChildFocusEvent.d
+include/d/wx/Choice.d
+include/d/wx/ChoiceDialog.d
+include/d/wx/ClientData.d
+include/d/wx/Clipboard.d
+include/d/wx/CloseEvent.d
+include/d/wx/Colour.d
+include/d/wx/ColourDialog.d
+include/d/wx/ComboBox.d
+include/d/wx/CommandEvent.d
+include/d/wx/Config.d
+include/d/wx/ContextMenuEvent.d
+include/d/wx/Control.d
+include/d/wx/Cursor.d
+include/d/wx/DC.d
+include/d/wx/DND.d
+include/d/wx/DataFormat.d
+include/d/wx/DataObject.d
+include/d/wx/DbGrid.d
+include/d/wx/Defs.d
+include/d/wx/Dialog.d
+include/d/wx/DirDialog.d
+include/d/wx/Display.d
+include/d/wx/DisplayChangedEvent.d
+include/d/wx/DocManager.d
+include/d/wx/DocTemplate.d
+include/d/wx/Document.d
+include/d/wx/EraseEvent.d
+include/d/wx/Event.d
+include/d/wx/EvtHandler.d
+include/d/wx/FileDialog.d
+include/d/wx/FindReplaceDialog.d
+include/d/wx/FlexGridSizer.d
+include/d/wx/FocusEvent.d
+include/d/wx/Font.d
+include/d/wx/FontDialog.d
+include/d/wx/FontMisc.d
+include/d/wx/Frame.d
+include/d/wx/GDIObject.d
+include/d/wx/GLCanvas.d
+include/d/wx/Gauge.d
+include/d/wx/GdiCommon.d
+include/d/wx/Grid.d
+include/d/wx/GridBagSizer.d
+include/d/wx/GridCtrl.d
+include/d/wx/GridSizer.d
+include/d/wx/HTML.d
+include/d/wx/HelpEvent.d
+include/d/wx/HtmlHelpController.d
+include/d/wx/HtmlListBox.d
+include/d/wx/IControlWithItems.d
+include/d/wx/Icon.d
+include/d/wx/IconizeEvent.d
+include/d/wx/IdleEvent.d
+include/d/wx/Image.d
+include/d/wx/ImageHandlers.d
+include/d/wx/ImageList.d
+include/d/wx/InitDialogEvent.d
+include/d/wx/KeyEvent.d
+include/d/wx/LayoutWin.d
+include/d/wx/ListBox.d
+include/d/wx/ListCtrl.d
+include/d/wx/Listbook.d
+include/d/wx/Locale.d
+include/d/wx/Log.d
+include/d/wx/MDI.d
+include/d/wx/MaximizeEvent.d
+include/d/wx/MemoryDC.d
+include/d/wx/Menu.d
+include/d/wx/MenuBar.d
+include/d/wx/MenuItem.d
+include/d/wx/MessageDialog.d
+include/d/wx/MiniFrame.d
+include/d/wx/MouseCaptureChangedEvent.d
+include/d/wx/MouseEvent.d
+include/d/wx/MoveEvent.d
+include/d/wx/NavigationKeyEvent.d
+include/d/wx/NcPaintEvent.d
+include/d/wx/Notebook.d
+include/d/wx/NotebookSizer.d
+include/d/wx/NotifyEvent.d
+include/d/wx/NumberDialog.d
+include/d/wx/PaintEvent.d
+include/d/wx/Palette.d
+include/d/wx/PaletteChangedEvent.d
+include/d/wx/Panel.d
+include/d/wx/Pen.d
+include/d/wx/PrintData.d
+include/d/wx/PrintDialog.d
+include/d/wx/PrintPreview.d
+include/d/wx/Printer.d
+include/d/wx/ProgressDialog.d
+include/d/wx/QueryNewPaletteEvent.d
+include/d/wx/RadioBox.d
+include/d/wx/RadioButton.d
+include/d/wx/Region.d
+include/d/wx/SashWindow.d
+include/d/wx/ScrollBar.d
+include/d/wx/ScrolledWindow.d
+include/d/wx/SetCursorEvent.d
+include/d/wx/ShowEvent.d
+include/d/wx/SizeEvent.d
+include/d/wx/Sizer.d
+include/d/wx/SizerItem.d
+include/d/wx/Slider.d
+include/d/wx/Sound.d
+include/d/wx/SpinButton.d
+include/d/wx/SpinCtrl.d
+include/d/wx/SplashScreen.d
+include/d/wx/SplitterWindow.d
+include/d/wx/StaticBitmap.d
+include/d/wx/StaticBox.d
+include/d/wx/StaticBoxSizer.d
+include/d/wx/StaticLine.d
+include/d/wx/StaticText.d
+include/d/wx/StatusBar.d
+include/d/wx/StyledTextCtrl.d
+include/d/wx/SysColourChangedEvent.d
+include/d/wx/SystemSettings.d
+include/d/wx/TabCtrl.d
+include/d/wx/TextCtrl.d
+include/d/wx/TextDialog.d
+include/d/wx/TipDialog.d
+include/d/wx/TipWindow.d
+include/d/wx/ToggleButton.d
+include/d/wx/ToolBar.d
+include/d/wx/ToolTip.d
+include/d/wx/TreeCtrl.d
+include/d/wx/UpdateUIEvent.d
+include/d/wx/Utils.d
+include/d/wx/VLBox.d
+include/d/wx/VScroll.d
+include/d/wx/Validator.d
+include/d/wx/VideoMode.d
+include/d/wx/View.d
+include/d/wx/Window.d
+include/d/wx/WindowCreateEvent.d
+include/d/wx/WindowDestroyEvent.d
+include/d/wx/Wizard.d
+include/d/wx/WizardPage.d
+include/d/wx/WizardPageSimple.d
+include/d/wx/XmlResource.d
+include/d/wx/common.d
+include/d/wx/wx.d
+include/d/wx/wxDateTime.d
+include/d/wx/wxObject.d
+include/d/wx/wxPlatform.d
+include/d/wx/wxString.d
+include/d/wx/wxVersion.d
+lib/libwxc.a
+lib/libwxd.a
+%%PORTDOCS%%%%EXAMPLESDIR%%/Controls/Controls.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Controls/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Controls/Icons/choice.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Controls/Icons/combo.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Controls/Icons/gauge.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Controls/Icons/list.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Controls/Icons/radio.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Controls/Icons/stattext.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Controls/Icons/text.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Controls/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Controls/mondrian.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Dialogs/Dialogs.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Dialogs/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Dialogs/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Dialogs/mondrian.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Dialogs/tips.txt
+%%PORTDOCS%%%%EXAMPLESDIR%%/Display/CompareModesDialog.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Display/Display.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Display/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Display/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Dnd/Dnd.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Dnd/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Dnd/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Dnd/dnd_copy.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Dnd/dnd_move.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Dnd/dnd_none.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Dnd/mondrian.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/EventDemo/EventDemo.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/EventDemo/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/EventDemo/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Font/Font.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Font/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Font/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Font/mondrian.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/GLCube/GLCube.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/GLCube/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/GLCube/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/GLCube/glu32.lib
+%%PORTDOCS%%%%EXAMPLESDIR%%/GLCube/mondrian.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/GLCube/opengl32.lib
+%%PORTDOCS%%%%EXAMPLESDIR%%/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Grid/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Grid/Grid.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Grid/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Grid/mondrian.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/HTML/Data/8859_2.htm
+%%PORTDOCS%%%%EXAMPLESDIR%%/HTML/Data/about.htm
+%%PORTDOCS%%%%EXAMPLESDIR%%/HTML/Data/cp1250.htm
+%%PORTDOCS%%%%EXAMPLESDIR%%/HTML/Data/f.html
+%%PORTDOCS%%%%EXAMPLESDIR%%/HTML/Data/fft.html
+%%PORTDOCS%%%%EXAMPLESDIR%%/HTML/Data/i18n.gif
+%%PORTDOCS%%%%EXAMPLESDIR%%/HTML/Data/imagemap.htm
+%%PORTDOCS%%%%EXAMPLESDIR%%/HTML/Data/imagemap.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/HTML/Data/logo.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/HTML/Data/pic.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/HTML/Data/pic2.bmp
+%%PORTDOCS%%%%EXAMPLESDIR%%/HTML/Data/regres.htm
+%%PORTDOCS%%%%EXAMPLESDIR%%/HTML/Data/tables.htm
+%%PORTDOCS%%%%EXAMPLESDIR%%/HTML/Data/test.htm
+%%PORTDOCS%%%%EXAMPLESDIR%%/HTML/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/HTML/HTML.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/HTML/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/HTML/mondrian.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Hello/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Hello/Hello.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Hello/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/HtmlHelp/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/HtmlHelp/HtmlHelp.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/HtmlHelp/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/HtmlHelp/helpfiles/Index.hhk
+%%PORTDOCS%%%%EXAMPLESDIR%%/HtmlHelp/helpfiles/another.hhc
+%%PORTDOCS%%%%EXAMPLESDIR%%/HtmlHelp/helpfiles/another.hhp
+%%PORTDOCS%%%%EXAMPLESDIR%%/HtmlHelp/helpfiles/another.htm
+%%PORTDOCS%%%%EXAMPLESDIR%%/HtmlHelp/helpfiles/book1.htm
+%%PORTDOCS%%%%EXAMPLESDIR%%/HtmlHelp/helpfiles/book2.htm
+%%PORTDOCS%%%%EXAMPLESDIR%%/HtmlHelp/helpfiles/contents.hhc
+%%PORTDOCS%%%%EXAMPLESDIR%%/HtmlHelp/helpfiles/main.htm
+%%PORTDOCS%%%%EXAMPLESDIR%%/HtmlHelp/helpfiles/page2-b.htm
+%%PORTDOCS%%%%EXAMPLESDIR%%/HtmlHelp/helpfiles/testing.hhp
+%%PORTDOCS%%%%EXAMPLESDIR%%/HtmlListBox/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/HtmlListBox/HtmlListBox.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/HtmlListBox/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/HtmlListBox/mondrian.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Info.plist.in
+%%PORTDOCS%%%%EXAMPLESDIR%%/Internat/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Internat/Internat.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Internat/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Internat/de/internat.mo
+%%PORTDOCS%%%%EXAMPLESDIR%%/Internat/de/internat.po
+%%PORTDOCS%%%%EXAMPLESDIR%%/Internat/fr/internat.mo
+%%PORTDOCS%%%%EXAMPLESDIR%%/Internat/fr/internat.po
+%%PORTDOCS%%%%EXAMPLESDIR%%/Internat/ja
+%%PORTDOCS%%%%EXAMPLESDIR%%/Internat/mondrian.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Internat/ru/internat.mo
+%%PORTDOCS%%%%EXAMPLESDIR%%/Internat/ru/internat.po
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/controlssmall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/dialogssmall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/displaysmall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/dndsmall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/eventdemosmall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/fontsmall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/freecellsmall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/gridsmall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/htmlhelpsmall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/htmllistboxsmall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/htmlsmall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/imgviewsmall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/internatsmall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/listbooksmall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/listctrlsmall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/logo2.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/mdismall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/minimalsmall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/notebooksmall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/printsmall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/sashwindowsmall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/splittersmall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/treectrlsmall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/wizardsmall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/wxd.gif
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps/xrcsmall.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Launcher.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/launcherbottom.html
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/launchertop.html
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/mondrian.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/wxDSamplesLauncher.html
+%%PORTDOCS%%%%EXAMPLESDIR%%/ListCtrl/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/ListCtrl/ListCtrl.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/ListCtrl/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/ListCtrl/bitmaps/small1.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/ListCtrl/bitmaps/toolbrai.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/ListCtrl/bitmaps/toolchar.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/ListCtrl/bitmaps/toolchec.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/ListCtrl/bitmaps/tooldata.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/ListCtrl/bitmaps/toolgame.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/ListCtrl/bitmaps/toolnote.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/ListCtrl/bitmaps/tooltime.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/ListCtrl/bitmaps/tooltodo.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/ListCtrl/bitmaps/toolword.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/ListCtrl/mondrian.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/ListView/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/ListView/ListView.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/ListView/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/ListView/mondrian.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Listbook/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Listbook/Listbook.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Listbook/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Listbook/bmp/toblom01.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Listbook/bmp/toblom02.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Listbook/bmp/toblom03.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Listbook/bmp/toblom04.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Listbook/bmp/toblom05.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Listbook/bmp/toblom06.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Listbook/bmp/toblom07.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Listbook/bmp/toblom08.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Listbook/bmp/toblom09.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Listbook/bmp/toblom10.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Listbook/bmp/toblom11.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Listbook/bmp/toblom12.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Listbook/bmp/toblom13.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Listbook/bmp/toblom14.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Listbook/bmp/toblom15.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Listbook/mondrian.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Mdi/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Mdi/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Mdi/Mdi.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Mdi/bitmaps/copy.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Mdi/bitmaps/cut.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Mdi/bitmaps/help.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Mdi/bitmaps/new.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Mdi/bitmaps/open.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Mdi/bitmaps/paste.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Mdi/bitmaps/preview.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Mdi/bitmaps/print.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Mdi/bitmaps/save.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Mdi/mondrian.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Minimal/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Minimal/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Minimal/Minimal.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Minimal/mondrian.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Notebook/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Notebook/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Notebook/Notebook.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Platform/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Platform/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Platform/Platform.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Printing/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Printing/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Printing/Printing.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Printing/mondrian.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/SashWindow/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/SashWindow/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/SashWindow/SashWindow.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Sound/9000g.wav
+%%PORTDOCS%%%%EXAMPLESDIR%%/Sound/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Sound/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Sound/Sound.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Sound/cuckoo.wav
+%%PORTDOCS%%%%EXAMPLESDIR%%/Sound/doggrowl.wav
+%%PORTDOCS%%%%EXAMPLESDIR%%/Sound/tinkalink2.wav
+%%PORTDOCS%%%%EXAMPLESDIR%%/Splitter/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Splitter/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Splitter/Splitter.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/TreeCtrl/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/TreeCtrl/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/TreeCtrl/TreeCtrl.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/TreeCtrl/icon0.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/TreeCtrl/icon1.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/TreeCtrl/icon2.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/TreeCtrl/icon3.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/TreeCtrl/icon4.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/TreeCtrl/mondrian.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Tutorial/Doc/tutorial.html
+%%PORTDOCS%%%%EXAMPLESDIR%%/Tutorial/Doc/tutorial.jpg
+%%PORTDOCS%%%%EXAMPLESDIR%%/Tutorial/Doc/wxnet.css
+%%PORTDOCS%%%%EXAMPLESDIR%%/Tutorial/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Tutorial/ImageList.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Tutorial/ImageView.bmp
+%%PORTDOCS%%%%EXAMPLESDIR%%/Tutorial/ImageView.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Tutorial/ImageViewer.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Tutorial/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Tutorial/Thumbnail.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Wizard/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Wizard/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Wizard/Wizard.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Wizard/wiztest.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Wizard/wiztest2.png
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/GNUmakefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/Xrcdemo.d
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/appicon.ico
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/appicon.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/artprov.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/artprov.xrc
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/basicdlg.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/basicdlg.xrc
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/controls.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/controls.xrc
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/custclas.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/custclas.xrc
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/derivdlg.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/derivdlg.xrc
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/fileopen.gif
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/filesave.gif
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/frame.xrc
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/fuzzy.gif
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/menu.xrc
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/platform.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/platform.xrc
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/quotes.gif
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/resource.xrc
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/scanning.gif
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/sppicon.ico
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/toolbar.xrc
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/uncenter.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/uncenter.xrc
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/update.gif
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/variable.xpm
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/variable.xrc
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/wxglade.wxg
+%%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc/wxglade.xrc
+%%PORTDOCS%%%%EXAMPLESDIR%%/wxmac.icns
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Xrc/rc
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Xrc
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Wizard
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Tutorial/Doc
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Tutorial
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/TreeCtrl
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Splitter
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Sound
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/SashWindow
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Printing
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Platform
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Notebook
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Minimal
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Mdi/bitmaps
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Mdi
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Listbook/bmp
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Listbook
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/ListView
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/ListCtrl/bitmaps
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/ListCtrl
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Launcher/Bitmaps
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Launcher
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Internat/ru
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Internat/fr
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Internat/de
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Internat
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/HtmlListBox
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/HtmlHelp/helpfiles
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/HtmlHelp
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Hello
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/HTML/Data
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/HTML
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Grid
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/GLCube
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Font
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/EventDemo
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Dnd
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Display
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Dialogs
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Controls/Icons
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%/Controls
+@dirrm %%PORTDOCS%%%%EXAMPLESDIR%%
+@dirrm include/d/wx
+@dirrmtry include/d