aboutsummaryrefslogtreecommitdiff
path: root/x11-toolkits
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2013-10-25 15:08:37 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2013-10-25 15:08:37 +0000
commit12b15603ea8b50dbf2f96b4008c10466c9cf92e6 (patch)
tree515e272581bc61444d06dda1fcb0eda358432051 /x11-toolkits
parent3f28e5234cb6362db2ca3194b106c579d20283c9 (diff)
downloadports-12b15603ea8b50dbf2f96b4008c10466c9cf92e6.tar.gz
ports-12b15603ea8b50dbf2f96b4008c10466c9cf92e6.zip
Notes
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Xaw3d/Makefile2
-rw-r--r--x11-toolkits/Xaw3d/files/patch-Box.c24
2 files changed, 25 insertions, 1 deletions
diff --git a/x11-toolkits/Xaw3d/Makefile b/x11-toolkits/Xaw3d/Makefile
index bbb8c3bbb9db..c6e7e008053a 100644
--- a/x11-toolkits/Xaw3d/Makefile
+++ b/x11-toolkits/Xaw3d/Makefile
@@ -3,7 +3,7 @@
PORTNAME= Xaw3d
PORTVERSION= 1.5E
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= x11-toolkits
MASTER_SITES= ftp://ftp.visi.com/users/hawkeyd/X/ \
ftp.slackware.com/pub/slackware/slackware_source/x/xaw3d/
diff --git a/x11-toolkits/Xaw3d/files/patch-Box.c b/x11-toolkits/Xaw3d/files/patch-Box.c
new file mode 100644
index 000000000000..53cfe5b80905
--- /dev/null
+++ b/x11-toolkits/Xaw3d/files/patch-Box.c
@@ -0,0 +1,24 @@
+*** Box.c~ 1996-10-15 10:41:18.000000000 -0400
+--- Box.c 2007-04-21 14:12:44.000000000 -0400
+***************
+*** 353,360 ****
+ else {
+ width = preferred_width;
+ do { /* find some width big enough to stay within this height */
+! width *= 2;
+! if (width > constraint->width) width = constraint->width;
+ DoLayout(w, width, 0, &preferred_width, &preferred_height, FALSE);
+ } while (preferred_height > constraint->height &&
+ width < constraint->width);
+--- 353,363 ----
+ else {
+ width = preferred_width;
+ do { /* find some width big enough to stay within this height */
+! if (width > constraint->width/2) /* avoid short int overflow */
+! width = constraint->width;
+! else
+! width *= 2;
+!
+ DoLayout(w, width, 0, &preferred_width, &preferred_height, FALSE);
+ } while (preferred_height > constraint->height &&
+ width < constraint->width);